AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Active Member
mcanta
Posts: 6
Registered: ‎11-28-2012
Message 1 of 7 (329 Views)

Labels not plotting correctly

329 Views, 6 Replies
11-28-2012 09:42 AM

Hello.  I'm using Civil 3D 2012.  When it generates labels (alignment stationing, profile station & elevation, etc.), it keeps generating them in layer 0.  It does not matter how I change the styles to the layer that I want. 

 

It allows me to change the properties of the labels to the layer that I want after the labels have been generated.  They look ok on my computer screen.

 

However, when I plot the plans, the labels do not follow the lineweights that the layer should be on.  I think it still plotting as if it was layer 0. 

 

If I explode the labels, I can get them to plot correctly by changing the layer.  

 

Any ideas? 

*Expert Elite*
tcorey
Posts: 2,598
Registered: ‎12-18-2002
Message 2 of 7 (325 Views)

Re: Labels not plotting correctly

11-28-2012 09:59 AM in reply to: mcanta

On the Settings tab of Toolspace, find your drawing name. Right click and select Edit Drawing Settings. Go to the Object Layers tab.

 

There is a good reason for this two-level layer scheme. For example, it allows you to freeze all Surface label layers at once by freezing the layer set in Drawing Settings. To freeze individual Surface label styles, you freeze that style's particular layer as set on the General tab of the Label Style Composer.

 

 

Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
*Expert Elite*
troma
Posts: 2,520
Registered: ‎05-21-2008
Message 3 of 7 (322 Views)

Re: Labels not plotting correctly

11-28-2012 10:01 AM in reply to: mcanta

I think you may be running into the difference between the object layer; that the label is actually on (shows up in layer toolbar/properties when label is selected) and the style layer, which is set in the label style (and which should control what the label looks like on screen and on paper).

 

However, I don't know why it would look good on screen but not on paper.

 

The style layer you can change in the style and all labels will update.

The object layer you can change by selecting the object and putting it on whatever layer.  You can also set the default for this by going into toolspace>settings, right-clicking on your drawing name and going to the layers tab.


Credit where credit is due! Give kudos or accept as solution whenever you can.

*Expert Elite*
troma
Posts: 2,520
Registered: ‎05-21-2008
Message 4 of 7 (321 Views)

Re: Labels not plotting correctly

11-28-2012 10:02 AM in reply to: tcorey

Tim you're a faster typer than me!


Credit where credit is due! Give kudos or accept as solution whenever you can.

*Expert Elite*
tcorey
Posts: 2,598
Registered: ‎12-18-2002
Message 5 of 7 (316 Views)

Re: Labels not plotting correctly

11-28-2012 10:14 AM in reply to: troma

troma wrote:

Tim you're a faster typer than me!


I'd be faster if I didn't always go five forward, two back...:smileywink:

Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
Active Member
mcanta
Posts: 6
Registered: ‎11-28-2012
Message 6 of 7 (314 Views)

Re: Labels not plotting correctly

11-28-2012 10:22 AM in reply to: tcorey

Thanks for the quick reply.  After changing the object layer where you suggested (both in my Xref file and Sheet file), it's still not plotting correctly.

 

I should say that under, "Label Style Composer," the preview screen shows the stationing label as a white color no matter what changes I do to the layer, lineweight, and color settings under the general tab, layout tab (contents/format tab), and summary tab (label).

 

 

Valued Contributor
C3D_TomR
Posts: 61
Registered: ‎07-01-2010
Message 7 of 7 (267 Views)

Re: Labels not plotting correctly

11-30-2012 03:16 PM in reply to: mcanta

Check for ByLayer vs ByBlock in the components of the style.

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.