AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Contributor
kdixon
Posts: 22
Registered: ‎10-26-2006
Message 1 of 4 (283 Views)
Accepted Solution

Label Style Overides Not Working

283 Views, 3 Replies
01-08-2013 10:24 AM

I am having trouble getting my Styles to display on the correct layer.

I want my Contour Label to display on Layer C3D-CONT-LABEL as set in the Style. It is being placed on C3D-SRF-LBLS wich is the Object Layer.

It seems my Overrides are not working.

What am I missing about the Hierarchy? I have attached some screen shots of my settings for Contour Labels.

Please help, this is driving me crazy.

 

Kirk Dixon

Windows 7 64 Bit

Intel(R) Core(TM) i7

860 @ 2.8 GHz

16 GB Ram

NVIDIA Quadro FX 1800

 

 

The settings you posted are the Label Style for an individual label and the Label Style Defaults that control the default settings for when you make a new label.  The layer set in the label style controls the look of the label, it's display.  But the label as an object is placed on the label object layer.

 

Think of the label as a block.  There is text on one layer.  This is made into a block.  The block is inserted on a different layer.  Similarly the label displays the colour of one layer, but is actually on a different layer.

 

Have you tried messing with the object layers?  Toolspace > Settings.  Right-click on the drawing name > Edit drawing settings > Object Layers

*Expert Elite*
troma
Posts: 2,524
Registered: ‎05-21-2008
Message 2 of 4 (279 Views)

Re: Label Style Overides Not Working

01-08-2013 10:43 AM in reply to: kdixon

The settings you posted are the Label Style for an individual label and the Label Style Defaults that control the default settings for when you make a new label.  The layer set in the label style controls the look of the label, it's display.  But the label as an object is placed on the label object layer.

 

Think of the label as a block.  There is text on one layer.  This is made into a block.  The block is inserted on a different layer.  Similarly the label displays the colour of one layer, but is actually on a different layer.

 

Have you tried messing with the object layers?  Toolspace > Settings.  Right-click on the drawing name > Edit drawing settings > Object Layers


Credit where credit is due! Give kudos or accept as solution whenever you can.

Contributor
kdixon
Posts: 22
Registered: ‎10-26-2006
Message 3 of 4 (218 Views)

Re: Label Style Overides Not Working

01-15-2013 06:07 PM in reply to: troma
Thank You for your reply, Yes, Under Drawing Settings, Object layers - Tin Surface-Labeling, C3D-SRF-LBLS-, this where all of my Surface Labels are going. So these labels are being controlled by 2 layers? What about Label Style Defaults? You can set them under Drawing Settings and for individual Features. I'm confused as to how these work. Thanks Again, [KRD-EMAIL SIG]
*Expert Elite*
troma
Posts: 2,524
Registered: ‎05-21-2008
Message 4 of 4 (213 Views)

Re: Label Style Overides Not Working

01-16-2013 05:43 AM in reply to: kdixon

When you create a new label it has certain settings, the 'default' settings.  Things like layers, text height, dragged state settings; the whole works.  These are set by the 'Label Style Defaults'.

I only see Label Style Defaults when I click on the heading above the labels in Toolspace > Settings.  I'm working in 2011.  What version are you in and where exactly are you seeing the same thing twice?


Credit where credit is due! Give kudos or accept as solution whenever you can.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.