AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Valued Contributor
bo.martin
Posts: 65
Registered: ‎06-12-2010
Message 1 of 9 (707 Views)
Accepted Solution

GEO Tiff Issue

707 Views, 8 Replies
10-08-2012 09:06 AM

C3D 2013

Win 7 64 Bit (or Win 8 64 Bit Same Problem)

 

When I insert a geo ref tif image it's not recogonizing the world file.

I've check the image reference and the world file and they match.

 

Here is my world file:

 

0.500000000000000
0.000000000000000
0.000000000000000
-0.500000000000000
1841129.250000000000000
186743.750000000000000

 

The wierder part is that if I scale the image by .3048 (Meters to feet correction)

and paste the world file cooridnates It comes in as if the world file is referencing the

SW corner of the tiff, not the NW cor that is specified in the world file.

Suggestions?

My zone and units are set correctly also.

 

TIA

 

Bo

 

 


bo.martin wrote:

C3D 2013

Win 7 64 Bit (or Win 8 64 Bit Same Problem)

 

When I insert a geo ref tif image it's not recogonizing the world file.

I've check the image reference and the world file and they match.

 

Here is my world file:

 

0.500000000000000
0.000000000000000
0.000000000000000
-0.500000000000000
1841129.250000000000000
186743.750000000000000

 

The wierder part is that if I scale the image by .3048 (Meters to feet correction)

and paste the world file cooridnates It comes in as if the world file is referencing the

SW corner of the tiff, not the NW cor that is specified in the world file.

Suggestions?

My zone and units are set correctly also.

 

TIA

 

Bo

 

 


Check out my post in the Map group.

 

http://forums.autodesk.com/t5/AutoCAD-Map-3D/Civil-3D-2013-Map-2013-Image-Issue/td-p/3415105

 

There is a "new feature" in 2013 where Map tries to reproject an image on import by reading the embedded or external world file.  The problem is, Autodesk ignores the map units.  I had a SR regarding this and Autodesk doesn't feel it's a bug, but the outcome means that all of the State of Tennessee's aerial images won't come into the drawing correctly.  No other GIS program misreads the coordinate system of the files, it's just Autodesk's 2013 software.  

 

What we have to do, which will probably happen from now on, is to turn off the drawing's coordinate system, insert the image (MAPIINSERT will ignore the projection information if no coordinate system is set and will just read the raw X,Y, and scale like it always did before), then turn back on the coordinate system.  This is a horribly time consuming process when I deal almost daily with orthophotos, but Autodesk has given us no choice. 

 

This is also the reason that only two of us in the office are using 2013.  This has been the most problamatic release we've ever used and the first that we've never fully upgraded to.  I have my doubts as to whether 2014 or even 2015 will fix this problem given Autodesk's track record.

Setting the dwg to No Datum, No Projection worked.

Easy fix!!!!!

 

One would hope this will be fixed in the 1st service pack.

 

Thanks!!

*Expert Elite*
tcorey
Posts: 2,761
Registered: ‎12-18-2002
Message 2 of 9 (697 Views)

Re: GEO Tiff Issue

10-08-2012 10:22 AM in reply to: bo.martin

Maybe you're using the AutoCAD Image attach function instead of the AutoCAD Map Mapiinsert command. AutoCAD's does not read the world file.

Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
Valued Contributor
bo.martin
Posts: 65
Registered: ‎06-12-2010
Message 3 of 9 (692 Views)

Re: GEO Tiff Issue

10-08-2012 10:53 AM in reply to: tcorey

Using mapiinsert

Modify Corelation Checked

*Expert Elite*
antoniovinci
Posts: 1,780
Registered: ‎06-03-2011
Message 4 of 9 (683 Views)

Re: GEO Tiff Issue

10-08-2012 11:28 AM in reply to: bo.martin

Are you 100% sure that image and worldfile have the same identical name, e.g. BOMARTIN.TIF and BOMARTIN.TFW..?

If so, try to embed the worldfile inside the image, by means of the free tool GeotiffExaminer by Mentor Software, then erase the worldfile .TFW and issue again the _MAPIINSERT command: any changes?

 

P.S.

A pair TIF+TFW is not a Geotiff, sir.

Valued Contributor
bo.martin
Posts: 65
Registered: ‎06-12-2010
Message 5 of 9 (674 Views)

Re: GEO Tiff Issue

10-08-2012 12:01 PM in reply to: antoniovinci

Been There, Done that.

Using GeotiffExaminer the ref in the tif file matches the twf world file.

 

WIll try again after I weed my way through a 100 page title policy.

Argh. Sometimes I hate ALTA Surveys.

 

 

 

 

 

*Expert Elite*
antoniovinci
Posts: 1,780
Registered: ‎06-03-2011
Message 6 of 9 (639 Views)

Re: GEO Tiff Issue

10-08-2012 10:42 PM in reply to: bo.martin

If you can't solve your issue, feel free to share with us that .TIF (zipped, please): you may take a look at it.

Valued Mentor
engrtech
Posts: 762
Registered: ‎05-05-2008
Message 7 of 9 (623 Views)

Re: GEO Tiff Issue

10-09-2012 07:00 AM in reply to: bo.martin

bo.martin wrote:

C3D 2013

Win 7 64 Bit (or Win 8 64 Bit Same Problem)

 

When I insert a geo ref tif image it's not recogonizing the world file.

I've check the image reference and the world file and they match.

 

Here is my world file:

 

0.500000000000000
0.000000000000000
0.000000000000000
-0.500000000000000
1841129.250000000000000
186743.750000000000000

 

The wierder part is that if I scale the image by .3048 (Meters to feet correction)

and paste the world file cooridnates It comes in as if the world file is referencing the

SW corner of the tiff, not the NW cor that is specified in the world file.

Suggestions?

My zone and units are set correctly also.

 

TIA

 

Bo

 

 


Check out my post in the Map group.

 

http://forums.autodesk.com/t5/AutoCAD-Map-3D/Civil-3D-2013-Map-2013-Image-Issue/td-p/3415105

 

There is a "new feature" in 2013 where Map tries to reproject an image on import by reading the embedded or external world file.  The problem is, Autodesk ignores the map units.  I had a SR regarding this and Autodesk doesn't feel it's a bug, but the outcome means that all of the State of Tennessee's aerial images won't come into the drawing correctly.  No other GIS program misreads the coordinate system of the files, it's just Autodesk's 2013 software.  

 

What we have to do, which will probably happen from now on, is to turn off the drawing's coordinate system, insert the image (MAPIINSERT will ignore the projection information if no coordinate system is set and will just read the raw X,Y, and scale like it always did before), then turn back on the coordinate system.  This is a horribly time consuming process when I deal almost daily with orthophotos, but Autodesk has given us no choice. 

 

This is also the reason that only two of us in the office are using 2013.  This has been the most problamatic release we've ever used and the first that we've never fully upgraded to.  I have my doubts as to whether 2014 or even 2015 will fix this problem given Autodesk's track record.

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
Valued Contributor
bo.martin
Posts: 65
Registered: ‎06-12-2010
Message 8 of 9 (604 Views)

Re: GEO Tiff Issue

10-09-2012 03:35 PM in reply to: engrtech

Setting the dwg to No Datum, No Projection worked.

Easy fix!!!!!

 

One would hope this will be fixed in the 1st service pack.

 

Thanks!!

*Expert Elite*
LisaPohlmeyer
Posts: 601
Registered: ‎01-14-2009
Message 9 of 9 (585 Views)

Re: GEO Tiff Issue

10-10-2012 05:30 AM in reply to: bo.martin

Wow, what a horrible way to have to "work around" an issue that was never an issue before.  I'm glad you figured it out.  It has been one of the many reasons we haven't moved to 2013. Thanks for sharing, I'll add this solution to my list.

Lisa Pohlmeyer

C3D 2012 SP4, C3D 2015
Please use "Accept as Solution" if this solved your issue.
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.