AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Member
3 Posts
0 Kudos
Registered: ‎07-01-2013
Post 1 of 7
Accepted Solution

Drawing 3d Polylines from points not working...

620 Views, 6 Replies
07-01-2013 03:43 PM

I have points in a 2012 C3D drawing and I am looking to draw 3d polylines from point to point.  Ultimately I am wanting to generate breaklines for a surface from a topo.  I was able to do this a few months ago and now no matter what I try nothing seems to work.  When use the 3P command the Z Vertex is 0.  All of the points in the drawing have elevations. I tried drawing a feature line however, the beginning elevation is saying 0.  Its as if these lines do not recognize my points as having elevations.  If anyone has a solution it would be greatly appreciated... 

Have you checked the point style that is applied to those points to see if the Z is being flattened?
Distinguished Contributor
209 Posts
7 Kudos
Registered: ‎12-07-2006
Post 2 of 7

Re: Drawing 3d Polylines from points not working...

07-01-2013 05:57 PM in reply to: PLS22395

Check your OSNAPZ value.

 

0 = Osnap uses the Z-value of the specified point

1 = Osnap substitutes the Z-value of the specified point with the elevation (ELEV) set for the current UCS

*Expert Elite*
2,804 Posts
288 Kudos
Registered: ‎07-09-2003
Post 3 of 7

Re: Drawing 3d Polylines from points not working...

07-01-2013 08:45 PM in reply to: PLS22395
Have you checked the point style that is applied to those points to see if the Z is being flattened?
Matt Kolberg
Cansel - Autodesk Division
http://www.cansel.ca/
Member
3 Posts
0 Kudos
Registered: ‎07-01-2013
Post 4 of 7

Re: Drawing 3d Polylines from points not working...

07-02-2013 07:13 AM in reply to: mathewk

Thats exactly what it was, Thank you!

Mentor
180 Posts
5 Kudos
Registered: ‎04-19-2007
Post 5 of 7

Re: Drawing 3d Polylines from points not working...

08-14-2013 01:17 PM in reply to: mathewk
Mark where do you check that? I cannot find the z setting. is it in commands under point style settings????
Member
3 Posts
0 Kudos
Registered: ‎07-01-2013
Post 6 of 7

Re: Drawing 3d Polylines from points not working...

08-15-2013 07:24 AM in reply to: elaine3051

Yes it is, click on any point, right click go to point group settings, pull the tab down right of the style, click edit current, go to the 3d geometry then you can select to flatten points to an elevation or use the point elevation. 

*Expert Elite*
2,539 Posts
267 Kudos
Registered: ‎05-21-2008
Post 7 of 7

Re: Drawing 3d Polylines from points not working...

08-15-2013 02:03 PM in reply to: elaine3051
In other words, not commands, but the point style itself.


Credit where credit is due! Give kudos or accept as solution whenever you can.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!