AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
*Expert Elite*
tcorey
Posts: 2,765
Registered: ‎12-18-2002
Message 1 of 6 (435 Views)

Curve tag labels populate with ???

435 Views, 5 Replies
07-02-2012 09:40 AM

Civil 3D 2013. This is happening to a client and I have confirmed the issue in my office using his drawing and new drawings created from acad.dwt or the civil 3d imperial ncs template.

 

Create a curve tag label style, label a curve, and the label says ???. If you edit the label style, go to the layout tab, change the preview from curve label style to line label style and then back to curve label style, sometimes the label changes to show the tag number, but like once out of thirty tries. If the preview updates correctly, the tags in the drawing will update as well, now showing numbers.

 

I have found the same behavior with parcel curve labels.

 

Has anyone else seen this? Did you find a fix?

 

Thanks in advance,

 

Tim



Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
*Expert Elite*
BrianHailey
Posts: 2,858
Registered: ‎04-27-2005
Message 2 of 6 (428 Views)

Re: Curve tag labels populate with ???

07-02-2012 10:13 AM in reply to: tcorey

Not really a fix but a different way of doing things. I never create a label style that starts out as a tag. I label in the drawing with some information and then when I create the table I have it convert the labels to tags. Do you still see the issue if you do it this way?

Brian Hailey
CAD-1.com
My Blog
*Expert Elite*
TRogers
Posts: 1,390
Registered: ‎09-05-2007
Message 3 of 6 (410 Views)

Re: Curve tag labels populate with ???

07-02-2012 12:22 PM in reply to: tcorey

I have had a few calls about this issue.  @Brian, yes it still happens.  Example, if i have a curve and a line, I grab the diamond grip and drag the tag past the end of the curve, then back and they turn into ???.  See below...

 

tags.gif

If the issue was resolved by this method, please click on "Accept As Solution"
*Civil 3DJ*
Todd Rogers

Visit my blog here.

     
*Expert Elite*
BrianHailey
Posts: 2,858
Registered: ‎04-27-2005
Message 4 of 6 (403 Views)

Re: Curve tag labels populate with ???

07-02-2012 12:56 PM in reply to: TRogers

A possible workaround, select the labels, change them to the parent style, then back to the child style.

 

http://screencast.com/t/53h3ANjx4

Brian Hailey
CAD-1.com
My Blog
*Expert Elite*
tcorey
Posts: 2,765
Registered: ‎12-18-2002
Message 5 of 6 (369 Views)

Re: Curve tag labels populate with ???

07-04-2012 11:37 AM in reply to: tcorey

Thanks for the replies. I'll follow up with Autodesk to make sure they know about this behavior.

 

 

Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
Valued Mentor
IanMcClain
Posts: 469
Registered: ‎09-29-2008
Message 6 of 6 (297 Views)

Re: Curve tag labels populate with ???

01-14-2013 03:37 PM in reply to: tcorey

I just came across this same issue in an old drawing. It turned out that curve tag label style was defined in "Label mode" and not "Tag mode". After I change that it behaved as expected.

-Ian McClain
(running C3D 2012 sp4, Win7 64bit, 8GB)
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.