AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Contributor
TheJabberwocky
Posts: 17
Registered: ‎05-29-2012
Message 1 of 5 (204 Views)

Alignment from object issues

204 Views, 4 Replies
11-19-2013 08:16 PM

Just in the last few days I have started having issues when creating alignments from objects.

 

I am building roads from plans for setout on site, I receive 2d linework and need to build the 3d road up. I join the required linework into a polyline so I can make a few checks that the lengths and so on are correct before I continue. Then usually I would just go and make an alignment from the polyline.

 

eg Monday I was setting up 3 intersections and dealing with 6 kerb returns on there. The first 2 created correctly, then when I created the 3rd one I couldn't see it. Then when I did zoom extents it was way off to the left and a mirror of the linework I was trying to create it from. It did it to a further 2 of them and the other 2 came out correctly.

 

Now it is doing to me when trying to create a centreline.

 

Is there some issues with what I am doing or what is going on?

Mentor
PorterCAD
Posts: 179
Registered: ‎01-09-2007
Message 2 of 5 (186 Views)

Re: Alignment from object issues

11-20-2013 04:05 AM in reply to: TheJabberwocky
Just curious...do either if your polylines have elevations to them (3D polylines)?
Jason Porter
Enceptia Technical Advisor & Civil Solutions Blogger
http://enceptia.com/author/jporter/
Distinguished Contributor
Hammer.john.j
Posts: 133
Registered: ‎05-06-2008
Message 3 of 5 (178 Views)

Re: Alignment from object issues

11-20-2013 06:22 AM in reply to: TheJabberwocky
Recommend tracing the lines and arcs with the alignment creation tools because sometimes the pljoin adds 0 length lines at the joint.... plus with the alignment creation tools you have more flexibility with the curves and you can be certain everything is tangential. I understand you are receiving the 2d linework, but you can place that on a non-plotting or design layer and trace over it with alignment creation tools and avoid problems with alignments from objects.
John Hammer, LA
Dell Precision T3500 - Xenon W3550 @ 3.07 (4 core)
Ram @ 12Gb
64bit Win7 Pro
Samsung SSD
NVIDIA Quadro 2000 - Dual Monitors
Cat 6 network with GlobalScape Avail Agent - WAFS
Infrastructure Design Suite Premium and Civil 3D 2012 & 2014
Contributor
TheJabberwocky
Posts: 17
Registered: ‎05-29-2012
Message 4 of 5 (156 Views)

Re: Alignment from object issues

11-21-2013 02:08 PM in reply to: Hammer.john.j

Figured out what the issue was.

 

It was this annoying "Normal Z Value" thing being -1 for those arcs which were causing issues.

 

And to answer the question I create all my alignments from 2d data. I would so much prefer receiving 3d data, but that does not happen very often at all. They are too concerned that the data they might send will differ from the plans and I will use it without checking it first. Maybe they should just get it right in the first place.

*Expert Elite*
mikeevans
Posts: 816
Registered: ‎09-29-2008
Message 5 of 5 (134 Views)

Re: Alignment from object issues

11-22-2013 09:31 AM in reply to: TheJabberwocky
As John says. You are better to trace & recreate the alignment than to convert.

Converting the polyline does not create co-joined intelligent alignments which maintain correct tangency etc.

You can't drag and adjust the converted alignment PVI nodes like you can a dynamic alignment.
Mike Evans

Civil3D 2013 / 2014 British UK
Windows 7 Professional 64-bit
Intel(R) Core(TM) i7-3820 CPU @ 3.60GHz (8 CPUs), ~4.0GHz With 32768MB RAM, AMD FirePro V4900, Dedicated Memory: 984 MB, Shared Memory: 814 MB

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.