AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Valued Mentor
778 Posts
67 Kudos
Registered: ‎05-05-2008
Post 1 of 4

Alignment color/weight in Viewport Different than Model Space and Style (2013)

1046 Views, 3 Replies
02-19-2013 07:15 AM

I'm having a very annoying problem where the color and lineweight of my alignment in a viewport is not what it's set to be. I have an alignment with a style that sets all the linework components to a layer named C-STRM-CNTR-N, the color is set to BYLAYER, the linetype set to Continuous, and lineweight set to .80mm (see style_and_layer_screenshots.png). The layer C-STRM-CNTR-N has Cyan as the color, which shows in the Alignment Style dialog box (see style_and_layer_screenshots.png). In the model space everything looks fine (see c3d_model_space_screenshot.png). But in my layout, the alignment is a different color and lineweight (see c3d_layout_screenshot.png). 

 

At first I thought maybe the alignment wasn't on the correct layer, but I checked and it's set correctly. Then I checked to see if the layer C-STRM-CNTR-N had a different color set for the viewport through the layer manager, but it's set to Cyan just like it's supposed to be. I went to the model space and noticed the color is correct. Frustrated and at a loss, I closed C3D, then reopened it and the problem is still there.

 

Anyone know why I can't change the lineweight nor the color of the alignment in this viewport? If I change either of those two settings in the Alignment Style Dialog box nothing changes, but the linetype does change.  What the heck is going on?

 

 

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
New Member
2 Posts
0 Kudos
Registered: ‎10-03-2006
Post 2 of 4

Re: Alignment color/weight in Viewport Different than Model Space and Style (201

02-20-2013 10:15 AM in reply to: engrtech

We are having the same issue with Civil 3D 2012.  The appears to be drawing specific and opening on another workstations does not change the display.

Civil 3D 2012 x64
Win 7 64Bit
24Gb RAM
Member
4 Posts
0 Kudos
Registered: ‎08-15-2012
Post 3 of 4

Re: Alignment color/weight in Viewport Different than Model Space and Style (201

09-05-2013 12:16 PM in reply to: engrtech

I just ran into this with Civil 3D 2012 on a drawing made in 2010.  I fixed this by making a new alignment style that was exactly the same as before and it worked. Hope this helps!

Valued Mentor
778 Posts
67 Kudos
Registered: ‎05-05-2008
Post 4 of 4

Re: Alignment color/weight in Viewport Different than Model Space and Style (201

09-06-2013 06:55 AM in reply to: engrtech

I found the problem. If you use a color that is not on the ACAD pallet the colors will not work correctly. For instance, I had a color that was a true color instead of a standard ACAD color, which causes it not to show up correctly. I changed the color to a non-true color and it worked.

 

I haven't checked to see if this is fixed in 2014 as I quit using any colors that weren't part of the standard pallet. 

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!