AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Active Member
jroot
Posts: 9
Registered: ‎09-21-2005
Message 1 of 5 (460 Views)
Accepted Solution

2014 Slow Dimensions

460 Views, 4 Replies
09-03-2013 04:33 AM

In 2014 when we create dimensions (aligned usually) or even move or edit them it seems to hang and take about 30 seconds to perform the command.  In a blank new drawing this seems to go quicker.  In one drawing that had a large surface I LandXMLout the surface and brought it back in and the dimensioning became faster.

Has anyone else had this problem or can think of why this would be?

VBA is not loaded, we're all running 64bit on W7 with 8GB+ RAM.  Video cards are ATI Firepro 4900.  We did not have this problem on the same hardware with C3D 2011.  I have tried tweaking hardware acceleration with no improvement.

 

Thank you for your help,

 

-Joe

We finally figured this out.  For some reason it was hanging due to the block "arrow1" we were using as the arrowhead on out dimensions.  This block has been used for probably 10 years in our drawings.

-It worked just fine in C3D 2011

-It’s only slow when there is a surface

-Leaders also use “arrow1” but are not slow at all

 

I replaced this block with the same exact arrowhead but as an annotative block and there is no more hanging.

*shrug*

Mentor
john.mckenzie
Posts: 222
Registered: ‎12-19-2006
Message 2 of 5 (425 Views)

Re: 2014 Slow Dimensions

09-04-2013 06:10 AM in reply to: jroot

Since xml'ing the surface improved perfomance of dimensioning, I suspect you may have an issue with that surface. Is this problem consistent in all drawings with all surfaces or is it isolated to this one surface causing performance issues?

Active Member
jroot
Posts: 9
Registered: ‎09-21-2005
Message 3 of 5 (416 Views)

Re: 2014 Slow Dimensions

09-04-2013 06:22 AM in reply to: john.mckenzie

It seems to be this way in drawings that *have* surfaces, but not every one.  In drawings without surfaces it seems to be fine.  Maybe this is a coincidence that I've found from trying to figure out the problem.

Mentor
john.mckenzie
Posts: 222
Registered: ‎12-19-2006
Message 4 of 5 (414 Views)

Re: 2014 Slow Dimensions

09-04-2013 06:29 AM in reply to: jroot

Then I suspect that it has much more to do with the surfaces than anything.

 

You might want to simplify the surface style as much as possible in case it is an issue with stressing the video card.

 

levelofdetailon typed at the command prompt can help with video card stress, but can cause other issues so use that with caution.

 

Would it help to have the surfaces in another file and data reference them into the file that you are annotating in?

OR xref the surface in from a file that it is properly represented in. ie: right style/scale/rotation/etc.

 

I would explore the workflow and approach through some of these ideas and see if you can hone in on a better way to approach the problem.

 

Big surfaces are resource hogs and depending upon how you are using them they can be real pigs.

 

just throwing out guesses.

Active Member
jroot
Posts: 9
Registered: ‎09-21-2005
Message 5 of 5 (359 Views)

Re: 2014 Slow Dimensions

10-17-2013 11:17 AM in reply to: jroot

We finally figured this out.  For some reason it was hanging due to the block "arrow1" we were using as the arrowhead on out dimensions.  This block has been used for probably 10 years in our drawings.

-It worked just fine in C3D 2011

-It’s only slow when there is a surface

-Leaders also use “arrow1” but are not slow at all

 

I replaced this block with the same exact arrowhead but as an annotative block and there is no more hanging.

*shrug*

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.