AutoCAD Civil 3D Customization

AutoCAD Civil 3D Customization

Reply
Active Contributor
JonRusk
Posts: 47
Registered: ‎12-16-2008
Message 1 of 5 (238 Views)
Accepted Solution

expressions losing custom pipe property reference

238 Views, 4 Replies
06-28-2012 02:01 PM

Is anyone else having problems using custom pipe properties in pipe label expressions in 2013? I have some expressions relating to stub callouts and the ones that directly reference the custom properties lose that reference every so often.

 

For example I have and expression called "STUB-Riser-Length2d" which is defined as "{Riser Length} / SQRT(2)" where "Riser Length" is the custom pipe property. Every week or so it changes to "/ SQRT(2)".

 

I haven't been able to find the pattern as to exactly when this happens yet. All expressions not referencing custom properties seem to be holding steady. The pipe catalog is on a shared drive on the network, if that makes any difference.

Civil 3D 2013 - Windows 7 Pro 64 - Dell T3500 - Xeon 2.67 - 24gb - Quadro 600

Ok, I think I found it... the drawing that is opened when Autocad starts loses the custom references 100% of the time. So if I just straight start Autocad, drawing1 breaks. If I double click a DWG in windows explorer when Autocad is closed, that drawing breaks. If I then close that drawing without saving and reopen it then it still has the references.

 

Product Support
SethHall
Posts: 723
Registered: ‎02-08-2010
Message 2 of 5 (219 Views)

Re: expressions losing custom pipe property reference

07-02-2012 09:45 AM in reply to: JonRusk

Does anything change with the catalog?

If you go in and check that part does that property still exist?

I wonder if PARTCATALOGREGEN is triggering this... do you recall running this command around the time the expression disappears?



Seth Hall
Product Support
GCSO - CSS - FTS
Autodesk, Inc.


Being Civil
Being Civil Twitter
Being Civil Facebook







Active Contributor
JonRusk
Posts: 47
Registered: ‎12-16-2008
Message 3 of 5 (214 Views)

Re: expressions losing custom pipe property reference

07-02-2012 02:47 PM in reply to: SethHall

The part catalog has 'non-standard' pipes but they are just the stock pipes with the names and descriptions changed. It hasn't been changed in weeks.

 

The custom properties always are in the pipe properties.

 

PARTCATALOGREGEN doesn't seem to affect it.

 

I thought maybe losing network connection would trigger it, it did once, after saved and reopened, but can't replicate it.

 

 

 

 

Civil 3D 2013 - Windows 7 Pro 64 - Dell T3500 - Xeon 2.67 - 24gb - Quadro 600
Active Contributor
JonRusk
Posts: 47
Registered: ‎12-16-2008
Message 4 of 5 (213 Views)

Re: expressions losing custom pipe property reference

07-02-2012 03:21 PM in reply to: SethHall

Ok, I think I found it... the drawing that is opened when Autocad starts loses the custom references 100% of the time. So if I just straight start Autocad, drawing1 breaks. If I double click a DWG in windows explorer when Autocad is closed, that drawing breaks. If I then close that drawing without saving and reopen it then it still has the references.

 

Civil 3D 2013 - Windows 7 Pro 64 - Dell T3500 - Xeon 2.67 - 24gb - Quadro 600
Active Contributor
JonRusk
Posts: 47
Registered: ‎12-16-2008
Message 5 of 5 (157 Views)

Re: expressions losing custom pipe property reference

07-31-2012 07:06 AM in reply to: SethHall

So I assume this is a bug then, and you guys are working on it?

Civil 3D 2013 - Windows 7 Pro 64 - Dell T3500 - Xeon 2.67 - 24gb - Quadro 600
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.