AutoCAD 2013/2014/2015

AutoCAD 2013/2014/2015

Reply
Valued Contributor
56 Posts
5 Kudos
Registered: ‎11-11-2008
Post 1 of 42
Accepted Solution

xrefs not loading

17615 Views, 41 Replies
04-03-2012 10:06 AM

about half of our xrefs are "unresolved" in AutoCAD 2013 that work fine in AutoCAD 2012.  I hope that there is a global fix for this as we certainly do not want to have to go fix hundreds of xrefs files around the network.

This issue is listed among the things fixed by Service Pack 1.1 for AutoCAD 2013.  Here is the line item from the service pack's readme file:

 

External Reference (XREF)

  • External reference drawings (XREFs) show as unresolved in AutoCAD 2013

The service pack is available here:

 

AutoCAD 2013 Service Pack 1.1

http://usa.autodesk.com/getdoc/id=DL20327837

 

AutoCAD LT 2013 Service Pack 1.1

http://usa.autodesk.com/getdoc/id=DL20327876

sue
New Member
1 Posts
0 Kudos
Registered: ‎04-03-2012
Post 2 of 42

Re: xrefs not loading

04-03-2012 11:45 PM in reply to: bcampbell

Had 2013 now for less than a day and none of our existing XREF's work, they all read as UNRESOLVED.

 

In the XREF menu the preview shows the full image but nothing shows in model space.

Member
4 Posts
0 Kudos
Registered: ‎04-05-2012
Post 3 of 42

Re: xrefs not loading

04-05-2012 12:50 PM in reply to: bcampbell

I'm having the same issue...

 

I still have 2012 installed and I open it up and it works fine. Then, I open it up in 2013 and all of the Xrefs are "unresolved" or "unreferenced".

 

PLEASE HELP!

Product Support
324 Posts
35 Kudos
Registered: ‎11-01-2005
Post 4 of 42

Re: xrefs not loading

04-05-2012 01:17 PM in reply to: craig_jacobson

From your screen capture, there are at least two DWG references which did get loaded, and some image references which also resolved.  This brings up a few questions:

 

  • Are the DWGs which are not resolving located in the same directories as the DWG and image references which are loading?
  • Are the DWGs which are resolving a different DWG file version (2004, 2007, 2010, etc.) than those which are not?
  • Are the external reference files located on your own hard drive or are they on a network share?
  • Are the external references relatively pathed or full pathed?  You can tell by selecting one in the External References palette, and then look to see if the "Saved Path" starts with a ... or with a \\ or drive letter.  If it's ... then it is a relative path.

As a test, try copying all of those reference files and paste them into a local folder on your workstation which also contains the parent drawing, 12010-A1.dwg.  Then, close AutoCAD, reopen it, and open 12010-A1 from that local directory and see what happens.  Please answer the above questions and post the results of the proposed test in this thread.



Zac Travis
Valued Contributor
56 Posts
5 Kudos
Registered: ‎11-11-2008
Post 5 of 42

Re: xrefs not loading

04-05-2012 01:34 PM in reply to: zalant

I have the same issue, some drawings work, some dont.  So here are my results:

 

  • Are the DWGs which are not resolving located in the same directories as the DWG and image references which are loading?    Yes
  • Are the DWGs which are resolving a different DWG file version (2004, 2007, 2010, etc.) than those which are not?     No
  • Are the external reference files located on your own hard drive or are they on a network share?  Network
  • Are the external references relatively pathed or full pathed?  Full pathed

did the test, got the broken results.  Could this problem be linked to annotation scales?  here is the error I get when I detach and try to re-attach the problem x-ref;    "X-FENCE METAL.dwg contains 148 annotation scales. It is recommended you open and resave the Xref file to remove excess scales." 

how can i quickly remove annotation scales?

 

thanks 

Member
4 Posts
0 Kudos
Registered: ‎04-05-2012
Post 6 of 42

Re: xrefs not loading

04-05-2012 01:37 PM in reply to: zalant

1- Yes “12010-TB’ is the dwg title block located in the job folder… which our company keeps all dwgs for each job in the same folder.

2-No, all dwgs are saved to same format (2004)

3- All the files are on the same network drive

4-Both, see the attached images showing the two different “path” methods with the same result. (The title block “12010-TB” that is loaded is full path “f:\drawings\etc\etc....”)

 

Test Method & Results:

 

1- Copied all dwgs from job folder 12010 into a local C: folder

2-Closed, reopened AutoCAD 2013; opened parent dwg file “12010-A1.dwg”

 

Result: xref paths are still looking to the original folder on the network (which is F: drive)

 

 

 

Member
4 Posts
0 Kudos
Registered: ‎04-05-2012
Post 7 of 42

Re: xrefs not loading

04-05-2012 01:42 PM in reply to: craig_jacobson

Again, for what it’s worth AutoCAD 2012 is working like a champ!

 

If the programmers didn't touch xrefing in updating to 2013 then I am leaning towards some kind of hidden system variable that is not set correctly.

Distinguished Contributor
109 Posts
5 Kudos
Registered: ‎07-25-2006
Post 8 of 42

Re: xrefs not loading

04-05-2012 03:14 PM in reply to: bcampbell

Since the core console is part of 2013, it's a good bet that pretty much _everything_ was touched by the programmers.  Call it a show-stopper bug, and hope SP1 comes out Real Soon Now

New Member
2 Posts
2 Kudos
Registered: ‎07-23-2010
Post 9 of 42

Re: xrefs not loading

04-09-2012 02:02 PM in reply to: morrolan

We are having exactly the same problem. I would love to know if there is a fix for this. Otherwise I will be reinstalling 2012  on several machines.

New Member
1 Posts
0 Kudos
Registered: ‎04-09-2012
Post 10 of 42

Re: xrefs not loading

04-09-2012 03:42 PM in reply to: bcampbell

Having the same problem, but the xref (in my case, our title block) works fine in 2009.

 

Downloaded the trial for 2013 (getting new machines next month) and can't get it to work.  I try reloading, attaching again, but when I go through the folders and select the title block, when I go to place, it's just the file name.

 

HELP!

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!