AutoCAD 2013/2014/2015

AutoCAD 2013/2014/2015

Reply
Member
wade
Posts: 5
Registered: ‎04-03-2012
Message 1 of 10 (2,725 Views)
Accepted Solution

UCSFOLLOW=1 - is there a way to make it not zoom extents

2725 Views, 9 Replies
08-28-2012 09:22 AM

Is there a setting or variable that I can change so that when I have UCSFOLLOW set to 1 it doesn't zoom extents everytime my UCS changes?

Yeah, I know what you mean.

One trick I use in large areas is to ZOOM O (object).

So, if you've set your UCS to an OBject and do the PLAN thing, you can ZOOM O P (for Previous) ENTER and AutoCAD should zoom into the previously selected object. Of course if it's a line that is running going through the whole project, then you're outta luck..... but if it's a gusset plate, it should would just fine.

PLAN C Z O P should be an easy macro to make in your tool palette.

I just tried it myself. The UCS OB does not retain the object as a previous selection. Bummer, but if you pick on it before you PLAN, then it will be in the Previous selection set.

*Expert Elite*
pendean
Posts: 23,364
Registered: ‎11-06-2003
Message 2 of 10 (2,701 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-29-2012 05:25 AM in reply to: wade

No, that's the setting you have turned on. Do you need to set Views instead?

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Member
wade
Posts: 5
Registered: ‎04-03-2012
Message 3 of 10 (2,699 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-29-2012 05:32 AM in reply to: wade

Um, not sure what you mean about views... if you're talking about saving views that would be way more cumbersome for what I'm doing... I want my view to spin when I change my UCS, but I don't want it to zoom to extents. Thanks.

Valued Mentor
hardin
Posts: 700
Registered: ‎08-30-2007
Message 4 of 10 (2,671 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-30-2012 07:52 AM in reply to: wade

Not exactly what you are looking for, but you could use the view cube to change views, then type (or make a macro on the tool pallette, or program a mouse button, etc) UCS V to change the UCS to the current view. Using the view cube just rotates the view without zooming around.

Member
wade
Posts: 5
Registered: ‎04-03-2012
Message 5 of 10 (2,668 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-30-2012 08:10 AM in reply to: wade

Well I'm only drawing 2D - so I don't think the view cube is quite what I need... basically what I was doing is drawing diagonal bracing and I'd use the UCS OB command to orientate to the brace, draw/stretch/manipulate it, then go back to World and draw the gussets. It's a large floor and I get tired of isolating/unisolating what I am working on, but switching between World and an object's UCS and having my screen zoom to extents is just as annoying... I can set UCSFOLLOW=0 and type PLAN but that zooms to extents as well - I'm getting the feeling Autodesk doesn't have a setting for me...

 

Thanks.

Valued Mentor
hardin
Posts: 700
Registered: ‎08-30-2007
Message 6 of 10 (2,663 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-30-2012 09:26 AM in reply to: wade
Oh. I see. Two things you could try. UCS Z to rotate it about the z axis. But if you type PLAN it will still spoon extents... Have you tried just changing your SNAPANG to stretch and draw? No need to always change ucs.
Valued Mentor
hardin
Posts: 700
Registered: ‎08-30-2007
Message 7 of 10 (2,662 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-30-2012 09:30 AM in reply to: wade
Zoom... Not spoon... Sorry. Also, no need to change view to plan either, other than visual comfort, I guess.
Member
wade
Posts: 5
Registered: ‎04-03-2012
Message 8 of 10 (2,660 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-30-2012 09:45 AM in reply to: wade

Its the visual comfort I'm going for :smileyhappy:

 

Rather than changing the Snap Angle I just set UCSFOLLOW=0 & use UCS OB - then my UCS does what I want; but I feel I work quicker when what I'm looking at is square to me...

 

Thanks.

Valued Mentor
hardin
Posts: 700
Registered: ‎08-30-2007
Message 9 of 10 (2,656 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-30-2012 09:57 AM in reply to: wade

Yeah, I know what you mean.

One trick I use in large areas is to ZOOM O (object).

So, if you've set your UCS to an OBject and do the PLAN thing, you can ZOOM O P (for Previous) ENTER and AutoCAD should zoom into the previously selected object. Of course if it's a line that is running going through the whole project, then you're outta luck..... but if it's a gusset plate, it should would just fine.

PLAN C Z O P should be an easy macro to make in your tool palette.

I just tried it myself. The UCS OB does not retain the object as a previous selection. Bummer, but if you pick on it before you PLAN, then it will be in the Previous selection set.

Member
wade
Posts: 5
Registered: ‎04-03-2012
Message 10 of 10 (2,652 Views)

Re: UCSFOLLOW=1 - is there a way to make it not zoom extents

08-30-2012 10:06 AM in reply to: wade

Hey - I think I just learned something! What I tried was I zoomed object first, then did UCS OB and it stayed zoomed in where it was - so I guess UCSFOLLOW=1 just uses the last zoom command? Either way,

 

Thank you

Thank you

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!