AutoCAD 2013/2014/2015

AutoCAD 2013/2014/2015

Reply
Active Contributor
kiarianc
Posts: 28
Registered: ‎12-12-2012
Message 1 of 7 (1,904 Views)
Accepted Solution

Stopping the mbutton from zooming all extents

1904 Views, 6 Replies
01-22-2013 02:41 AM

I usually use my mbutton to pan dwg. Just started using AutoCAD 2013 and I notice it zoom extents everytime I press the mbutton (the middle scrollwheel button). How do I disable this zoom extents?

 

One more thing, how do I disable the annoying auto complete whenever I type in a command? It seems to be slowing my work flow.

 

Thanks

 

Kiarian

*Expert Elite*
Alfred.NESWADBA
Posts: 8,995
Registered: ‎06-29-2007
Message 2 of 7 (1,894 Views)

Re: Stopping the mbutton from zooming all extents

01-22-2013 04:43 AM in reply to: kiarianc

Hi,

 

to your first question: a ZOOM EXTENTS by default is ony done when you double-click the mouse-wheel-button. Is it possible that you reconfigured your mouse-wheel-button in your mouse driver? (E.g. to do a single click in Windows-Explorer to enter a directory?)

 

>> [...] I disable the annoying auto complete

You have a small symbol besides the command-line-window for setting sysvars for commands (and command-window).

And if you enter in the command-line AUTOCOMPLETE ==> have you looked to the options? :smileywink:

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Active Contributor
kiarianc
Posts: 28
Registered: ‎12-12-2012
Message 3 of 7 (1,887 Views)

Re: Stopping the mbutton from zooming all extents

01-22-2013 05:01 AM in reply to: Alfred.NESWADBA

Hi,

 

Thanks for that. Autocomplete is the option I was looking for.

 

Re. the first problem, no, this is happening everytime I hold the scroll wheel to pan. Zooms extents everytime. When I type in mbuttonpan, it's set to 1. This should be fine, and if I press and hold, it sometimes acts as pan. Then when I try to pan again, bang... it's set to zoom extents again. Very annoying!

 

Kiarian

*Expert Elite*
Alfred.NESWADBA
Posts: 8,995
Registered: ‎06-29-2007
Message 4 of 7 (1,882 Views)

Re: Stopping the mbutton from zooming all extents

01-22-2013 05:28 AM in reply to: kiarianc

Hi,

 

>> this is happening everytime I hold the scroll wheel to pan. Zooms extents everytime

Some weeks ago we had a similar problem, the solution there was to change the mouse (wait until your neighbourh does a coffee-break and then hurry up :smileywink:)

At least try it, and if that also does not work try another mouse-type/-vendor to make sure it's no driver setting (even it's not happening every time).

 

. alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
*Expert Elite*
pendean
Posts: 22,244
Registered: ‎11-06-2003
Message 5 of 7 (1,880 Views)

Re: Stopping the mbutton from zooming all extents

01-22-2013 05:31 AM in reply to: kiarianc

Agree with Alfred, your hardware is the problem (mouse button), we've experienced the same here over the years.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Active Contributor
kiarianc
Posts: 28
Registered: ‎12-12-2012
Message 6 of 7 (1,872 Views)

Re: Stopping the mbutton from zooming all extents

01-22-2013 05:45 AM in reply to: pendean

Thanks for the replies. Mouse hardware doesn't seem to be the problem. Working from home. Just tried 3dsMax just to double check. Scroll button is working fine to pan. Scroll button works fine when pressed to rapid scroll internet page as well. Hmmmm. Strange.

 

Edit. You could be right. The scroll wheel is feeling a bit tetchy.

 

New Member
mbyrd
Posts: 1
Registered: ‎09-20-2010
Message 7 of 7 (1,556 Views)

Re: Stopping the mbutton from zooming all extents

06-02-2013 11:00 AM in reply to: kiarianc

Hi. I've been struggling with my middle mouse button on my Logitech M505 recently as well. I'm accustomed to using the middle wheel as a button for panning and it seemed that recently AutoCAD 2013 was acting like it was receiving comflicting instructions for this action. In other words, it would pan, stutter, and try to zoom or select. 

 

Anyway, I solved it by going to Device Manager and taking a look. The list of mice was much longer than it should have been. I uninstalled all of them (and deleted the driver when given the option) and used my track pad (i'm on a laptop) to then go to the Unifying software and repair my mouse. After that Device Manager still shows three HID-compliant mouse listing s but no Logitech listings (there were four of those previously). Now panning works as before.

 

I suspect I'd switched receivers and mice a few times too often and ended up with multiple comflicting drivers running simultaneously. 

 

Hope this helps someone.

 

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.