AutoCAD 2013/2014/2015

Reply
it
Active Member
it
Posts: 7
Registered: ‎03-30-2012
Message 1 of 6 (2,575 Views)

Shift-drag not deselecting

2575 Views, 5 Replies
04-26-2012 02:43 PM
We just installed AutoCAD P&ID 2013 and there is a HUGE problem with deselecting. This problem is not just on one computer, it is a systemic issue in P&ID 2013. 
Deselect is supposed to work like this (copying straight from the 2013 Help files) :
To deselect objects, SHIFT-click individual objects, SHIFT-drag across multiple selected objects, or press ESC to deselect all selected objects
This, however, is not true! You can only deselect  by clicking on individual objects, only a single object out of many contained inside the drag window will get deselected.  I have looked at all the relevant system variables and set them to the same as my 2012( and 11, and 09.. )  versions, which worked as it is supposed to:
PICKADD 1
PICKAUTO 1
PICKDRAG 0
PICKSTYLE 0
PICKFIRST 1
Searching through the Autodesk forums for a solution, all I found was a thread regarding add-ons in Civil 3D, and their issue was resolved by turning off third party add-ons, which we don't have any. Help! 
*Expert Elite*
tcorey
Posts: 2,697
Registered: ‎12-18-2002
Message 2 of 6 (2,567 Views)

Re: Shift-drag not deselecting

04-26-2012 04:16 PM in reply to: it

I don't know if this helps you narrow it down, but the functionality works correclty in vanilla AutoCAD 2013. I don't have P&ID to test, sorry.

 

Also, a possible workaround would be to press R <Enter> at the Select Objects prompt to get the Remove Objects prompt. Does this let you select multiple objects to remove, by crossing, window, etc?

 

Tim

 

Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
it
Active Member
it
Posts: 7
Registered: ‎03-30-2012
Message 3 of 6 (2,550 Views)

Re: Shift-drag not deselecting

04-27-2012 08:47 AM in reply to: tcorey

Tim,

 

Thanks for letting me know that it works properly in vanilla 2013, this must be an issue specific to P&ID. I am only using the 2D drafting capabilities right now, have not yet implemented all the extra functionality specific to P&ID due to this issue. 

 

Others who have had this desekect problem were using Civil 3D 2013, but their issue was resolved by changing variables in IOPTIONS and MAPIOPTIONS, which are not available in P&ID 2013. I even tried exporting my profile which worked so nicely from 2012 into 2013 but still, no dice. 

 

Priscilla Graeff

Drafting and Design

Cambridge Chemical Technologies

 

:womanfrustrated:

*Expert Elite*
rkmcswain
Posts: 3,573
Registered: ‎11-13-2006
Message 4 of 6 (2,538 Views)

Re: Shift-drag not deselecting

04-27-2012 01:25 PM in reply to: it

Priscilla,

 

   I can confirm your report in P&ID 2013, but only while no command is active (which is a bug)


However, if I start a command (such as ERASE), and pick multiple entities, then SHIFT+Window (or SHIFT+Crossing) some of the selected entities, ALL of them in the deselection set are unselected.

 


it
Active Member
it
Posts: 7
Registered: ‎03-30-2012
Message 5 of 6 (2,534 Views)

Re: Shift-drag not deselecting

04-27-2012 01:46 PM in reply to: rkmcswain
I didn't think of testing the problem with a command before selecting (I just never work that way) but that definitely works. 
We found a bug, now to try to get Autodesk to issue a service pack or hotfix....
Thank you so much!
*Expert Elite*
rkmcswain
Posts: 3,573
Registered: ‎11-13-2006
Message 6 of 6 (2,532 Views)

Re: Shift-drag not deselecting

04-27-2012 01:54 PM in reply to: it

it wrote:
....now to try to get Autodesk to issue a service pack or hotfix....

Good luck with that.....

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post