AutoCAD 2013/2014/2015

AutoCAD 2013/2014/2015

Reply
Active Contributor
Ixath
Posts: 36
Registered: ‎12-05-2011
Message 1 of 6 (858 Views)

DELETE and SAVEAS extremely slow compared to 2012

858 Views, 5 Replies
01-23-2013 10:45 AM

Deleting surfaces (presumably all objects?) and then saving the file is taking an extremely long time in 2013 instead of being instant as in 2012.

This following test was done using the same set of .sat files, the same lisp to automate, the same drawing template file, and every setting, option, and variable I could find were all set the same. I've also tried it with default settings, default template files, forcing the 2013 to save as a 2010.dwg, changing every variable I could find, and anything I could find on Google. Nothing is helping.

AutoCAD 2013
18 seconds: To import, process, and file->saveas 48.7megs of .sat files. Saved .dwg is 15.9megs.
13 seconds: To delete everything (5956 objects, all surfaces) in the newly created/saved drawing.
48 seconds: To file->saveas (on the once again empty .dwg), produces 736k file.
1:19 total

AutoCAD 2012
16 seconds: To import, process, and file->saveas 48.7megs of .sat files. Saved .dwg is 15.9megs.
Instant: To delete everything (5956 objects, all surfaces) in the newly created/saved drawing.
Instant: To file->saveas (on the once again completely empty .dwg), produces 283k file.
0:16 total

It doesn't make sense to me. It takes 18 seconds to import, process, and save a file full of objects, but then it takes 48 seconds just to save the exact same file when it is void of objects.

 

  • I've done the process manually to see if the lisp was the cause, and the delete/save times didn't change.
  • The time increase is present for 4 other people who have tried this. They are in a different office using completely different machines, so the times were slightly different.. but they were still there. I have SP1 installed and they do not.
  • Every file involved is on my C: drive. AutoCAD 2013 is a fresh install (installed it to troubleshoot this issue) and it is not attempting to access any network drive for any reason. Packet sniffer confirms that it's not sending large amounts of data to the internet either.

That's all I can think of. If anybody has any ideas or thoughts please let me know.

 

---slight update:
Setting CACHEMAXFILES to 0 and emptying the folder went a long way towards helping. Deleting is now instant and the file->saveas that follows it has dropped from 48 seconds to 25 seconds. This is still 25 seconds longer than I'd like, but it's a good start.

Since this individual issue might affect others (and doesn't belong in General), I made a separate post explaining it in a little more detail.

---

 

Thank you in advance for any help you can provide figuring out where that extra 25 seconds is coming from.

 

Bryan

 

 

*Expert Elite*
Alfred.NESWADBA
Posts: 9,595
Registered: ‎06-29-2007
Message 2 of 6 (815 Views)

Re: DELETE and SAVEAS extremely slow compared to 2012

01-26-2013 08:55 AM in reply to: Ixath

Hi,

 

just a few questions (hope that I have not overread anything in your post):

  • what operating system do you use?
  • how many memory have you built in?
  • did you use hardware acceleration or not?
  • have you installed VBA Enabler?
  • what applications/tools/apps do run on top of your AutoCAD?
  • do you have a vertical product or plain AutoCAD?

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Product Support
bryce.thelin
Posts: 426
Registered: ‎05-25-2010
Message 3 of 6 (787 Views)

Re: DELETE and SAVEAS extremely slow compared to 2012

01-28-2013 10:26 AM in reply to: Ixath

Hi Bryan,

 

Slower save times is an issue with AutoCAD 2013 that sometimes happens and we're looking into it. It does seem to be centered around having 3D objects in the drawing.

 

Aside from editing out 3D elements, setting CACHEMAXFILES to zero and emptying the cache folder can help. Probably the best workaround though is to set your DWF file format to 2010 (as you noted in your other forum thread).



Bryce Thelin
*Pro
murray-clack
Posts: 1,811
Registered: ‎12-08-2003
Message 4 of 6 (776 Views)

Re: DELETE and SAVEAS extremely slow compared to 2012

01-28-2013 11:47 AM in reply to: bryce.thelin

In addition to what Bryce was saying, what about setting the sysvar SAVEFIDELITY to a value of 0 (zero) before saving? (it's an oldie, but a goodie)

Active Contributor
Ixath
Posts: 36
Registered: ‎12-05-2011
Message 5 of 6 (764 Views)

Re: DELETE and SAVEAS extremely slow compared to 2012

01-29-2013 06:34 AM in reply to: Alfred.NESWADBA

Thank you for the responses everyone.

 

I want to point out that this is only an issue (or at least only noticeable) with very large files. If I import 15-20 megs it seems to be fine.. but if I bring in 40 or 60 megs of .sat files the save times skyrocket.

 

Murray:

Yes sir, I've tried savefidelity. I've tried treedepth, treemax, indexctl, disabling thumbnails, draworder, and another 20 or 30 various system variables with the hopes that something will provide a significant increase. Nothing is doing the trick.

 

Alfred:

I'm using 64bit Windows 7 with 16gigs of ddr 3. I've tried with and without hardware acceleration. However, I'm not sure I've tried disabling HA since I found the CACHEMAXFILES thing. I'll give that a shot again to be sure. I haven't installed the VBA enabler (it's a separate download now in 2013, right?) unless it snuck it in during the install somehow. I've tried with and without other programs running (fresh boot, all virus scan stuff disabled that I'm able to disable/kill, etc). I believe it's a vertical product? It's AutoCAD MEP 2013. The other machines are a bit better than mine. I'm 99% sure it's not a hardware or interfering software issue though.

 

Thank you again for the responses,

Bryan

*Expert Elite*
Alfred.NESWADBA
Posts: 9,595
Registered: ‎06-29-2007
Message 6 of 6 (753 Views)

Re: DELETE and SAVEAS extremely slow compared to 2012

01-29-2013 07:35 AM in reply to: bryce.thelin

Hi,

 

@Bryce

>> Probably the best workaround though is to set your DWF file format to 2010

That's the first time I get the info that saving back to an older release makes saving faster. I can't believe that (under normal cicumstances).

 

@Ixath

>> I believe it's a vertical product? It's AutoCAD MEP 2013

Yes, MEP is a vertical product. You might search in the >>>forum for MEP<<<, maybe there are people having the same problem or maybe you find some hints for your situation.

 

Good luck, - alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.