AutoCAD 2013/2014/2015

AutoCAD 2013/2014/2015

Reply
*Expert Elite*
1,392 Posts
131 Kudos
Registered: ‎05-08-2009
Post 1 of 5
Accepted Solution

Attribute text not displaying

2529 Views, 4 Replies
12-27-2012 03:15 PM

Hello - I have a client with an issue I cannot figure out...

 

They have one file xrefed into another but the text is not showing up. It is a block and the text is an attribute - but it is exploded.

I have attached 2 images - the first one - of the original file the second - where it is xrefed into another file with the text missing.

 

Any thoughts??

 

LD 


If this helped solve your issue - remember to 'accept as solution' to help other find answers!
You can't think AutoCAD and run Revit.
Email: LisaDragoEE@gmail.com

Attribute definitions (outside of blocks) don't show up when their host file is xrefed. They have to be part of a block definition to be visible.

 

A fix I saw suggested on another forum is to make a temporary block from the attributes and then use BURST to convert them to text.

Mentor
208 Posts
10 Kudos
Registered: ‎11-16-2003
Post 2 of 5

Re: Attribute text not displaying

12-27-2012 07:56 PM in reply to: LisaDrago

What if they "BURST" instead of exploding the attribute?

Autodesk AutoCAD Map 3D 2015
Windows 7 Professional
Service Pack 1
Intel(R) Core(TM) i5-4430 CPU @ 3.00 GHz
8.00 GB RAM
*Expert Elite*
9,793 Posts
1,210 Kudos
Registered: ‎06-29-2007
Post 3 of 5

Re: Attribute text not displaying

12-27-2012 10:44 PM in reply to: LisaDrago

Hi,

 

>> It is a block and the text is an attribute - but it is exploded

That might be the source of the problem as some people try to use attribute-definitions to place text within a drawing. The bad thing is that it works, they can start ATTDEF, and write the text .... but this written text is then the name of the attribute-definition.

As long as you leave the object like it is it looks like a text-info, but (and now the bad way starts) don't use this drawing with that attribute-definitions within any other drawing. In case of e.g. _INSERT this drawing into anohter one the attribute-definitions are part of the inserted block, but then they show up the values of the attribute ==> and the values are empty, the name of the attribute is not any more written down like a text. (hope that is clear described).

 

Either you have a tool that converts attribute-definitions to text-objects or you don't insert this drawing into any other one .... or you tell the guy who used attribute-definitions instead of text that he/she has to repair that.

 

HTH, - alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Mentor
249 Posts
59 Kudos
Registered: ‎11-07-2012
Post 4 of 5

Re: Attribute text not displaying

12-28-2012 09:29 AM in reply to: LisaDrago

Attribute definitions (outside of blocks) don't show up when their host file is xrefed. They have to be part of a block definition to be visible.

 

A fix I saw suggested on another forum is to make a temporary block from the attributes and then use BURST to convert them to text.

--
Kate Morrical
Digital Design Manager
Washington, DC
BIMmuse.com
*Expert Elite*
1,392 Posts
131 Kudos
Registered: ‎05-08-2009
Post 5 of 5

Re: Attribute text not displaying

12-28-2012 09:38 AM in reply to: KateMorrical

I had trued just the burst and that did not work - creating a tempoary block and bursting that worked.

 

Thank you all for your help!

 

LD


If this helped solve your issue - remember to 'accept as solution' to help other find answers!
You can't think AutoCAD and run Revit.
Email: LisaDragoEE@gmail.com
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post