AutoCAD 2013/2014/2015

AutoCAD 2013/2014/2015

Reply
Active Contributor
JGAo1
Posts: 43
Registered: ‎05-04-2006
Message 1 of 14 (2,223 Views)
Accepted Solution

ACAD LT 2014 - How to turn off warning message when loading a script

2223 Views, 13 Replies
04-15-2013 01:29 AM

We use scripts a fair bit in acadLT & from the Desktop icon. The 2014 behavior has changed in that it displays a warning (screengrab attached) before allowing the script to load.
This is going to be a pain for users. I can't see a way to add a folder as a trusted source in LT.

Does anyone have a cure for this issue?

JGA

Alfred Neswadba suggested the following idea in the Elite forum:  

 

...have you tried to pass the paths (for the trusted paths) directly into the registry?

It is to be found for full AutoCAD (in my German version with English language pack and my profile):

HKCU/Software/Autodesk/AutoCAD/R19.1/ACAD-D0001:409/Profiles/AN_DevNET/Variables/TRUSTEDPATHS

 

Also the variable SECURELOAD is stored there!


It's worth a shot as long as your fully confident working directly in the Registry of course.  And it's something to investigate while you wait to hear something else from Autodesk.  Let us know what you find and if it works.

 

Dave.

*Expert Elite*
braudpat
Posts: 2,277
Registered: ‎12-15-2006
Message 2 of 14 (2,212 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 02:16 AM in reply to: JGAo1

 

Hello

 

You have to play with :

TRUSTEDPATHS , TRUSTEDDOMAINS , SECURELOAD

 

I imagine that SECURELOAD = 0 could be enough !?

 

Bye, Pat

 

 

 

Bye, Pat ( Supporting Troops )
If you are happy with my answer please mark "Accept as Solution" and if very happy please give me a Kudos (Compliment) - Thanks
Active Contributor
JGAo1
Posts: 43
Registered: ‎05-04-2006
Message 3 of 14 (2,200 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 03:17 AM in reply to: JGAo1

Thanks for replying.
Unfortunately, none of these variables/commands are available in LT. It's a real pain.

 

 

JGA
*Expert Elite*
heinsite
Posts: 880
Registered: ‎03-15-2008
Message 4 of 14 (2,191 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 04:27 AM in reply to: JGAo1

I don't have LT 2014, but in the full version of AutoCAD in Options > Files there is a new setting for Trusted Locations.  Look in your version to see if it's there and if so, set a path to the directory that's giving you trouble.

 

trusted locations.jpg

 

Dave

------------------------------------------------------
Dave Hein, P.E.
Active Contributor
JGAo1
Posts: 43
Registered: ‎05-04-2006
Message 5 of 14 (2,172 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 06:37 AM in reply to: heinsite

Dave,

Thanks again. Unfortunately LT doesn't have the added entry to the support path.
I wondered if this could be a registry entry for LT, but couldn't see anything to help me out.

JGA
*Expert Elite*
braudpat
Posts: 2,277
Registered: ‎12-15-2006
Message 6 of 14 (2,167 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 06:41 AM in reply to: JGAo1

 

Hello

 

Maybe Autodesk has forgotten "something" for ACAD LT 2014 !? 

 

Bye, Pat

 

 

Bye, Pat ( Supporting Troops )
If you are happy with my answer please mark "Accept as Solution" and if very happy please give me a Kudos (Compliment) - Thanks
*Expert Elite*
heinsite
Posts: 880
Registered: ‎03-15-2008
Message 7 of 14 (2,156 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 07:25 AM in reply to: braudpat

I just elevated this to where Autodesk will see it a little sooner.  We'll find out shortly what's up here.

 

Dave.

------------------------------------------------------
Dave Hein, P.E.
Active Contributor
JGAo1
Posts: 43
Registered: ‎05-04-2006
Message 8 of 14 (2,152 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 07:29 AM in reply to: heinsite

Thanks. I've received a message from Autodesk:-

 

"Regarding the problem with the dialog box that appears when running a script file on LT, notice that for the moment there is no way to disable this dialog. Our development team is working in a way to fix this.

 

As soon as we have more information from them I'll contact you again."

 

As you noted before, I think they missed a bit!

 

Thanks for your help.

JGA
*Expert Elite*
heinsite
Posts: 880
Registered: ‎03-15-2008
Message 9 of 14 (2,144 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 07:51 AM in reply to: JGAo1

It's still early in the 2014 release history.  I'm sure more issues will pop up before too long.

 

Glad you got some Autodesk feedback!  We may hear more within a day or so too.

 

Dave.

------------------------------------------------------
Dave Hein, P.E.
*Expert Elite*
heinsite
Posts: 880
Registered: ‎03-15-2008
Message 10 of 14 (2,091 Views)

Re: ACAD LT 2014 - How to turn off warning message when loading a script

04-15-2013 06:42 PM in reply to: JGAo1

Alfred Neswadba suggested the following idea in the Elite forum:  

 

...have you tried to pass the paths (for the trusted paths) directly into the registry?

It is to be found for full AutoCAD (in my German version with English language pack and my profile):

HKCU/Software/Autodesk/AutoCAD/R19.1/ACAD-D0001:409/Profiles/AN_DevNET/Variables/TRUSTEDPATHS

 

Also the variable SECURELOAD is stored there!


It's worth a shot as long as your fully confident working directly in the Registry of course.  And it's something to investigate while you wait to hear something else from Autodesk.  Let us know what you find and if it works.

 

Dave.

------------------------------------------------------
Dave Hein, P.E.
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.