AutoCAD 2013/2014/2015

AutoCAD 2013/2014/2015

Reply
Distinguished Mentor
darawork
Posts: 832
Registered: ‎12-04-2003
Message 1 of 22 (2,712 Views)
Accepted Solution

2014 - Unknown command results in massive lag....

2712 Views, 21 Replies
07-04-2013 09:30 AM

Hi all,

 

This can best be demonstrated with a video:

 

http://www.sendspace.com/file/zvq113 (.AVI video 3.42mb)

 

Basically, when I accidentally input a typo into the command line there is a massive lag before AutoCad comes back to life. Nearly three seconds.

 

This happens on our AutoCad 2014 LT installations too.

 

I have all the predictive/corrective command line features turned off.

I have also uninstalled 360 and online content services, prior to the problem, to no avail.

 

Our office internet is proxied, and there are no ports opened for any Autodesk products.

Is it trying to search 'online' help for the command typo or something?

 

Anyone have any idea what is causing this? It's losing us valuable seconds / minutes / days / weeks / months, depending on how you look at it.

System information: Win7 x64 / 3DSMax Design 2015 / AutoCad 2014 / Xeon E31225 quadcore @3.10Ghz / nVidia GTX760 2GB (344.11 Driver) / 24Gb Ram / Corsair 650w

Since IT moved the user accounts, two days ago, and a few subsequent reboots / log-ins / MS sync catchup... the whole teams installations have speeded up, to the point of ver2013.

 

Watch your server accounts... Moving office? Make sure IT move your /Documents folder locally.

 

pita

*Expert Elite*
Alfred.NESWADBA
Posts: 9,583
Registered: ‎06-29-2007
Message 2 of 22 (2,699 Views)

Re: 2014 - Unknown command results in massive lag....

07-04-2013 11:19 AM in reply to: darawork

Hi,

 

have you tried to disable the commandline options like "AutoCorrect", "Search ..."?

 

2013-07-04 20-17-52.png

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
*Expert Elite*
maxim_k
Posts: 4,174
Registered: ‎07-22-2010
Message 3 of 22 (2,692 Views)

Re: 2014 - Unknown command results in massive lag....

07-04-2013 12:34 PM in reply to: Alfred.NESWADBA
>>>I have all the predictive/corrective command line features turned off.<<<
This looks like not AutoCorrect problem, as OP already turned it off.

@darawork - Do you have such delay even if you type correct command name?

Maxim
Architect
MARSS

MacACAD | MARSS


*Expert Elite*
rkmcswain
Posts: 3,640
Registered: ‎11-13-2006
Message 4 of 22 (2,684 Views)

Re: 2014 - Unknown command results in massive lag....

07-04-2013 02:19 PM in reply to: darawork

Test this way: Unplug all wired network connections and disable all WiFi connections, so there is NO network connections at all

 

Then fire up AutoCAD and see if it acts the same.

Distinguished Mentor
darawork
Posts: 832
Registered: ‎12-04-2003
Message 5 of 22 (2,661 Views)

Re: 2014 - Unknown command results in massive lag....

07-05-2013 02:03 AM in reply to: darawork

Typing some commands results in lag too, usually commands that invoke dialogue boxes for Autocad 2014.

Another user here with LT says the 'matchprop' command takes ages to start up, amongst others.

 

Strangely though, after the first initial lag when the command is first used in a session.... it starts up quicker the next time we use it. Like it is now preloaded into memory and can be invoked quicker. This happens with some express tool commands, like layfrz or others.

System information: Win7 x64 / 3DSMax Design 2015 / AutoCad 2014 / Xeon E31225 quadcore @3.10Ghz / nVidia GTX760 2GB (344.11 Driver) / 24Gb Ram / Corsair 650w
Distinguished Mentor
darawork
Posts: 832
Registered: ‎12-04-2003
Message 6 of 22 (2,658 Views)

Re: 2014 - Unknown command results in massive lag....

07-05-2013 02:13 AM in reply to: rkmcswain

"Test this way: Unplug all wired network connections and disable all WiFi connections, so there is NO network connections at all" -  rkmcswain

 

 

Amazingly, this actually works!

 

Commands start up quickly and typos result in an instant 'unknown command' reply. Problem sorted...... nearly;

 

I still need access to my work network! :-/

 

So..... how do I fix this? I wonder if adding new firewall rules would work? Or an option in AutoCad to disable online snooping for commands. Maybe a program like ZoneAlarm or something? Even a registry hack?

 

As stated before, I have uninstalled 360 and online content service. What else would be checking for online content?

 

Unplugging the network cable fixes it!?! That's messed up eh?

System information: Win7 x64 / 3DSMax Design 2015 / AutoCad 2014 / Xeon E31225 quadcore @3.10Ghz / nVidia GTX760 2GB (344.11 Driver) / 24Gb Ram / Corsair 650w
Distinguished Mentor
darawork
Posts: 832
Registered: ‎12-04-2003
Message 7 of 22 (2,653 Views)

Re: 2014 - Unknown command results in massive lag....

07-05-2013 02:26 AM in reply to: darawork

Just thought to include a screengrab of the Autodesk Products installed at the time of installation of AutoCad 2014.

The list is sorted by installation date.

 

I have also included a screengrab of all the AutoDesk software installed, sorted by publisher.

 

 

System information: Win7 x64 / 3DSMax Design 2015 / AutoCad 2014 / Xeon E31225 quadcore @3.10Ghz / nVidia GTX760 2GB (344.11 Driver) / 24Gb Ram / Corsair 650w
*Expert Elite*
maxim_k
Posts: 4,174
Registered: ‎07-22-2010
Message 8 of 22 (2,648 Views)

Re: 2014 - Unknown command results in massive lag....

07-05-2013 02:38 AM in reply to: darawork
Just a thought. What if to try to download and install Off-line Help documentation, then uncheck "Use online help content when available" (or something like this, don't remember exact name) in AutoCAD options.

Maxim
Architect
MARSS

MacACAD | MARSS


Distinguished Mentor
darawork
Posts: 832
Registered: ‎12-04-2003
Message 9 of 22 (2,645 Views)

Re: 2014 - Unknown command results in massive lag....

07-05-2013 03:16 AM in reply to: darawork

Tried that, no luck. Still lags.

 

 

Here is a screenshot of a list of Autodesk processes (highlighted in blue) and their port accesses. I've blanked out a few sensitive bits.

 

The only thing I think is accessing for AutoCad 2014 is WSCommCntr4.exe

System information: Win7 x64 / 3DSMax Design 2015 / AutoCad 2014 / Xeon E31225 quadcore @3.10Ghz / nVidia GTX760 2GB (344.11 Driver) / 24Gb Ram / Corsair 650w
Distinguished Mentor
darawork
Posts: 832
Registered: ‎12-04-2003
Message 10 of 22 (2,642 Views)

Re: 2014 - Unknown command results in massive lag....

07-05-2013 03:38 AM in reply to: darawork

I have stopped WSCommCntr4.exe from loading into memory, by disabling InfoCenter.

 

www.cad-notes.com/2012/12/speed-up-autocad-configuration/

 

No luck, autocad still lagging.

 

Plugging the network cable out still seems to be the only way to speed AutoCad up.

System information: Win7 x64 / 3DSMax Design 2015 / AutoCad 2014 / Xeon E31225 quadcore @3.10Ghz / nVidia GTX760 2GB (344.11 Driver) / 24Gb Ram / Corsair 650w
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.