AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
New Member
2 Posts
0 Kudos
Registered: ‎09-16-2011
Post 1 of 3

replace block in mleader style

247 Views, 2 Replies
09-16-2011 06:45 AM

Hello all.

 

I am trying to do the following. I have drawing with Multileaders in it, all of which have a mleader style wich has "block-a" as content. In these Mleaders I want to change "block-a" to "block-b".

 

I thought of two possible ways to achieve this:

 

1. replace the block in the mleader style and regen the drawing. This doesn't work. New Mleaders that I make with the aforementioned style have "block-b" as content but the existing Mleaders keep the old "block-a".

 

2. replace the block with the BLOCKREPLACE command and bypass the whole Mleader business. This also doesn't work. The blocks that are not part of an Mleader get replaced just fine, but the ones inside an Mleader remain their same old self.

 

I guess it could be achieved by adjusting "block-a" itself into being similair to "block-b" but this sort of defeats the purpose of being able to choose a block as content for your Mleader style doesn't it? Any thoughts?

 

*Expert Elite*
1,658 Posts
213 Kudos
Registered: ‎08-15-2008
Post 2 of 3

Re: replace block in mleader style

09-16-2011 07:06 AM in reply to: vansluijters

I just tried it with the properties manager and it worked perfect.  Pick on the mleader, in properties change the block to a different one.

----------------------------------------------------------------------------
If something I wrote can be interpreted two ways, and one of the ways makes you sad or angry, I meant the other one.
New Member
2 Posts
0 Kudos
Registered: ‎09-16-2011
Post 3 of 3

Re: replace block in mleader style

09-16-2011 07:27 AM in reply to: GrantsPirate

@COJonez

Thanks for trying, but it doesn't work quite the way I want to.

 

first of all, it's not just about one mleader but...let's say quite a few. I could isolate them through various ways and then apply your method but this strikes me as a detour that shouldn't be necessary.

 

There is another problem however. The block I want to replace has a few Attributes in it. The new block has the same Attributes plus a few extra. Now, when I use your method the data gets mixed up.

For example. "block-a" with Attribute NAME and Attribute COLOR has the value 'awesome' for NAME and a blank value for COLOR. When I use your method I get the value 'awesome' in the COLOR field and the blank for NAME. What's up with that?

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post