AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
Contributor
nothin
Posts: 19
Registered: ‎03-27-2012
Message 1 of 10 (969 Views)
Accepted Solution

Removing Character Formatting

969 Views, 9 Replies
10-30-2012 01:09 PM

I am working with tables that are linked to data from an excel file.

 

After I create a table I dettach it from the excel file. I do not want the excel file to control the table.

 

I then need to update the text format of all the text in the table. I've noticed that the text strings are still formatted based on how the excel file was formatted.

 

The only way to remove this is to click on the cell, highlight the text, right click, and then select Remove Character Formatting. Unfortunately I have to do this for each text string.

 

Is there a way to remove the character formatting for all of the text strings at once?

 

Even better, is there a way to format the table so that it does not change the text style based on what is in the excel file but instead based on AutoCAD's text styles?

 

I've attached an example of a table I'm working on. I've detached the table from the excel file.

To remove excel formatting from a linked table:

 

1-Type DATALINK

2-Double click the link your working with. Click the expand interface logo (circle with an angle in it (>)) to show all options.

3-Uncheck the box beside Use Excel Formatting.

 

That's how it's supposed to work, but it doesn't seem to always work for me. If there's a CAD expert, maybe you could let me know why this option doesnt always work

*Expert Elite*
pendean
Posts: 23,698
Registered: ‎11-06-2003
Message 2 of 10 (961 Views)

Re: Removing Character Formatting

10-30-2012 02:08 PM in reply to: nothin

TABLESTYLE perhaps, not text style. PROPERTIES command. I can't tell from your sample what it is you want to drop since all your fonts got replaced and no formatting changes.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
*Expert Elite*
leothebuilder
Posts: 481
Registered: ‎07-05-2010
Message 3 of 10 (959 Views)

Re: Removing Character Formatting

10-30-2012 02:16 PM in reply to: nothin

Not sure what you're trying to format but if I assume that it is the font, make sure the font is the way you want it in the excel sheet before inserting the table in autocad.

 

If the table is still linked to the excel file, change the font in the excel file and update the table link and the font will update in the autocad table

*Expert Elite*
leothebuilder
Posts: 481
Registered: ‎07-05-2010
Message 4 of 10 (955 Views)

Re: Removing Character Formatting

10-30-2012 02:20 PM in reply to: pendean

Dean , just must have the record..............just noticed, you have 12,000 posts !!!

Contributor
nothin
Posts: 19
Registered: ‎03-27-2012
Message 5 of 10 (953 Views)

Re: Removing Character Formatting

10-30-2012 02:25 PM in reply to: pendean

Even if I edit table style it still does not remove the character formatting.

Contributor
nothin
Posts: 19
Registered: ‎03-27-2012
Message 6 of 10 (952 Views)

Re: Removing Character Formatting

10-30-2012 02:26 PM in reply to: leothebuilder

I tried that but the font is still slightly different than the font I want to use in autocad.

*Expert Elite*
leothebuilder
Posts: 481
Registered: ‎07-05-2010
Message 7 of 10 (946 Views)

Re: Removing Character Formatting

10-30-2012 02:30 PM in reply to: nothin

Excel supports any "windows" TTF font.

What prevents you from using the same font in autocad as in excel ?

 

If you want to use a SHX font in autocad you're out of luck because excel is not compatible with SHX fonts.

 

 

Contributor
nothin
Posts: 19
Registered: ‎03-27-2012
Message 8 of 10 (928 Views)

Re: Removing Character Formatting

10-31-2012 02:18 PM in reply to: leothebuilder

That is a good point. The font in AutoCAD that I want to use is an SHX font.

 

Even so I would like the user to be able to change the font to whatever they want within autocad.

 

Perhaps there is a way to remove the character formatting with a lisp program?

 

I've attached some pictures to show what I'm talking about.

New Member
s2ghaziz
Posts: 2
Registered: ‎05-05-2011
Message 9 of 10 (876 Views)

Re: Removing Character Formatting

11-13-2012 07:41 AM in reply to: nothin

To remove excel formatting from a linked table:

 

1-Type DATALINK

2-Double click the link your working with. Click the expand interface logo (circle with an angle in it (>)) to show all options.

3-Uncheck the box beside Use Excel Formatting.

 

That's how it's supposed to work, but it doesn't seem to always work for me. If there's a CAD expert, maybe you could let me know why this option doesnt always work

Contributor
nothin
Posts: 19
Registered: ‎03-27-2012
Message 10 of 10 (873 Views)

Re: Removing Character Formatting

11-13-2012 08:16 AM in reply to: nothin

Thanks for the input! It worked! I did notice that I would loose the row and column widths if I did this. But if I created a table with the formatting linked to the excel file, then went back and edited the data link to remove the excel formatting, the rows and columns with keep the desired widths.

 

Is there a way to keep the column and row widths while removing the character formatting?

 

AWSOME!! Thanks again!!!

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.