AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Active Contributor
31 Posts
5 Kudos
Registered: ‎05-24-2011
Post 11 of 17

Re: Problem saving blocks to New Tool Palette

02-20-2012 11:24 AM in reply to: mattd

Oh patbeg..... Please don't yell at people who are only trying to help. If you need an answer that bad you need to use the autodesk support page and get help there. This is not the place to demand anything as this a place for users to help each other, cordially. As far as the try this try that, its the best and really only way to find the problem. There often are many things that relate too or work off of another element so its not always possible to give a direct answer with out it.

AutoCAD 2012
Dell Precision T7400, Intel Xeon @3.4GHz
Win XP 32bit 4GB RAM
Nvidia Quadro FX 3700
Cyborg R.A.T. 7 mouse
*Expert Elite*
880 Posts
127 Kudos
Registered: ‎03-15-2008
Post 12 of 17

Re: Problem saving blocks to New Tool Palette

02-20-2012 07:29 PM in reply to: GOLEN

Well put. 


There are many variables in the problems posted on these forums.  Finding an answer to a difficult technical issue can be like trying to figure out the spelling of a word you don't know how to spell.  When something goes wrong in a program as complex as AutoCAD we drill down to the problem with "try this", and "try that" to get information.  It's not that the participants here don't know how to fix something - there is expertise enough here to fix anything!  But if it isn't a simple fix, or if we don't know enough about a particular configuration, the answers to all those "try" questions fill in the blanks often enough to solve the problem.


It's a process.




Dave Hein, P.E.
Active Member
8 Posts
0 Kudos
Registered: ‎05-09-2010
Post 13 of 17

Re: Problem saving blocks to New Tool Palette

01-08-2013 11:55 PM in reply to: mattd

Sorry Im late to the party, but Im going to share my experience to anyone else who reads this thread.


My situation was slightly different as the tool palettes were on a shared network. A network that I have full rights to, but (after talking to IT) my autoCAD runs on a local system which does not have access to these files. They aren't read only to me in windows explorer, i can edit, delete and create files but AutoCAD cant.


Is this scenario or similar scenario possible on a single machine?


Well due to network capabilities IT didnt change this for me, instead I had to work around it by copying the tool palette files to my desktop. Changing the directory to look at these tool palettes. Modifying them. Overwriting the files on the network with the newly modified files on my desktop. Changing the directory location back to the network in ACAD.


I know this is circuitous. But testing this way (for the original post) would be able to determine if the files are read only for AutoCAD. Or if it is a glitch.


Hope this helps, sorry if it doesnt.

Valued Contributor
95 Posts
1 Kudo
Registered: ‎05-16-2005
Post 14 of 17

Re: Problem saving blocks to New Tool Palette

01-09-2013 10:34 AM in reply to: stevenwilson7810

I recently had this issue forced upon me. I use civil 3d 2011, on windows xp, with all service packs and updates for both.

We changed our file locations and created a set of server and local based support folders. I had the local folder listed first in the files section of the options, and the server location listed second. I was creating a couple new tool palettes to share, and I moved them from my local folder to the server folder, with Autocad still open.

That's when the problem hit me.

Now, it sees the palettes in both folders, but it won't let me create a new one. I click New Palette, and it shows up and asks for a name in the paletteset, but after naming, I try to place content onto it, and it won't accept it. It doesn't even save the file to either store location. I can add seperators and text, but neither of those trigger a save either.

Changing the order or removing and adding different location paths to the tool palette path doesn't affect anything except what palettes are shown (which then breaks my groups).

I went to another machine, and changed the order, putting the server store first and created a new palette. It worked exactly as it should. Just on my machine, it no longer works, with my configuration.


If I revert to a default profile, it works again.

And I know it's not something saved weird in the profile, as I import the ARG file fresh on startup of my autocad. I've opened the ARG file and found no reference to the tool palettes, so nothing got inadvertently written back to it.


It's kind of frustrating. Does anyone have any other ideas? 

Adam Reilly

Dell Precision T1700, Windows 7 Professional SP1
Intel Xeon E3-1220 3.10GHz, 64bit
Nvidia Quadro K2000
Valued Contributor
95 Posts
1 Kudo
Registered: ‎05-16-2005
Post 15 of 17

Re: Problem saving blocks to New Tool Palette

01-09-2013 10:53 AM in reply to: AdammReilly

As a follow up, I deleted the saved profile in options, and reimported it. That still didn't help.


I ended up setting my profile to one that worked, created several blank tool palettes and then copied them into the network store location. When I set my profile back to the standard, it showed these palettes, and I was able to edit the content on them.


It's a work around, but I'd still like to know why and what the problem is.

Adam Reilly

Dell Precision T1700, Windows 7 Professional SP1
Intel Xeon E3-1220 3.10GHz, 64bit
Nvidia Quadro K2000
11 Posts
0 Kudos
Registered: ‎03-05-2013
Post 16 of 17

Re: Problem saving blocks to New Tool Palette

04-13-2013 07:35 AM in reply to: mattd

i dont know why but i got same problem and it was solve after i save my workspace

New Member
1 Posts
0 Kudos
Registered: ‎06-04-2013
Post 17 of 17

Re: Problem saving blocks to New Tool Palette

06-04-2013 06:45 AM in reply to: GOLEN

I was experiencing the same problem, but it was not fixed when I changed my user settings. Instead, I created a new folder on my desktop, let's call it Temp, and relinked my Tool Palette File Location to the Temp folder. (Options > Files > Tool Palette File Location > Browse). Once I did this I was able to create new tabs in my tool palette and add blocks to them. After creating the tabs I needed, I went into the Temp folder and transfered the ATC files into the folder that resides on our server that everyone in our office links to. Once I had everything in place I just relinked myself to the original folder and discarded the Temp folder. The tabs are the only thing I'm unable to create when I'm linked to the server, but once I did the workaround I could add new blocks to them. Still, not a permanent fix, but it works.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post