AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
Active Contributor
nickelson
Posts: 48
Registered: ‎04-13-2010
Message 1 of 6 (1,447 Views)

Not just another Arial Narrow truetype too bold issue...

1447 Views, 5 Replies
10-06-2010 09:35 PM

Hi everyone

 

Some of you may have encountered the old chestnut that is arial narrow and other truetype fonts displaying too bold, and the usual problem of them having z values, fixed by flattening the text.

 

I have this problem but there is a twist to the story - all my text has been well and truly flattened. When I print from model space, it looks fine, from paper space through the viewport = too fat. This is where it gets really strange. When I change space on text (which had a z value of 0 in model space) to paper space, it suddenly has a z value of 1058.322. If I then set the z value to 0, it looks fine. Following this, if I then change space back into model space, the z value leaps from 0 to 569.161 (half of 1058.322, as the scale of viewport is 1:500(m), or 2:1) and is too fat again, and stays fat when I reset to 0. I have checked the center z value of the viewport and it is 0, and the ucs in paper space is world.

 

I am a little bamboozled - Any suggestions?

 

cheers

Contributor
mrdrafty
Posts: 14
Registered: ‎08-23-2010
Message 2 of 6 (1,179 Views)

Re: Not just another Arial Narrow truetype too bold issue...

11-08-2010 09:41 PM in reply to: nickelson

Hi

 

Did you get any resolution to this? I'm having the exact same problem which I can't find an answer for anywhere on the internet. I too stumbled on changing the space of the text and how AutoCAD then gives it a z value.

 

Does anyone have a solution?

 

Cheers.

Mentor
BernardMadoff
Posts: 578
Registered: ‎07-15-2009
Message 3 of 6 (1,177 Views)

Re: Not just another Arial Narrow truetype too bold issue...

11-08-2010 09:49 PM in reply to: nickelson

SET ucs world and plan world then wblock the data to a new file and see if this fixes the issue.

don't ask why, just do it.....:smileyvery-happy: might work might not

*Expert Elite*
ToanDN
Posts: 1,893
Registered: ‎09-26-2006
Message 4 of 6 (1,164 Views)

Re: Not just another Arial Narrow truetype too bold issue...

11-09-2010 05:52 AM in reply to: mrdrafty

Your viewport uses a different UCS other than WCS?

Contributor
mrdrafty
Posts: 14
Registered: ‎08-23-2010
Message 5 of 6 (1,150 Views)

Re: Not just another Arial Narrow truetype too bold issue...

11-09-2010 06:18 PM in reply to: nickelson

Thanks guys, although I've just managed to solve it. In my case the 'target z value' was non-zero. Corrected by entering 3dorbit in the viewport and changing the z target value in the properties box to 0.  While doing a wblock of the drawing often works, it's always good to know what actually causes the problem.

Active Contributor
nickelson
Posts: 48
Registered: ‎04-13-2010
Message 6 of 6 (1,138 Views)

Re: Not just another Arial Narrow truetype too bold issue...

11-09-2010 09:28 PM in reply to: mrdrafty

Success!

 

Top stuff mrdrafty, that was driving me insane!

 

Thanks everyone

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!