AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
Contributor
stephencowling6059
Posts: 21
Registered: ‎11-09-2009
Message 1 of 12 (6,173 Views)

Multileader Text frame gap - a workaround

6173 Views, 11 Replies
01-13-2011 09:06 PM

I've been bothered by this problem for a while.

If you add a frame to multileader text, Autocad places the frame stupidly close to the text.

 

I just worked out a way to trick Autocad into increasing the gap, but it is far from an ideal solution:

 

  1. Make the text size bigger than you want it to be. For me, for a final text height of 2.5mm I find 10mm works well.
  2. Then edit the text by double-clicking on it. The text editor contextual ribbon will appear.
  3. Highlight some, not all, of the text and change its height back to the height you want (eg 2.5 for my example). This will override the text properties while keeping the multileader properties at the larger size. Autocad will use the multileader properties to calculate the gap to the text frame.
  4. Close the text editor or click in blank space to exit the editor.
  5. Edit the text again and change the remaining text to the new height.

For multiline text you may need to adjust the line space factor as well.

 

It would be far better if Autodesk added a border offset factor to the frame, or better yet add a checkbox to the background mask dialog within the mtext editor to add a frame.

 

Hope this helps.

Member
Z00111111
Posts: 4
Registered: ‎01-24-2011
Message 2 of 12 (6,054 Views)

Re: Multileader Text frame gap - a workaround

01-24-2011 06:38 PM in reply to: stephencowling6059

I found that having a colour 255 full stop with a size bigger than the rest of the text at the beginning and end over every line creates a suitable gap between the actual text and the text box in all directions.

 

 

For multi-lined text, adjusting the line spacing factor to something below will fix the spacing with a bit of fiddling.

Member
Crys.Turner
Posts: 5
Registered: ‎07-11-2011
Message 3 of 12 (5,236 Views)

Re: Multileader Text frame gap - a workaround

12-20-2011 11:40 AM in reply to: stephencowling6059
 
Here's how to adjust that gap, Border Offset, without having to use a workaround.  This is an excerpt from AuitoCAD Help:
 
To add an opaque background or fill to a multiline text object
  1. If the ribbon is active, double-click a multiline text object to open the MTEXT ribbon contextual tab. If the ribbon is not active, the In-Place Text Editor is displayed.
  2. On the ribbon contextual tab, click Background Mask. In the editor, right-click. Click Background Mask.
  3. In the Background Mask dialog box, select Use Background Mask.
  4. Enter a value for Border Offset Factor.

    The value is based on the text height. A factor of 1.0 exactly fits the multiline text object. A factor of 1.5 (the default) extends the background by 0.5 times the text height.

  5. Under Fill Color, do one of the following:
    • Select the Use Drawing Background Color option.
    • Select a color for the background, or click Select Color to open the Select Color dialog box.
  6. Click OK to return to the editor.
  7. To save your changes and exit the editor, use one of the following methods:
    • On the MTEXT ribbon contextual tab, in the Close panel, click Close Text Editor.
    • Click in the drawing outside the editor.
    • Press CTRL+ENTER.

    The opaque background is applied when you exit the editor.

Contributor
stephencowling6059
Posts: 21
Registered: ‎11-09-2009
Message 4 of 12 (5,220 Views)

Re: Multileader Text frame gap - a workaround

12-21-2011 10:27 PM in reply to: stephencowling6059

Cool, looks like it's been fixed in Autocad 2012?

Member
Z00111111
Posts: 4
Registered: ‎01-24-2011
Message 5 of 12 (5,164 Views)

Re: Multileader Text frame gap - a workaround

01-08-2012 03:33 PM in reply to: Crys.Turner

That's not really the problem we've been encountering. Changing the background offset, for Multileaders, for some unkown reason, doesn't change the proximity of the Text Frame, when set to 'Yes', and there doesn't seem to be a variable determining the Text Frame Offset.

Active Contributor
john-B
Posts: 48
Registered: ‎09-09-2009
Message 6 of 12 (5,157 Views)

Re: Multileader Text frame gap - a workaround

01-08-2012 04:02 PM in reply to: stephencowling6059

Hi all,

Changing the LANDING GAP seems to increase the frame size for me.

New Member
r14201
Posts: 2
Registered: ‎05-14-2010
Message 7 of 12 (4,610 Views)

Re: Multileader Text frame gap - a workaround

05-23-2012 12:21 PM in reply to: stephencowling6059

I'm looking for some detail on this subject. Does 2012 have better control of this feature?

 

The posted "work around" does create an increased space, but my most common need is generating datum leaders with only 1 charater and providing this as a solution to my entire group, will likely not go over very well. My current work around is a block leader arrangement (multiple actually, for various positions) with embedded attribute, for the datum letter.

 

The posted AutoCAD help solution (using a background mask) is not working for me. Yes I can create a BG mask, but this is not affecting the size of the text frame.

 

I would like to be able to just use the multileader tool to create these datums, so I can simplify my automation tools processing.

 

Thanks

- Ken
Active Contributor
john-B
Posts: 48
Registered: ‎09-09-2009
Message 8 of 12 (4,592 Views)

Re: Multileader Text frame gap - a workaround

05-27-2012 02:36 PM in reply to: r14201
Ken, In autocad 2012 increasing the landing gap in mleader increases the text frame gap. Hope this is of some help. Regards John
New Member
r14201
Posts: 2
Registered: ‎05-14-2010
Message 9 of 12 (4,574 Views)

Re: Multileader Text frame gap - a workaround

05-29-2012 06:46 AM in reply to: john-B

Hi John, thanks for this clarification/confirmation.

- Ken
*Expert Elite*
LeafRiders
Posts: 322
Registered: ‎09-28-2010
Message 10 of 12 (3,365 Views)

Re: Multileader Text frame gap - a workaround

02-06-2013 07:39 AM in reply to: r14201

Some confusing responses here... The title of this thread is for MLeader Text frame gap, which ultimately is the gap for the masking applied when selecting "YES" to masking on an MLEADER...  In 2012 there is still only a yes or no option for masking, not an option to actually change this from 1.5 to 1.1 for example on the MLEADER.

 

If anyone has found a way to change the variable controlling the gap of the text (aka masking limits) on the MLEADER, please post here. From what I can tell it's on or off and the gap value is fixed.

 

Autodesk it's probably time to fix this one, or provide a valid solution to adust the text frame box extents, "Masking Offset" for the MLEADERS. Nothing like having a pile of MTEXT set to 1.1 offset and all the MLEADERS at the overkilled 1.5 default value.

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.