AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
Valued Mentor
mbuonocore
Posts: 392
Registered: ‎01-27-2006
Message 1 of 11 (2,476 Views)

Multi Leader styles not updating

2476 Views, 10 Replies
11-08-2011 06:51 PM

I have various multi leader styles set up in my drawing.  I place a multi leader (arrow and text not seperate mtext) then decided to change it to a different leader style let's say from ML48 to ML96.  The problem happens when I try to change it again.  It doesn't update to my new multi leader style.  Example....from ML96 back to ML48 or any other style.  It seems like I only get one opportunity to apply a different style.   Hope that make sense.  Thanks

Product Support
emily.xu
Posts: 467
Registered: ‎03-29-2010
Message 2 of 11 (2,453 Views)

Re: Multi Leader styles not updating

11-09-2011 09:15 PM in reply to: mbuonocore

I know your problem is you have set the Mleaderstyle for your different types of multi leader, and now you want to change from one style to another one,you can only successe for the first try, and unable to change it back.

I have tested on my machine, it works as expected.So I would suggest you to check the following:
1  Please make sure you have the latest service Pack(Update 2) for your AutoCAD 2011,if not, please go to: http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=17014611&linkID=9240618 to install it, please note you need to install update 1.1 first,and then update 2, see the readme.
2  Use MLEADERSTYLE command to set your multi leader styles,and also Style command for your text style.
3  To change the multi leader style, you have two ways: one is in the Properties pallet,change the Multileader style under Misc section.Another is select the multi leader, then go to Annotate tab, change the style in the Leaders column.

see attached AVI.

 
______________________________________________________________

If my post answers your question, please click the "Accept as Solution" button. This helps everyone find answers more quickly!

 




Emily Xu
Valued Mentor
mbuonocore
Posts: 392
Registered: ‎01-27-2006
Message 3 of 11 (2,444 Views)

Re: Multi Leader styles not updating

11-10-2011 04:55 AM in reply to: emily.xu

Thanks for the response.  None of those suggestions worked.  I have attached the file.  I just discovered this also happens in 2010.  There must be a setting somewhere that I am missing.  It works if I assign the annotative style and change the annotative scale.

Valued Mentor
mbuonocore
Posts: 392
Registered: ‎01-27-2006
Message 4 of 11 (2,435 Views)

Re: Multi Leader styles not updating

11-10-2011 07:31 AM in reply to: emily.xu

I just discovered for some reason by default, the multileader style settings are always being read for a scale of 1 not the intended scale factor.  48 or example 1/4"

If I change all of the height settings (arrow, landing, text height) to the plotted size 4.5" for example it works fine.  But I should be entering 3/32" or 1/8" for the heights and let autocad do the conversion by the scale entered in the style.

 

See attached.  There is a setting somewhere that is telling autocad to always read the styles for 1:1.......

The dimension styles work fine.

 

Product Support
emily.xu
Posts: 467
Registered: ‎03-29-2010
Message 5 of 11 (2,406 Views)

Re: Multi Leader styles not updating

11-11-2011 01:44 AM in reply to: mbuonocore

Reset Overall scale value for selected mleaders in Properties Palette.


______________________________________________________________

If my post answers your question, please click the "Accept as Solution" button. This helps everyone find answers more quickly!


 




Emily Xu
Valued Mentor
mbuonocore
Posts: 392
Registered: ‎01-27-2006
Message 6 of 11 (2,400 Views)

Re: Multi Leader styles not updating

11-11-2011 04:34 AM in reply to: emily.xu

Thanks for the reply.  I discovered two work arounds.  Can you explain why this is happening as the autocad default?  It's not efficient to change the properties everytime.  It does this in ACAD 2008, 2009, 2010, 2011

 

Thank you.

Product Support
emily.xu
Posts: 467
Registered: ‎03-29-2010
Message 7 of 11 (2,371 Views)

Re: Multi Leader styles not updating

11-14-2011 07:18 PM in reply to: mbuonocore

Thank you very much for reporting this problem, and I have escalated this issue to our development for deeply investigation. Any update from our dep will let you know.




Emily Xu
Product Support
emily.xu
Posts: 467
Registered: ‎03-29-2010
Message 8 of 11 (2,352 Views)

Re: Multi Leader styles not updating

11-17-2011 06:05 PM in reply to: emily.xu

This is a legacy bug from 2008, and our dev is working on it.The workaround for now is to change the scale manually from properties palette.




Emily Xu
Valued Mentor
mbuonocore
Posts: 392
Registered: ‎01-27-2006
Message 9 of 11 (2,341 Views)

Re: Multi Leader styles not updating

11-18-2011 06:37 AM in reply to: emily.xu

Thank you for the update.  I tested in version in v2007-2011 and found it must be a bug. 2007 worked fine.

Active Contributor
RFreund
Posts: 29
Registered: ‎05-09-2012
Message 10 of 11 (2,013 Views)

Re: Multi Leader styles not updating

09-28-2012 11:54 AM in reply to: emily.xu

Has there been a resolution to this problem? I'm using AutoCAD 2013 and this still seems to be an issue. 

I am using annotative MLeader. When I change the text height in mleaderstyle it does not update.

 

Thanks,

 

Ryan

www.HowToEngineer.com
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.