AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
Member
lakerlkr8
Posts: 4
Registered: ‎02-23-2010
Message 1 of 7 (463 Views)

MTEXT missing in XRefs

463 Views, 6 Replies
02-23-2010 12:48 PM
I am creating my own titleblocks for a certain project and just switched to Cad 2010 from 2006. I am drafting the titleblocks in their own model space and then XREF'ing it into the layout spaces of my drawings (a seperate file). For some reason, the MTEXT will not show up in an XREF'ed file. I was able to get the text to show up once I exploded it in the original titleblock file, but obviously not a real solution.

Any ideas?

MText, on it's own visible layer, custom text style with Annotative properties enabled. No show. ?
*Expert Elite*
Patchy
Posts: 6,325
Registered: ‎09-16-2009
Message 2 of 7 (463 Views)

Re: MTEXT missing in XRefs

02-23-2010 01:09 PM in reply to: lakerlkr8
List it to see if it has wrong UCS or different Z value.
Member
lakerlkr8
Posts: 4
Registered: ‎02-23-2010
Message 3 of 7 (463 Views)

Re: MTEXT missing in XRefs

02-23-2010 01:54 PM in reply to: lakerlkr8
MTEXT Layer: "Text"
Space: Model space
Handle = 360
Style = "Notes"
Annotative: Yes
Annotative scale: 1'-0" = 1'-0"
Location: X=2'-6 13/16" Y=1'-9 5/8" Z= 0'-0"
Width: 0'-3 29/32"
Normal: X= 0'-0" Y= 0'-0" Z= 0'-1"
Rotation: 0.00
Paper text height: 0'-0 3/16"
Model text height: 0'-0 3/16"
Line spacing: Multiple (1.000000x = 0'-0 5/16")
Attachment: TopLeft
Flow direction: ByStyle

UCS is set to world. Shouldn't be a problem...
*Dean Saadallah
Message 4 of 7 (463 Views)

Re: MTEXT missing in XRefs

02-23-2010 02:04 PM in reply to: lakerlkr8
REFEDIT, explode the block in detail, specifically the STYLE being used and
actual settings of the text.

Or post the file.

--
Dean Saadallah
http://LTisACAD.blogspot.com
--
Member
lakerlkr8
Posts: 4
Registered: ‎02-23-2010
Message 5 of 7 (463 Views)

Re: MTEXT missing in XRefs

02-23-2010 02:31 PM in reply to: lakerlkr8
Well, the clue to check the style was the key. My problem was solved by changing the text style from "Notes" (a custom style) to "Standard".

Although, I don't understand what about the "notes" style would prevent the text from showing up in a xref. When I used the


Command: refedit
Select reference: Object is not a valid reference

What about the text styles would differentiate if it were visible or not? Not sure how to post this information...
*Pro
murray-clack
Posts: 1,811
Registered: ‎12-08-2003
Message 6 of 7 (463 Views)

Re: MTEXT missing in XRefs

02-24-2010 05:57 AM in reply to: lakerlkr8
Could it be the "notes" style was set to Annotative and the "Standard" style wasn't? Did you try setting the annotation scaling in your layout to 1:1?
Member
lakerlkr8
Posts: 4
Registered: ‎02-23-2010
Message 7 of 7 (463 Views)

Re: MTEXT missing in XRefs

02-24-2010 07:39 AM in reply to: lakerlkr8
I believe it is related to the annotative/not annotative settings. I'm not savvy enough to know much about the Annotative Scale. Is this related to the command ANNOAUTOSCALE? In which case, the default is set to -4.

In any case, the style "notes" (which I discovered is a default setting with the template drawing) is defaulted to annotative and "standard" is defaulted not annotative. But going into the text manager, and physically altering the Notes Style to not annotative does not seem to affect the disappearing text (if the text is Notes style -- even if I unselect annotative -- it still does not appear in the x-ref'ed title block in the subsequent layouts).

...still a mystery
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.