AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
*Gene Marz
Post 1 of 6

Funky Layer Name Sorting

392 Views, 5 Replies
02-11-2010 10:51 AM
Working with MEP 2010, but I assume the smae problem exists in plain
AutoCAD.
If you have a '-' in a layer name, it sorts the layers differently in Layer
Manager vs. the pull-down for layers.
Layer Manager will ignore the '-', and the layer pull-down from the Layers
Ribbon will put those first.
*Dean Saadallah
Post 2 of 6

Re: Funky Layer Name Sorting

02-11-2010 11:55 AM in reply to: *Gene Marz
Did you need to post two screenshots?

--
Dean Saadallah
http://LTisACAD.blogspot.com
--
*Pro
1,814 Posts
80 Kudos
Registered: ‎12-08-2003
Post 3 of 6

Re: Funky Layer Name Sorting

02-11-2010 11:55 AM in reply to: *Gene Marz
I am using plain vanilla autocad, and my layers are sorted/listed the same no matter how I access them. Maybe check the system variable MAXSORT and set it to a higher value, and/or maybe in the Layer Manager you accidentally sorted the layers differently by clicking on the NAME header.

Re: Funky Layer Name Sorting

02-12-2010 12:58 AM in reply to: *Gene Marz
It all depens how the layers are been sorted in Layer Manager winddow,
Foe Instance if you have ana Xrefs attached and you click on the Xreff
layers(only they are dissplayed in the Layer Manager window) that's what
youi will see in the puldown manu plus the current layer and layer "0".
If you sort the yayers by collour or reverse alphabetical order , Thats how
they will apear in the pulldown menu..

When they are alphabeticly sorted first are the special characters or
punctuation smbols then numbers and letters.. Thats why the layers with
leading "-" comme first.


"Gene Marz" wrote in message
news:6334919@discussion.autodesk.com...
Working with MEP 2010, but I assume the smae problem exists in plain
AutoCAD.
If you have a '-' in a layer name, it sorts the layers differently in Layer
Manager vs. the pull-down for layers.
Layer Manager will ignore the '-', and the layer pull-down from the Layers
Ribbon will put those first.

Re: Funky Layer Name Sorting

02-12-2010 06:26 AM in reply to: *Gene Marz
Gene,

That was "standard" behaviour in v2009, but was fixed in v2010.
I also spotted the problem and posted it in the autodesk.autocad.2009 group
on may 16th 2008 after I notified ADSK ont he issue and got a hilarious
response.

Cheers,

Steven
*Gene Marz
Post 6 of 6

Re: Funky Layer Name Sorting

02-19-2010 08:53 AM in reply to: *Gene Marz
MAXSORT was set to 1000...sorted by names.....

"Steven" wrote in message
news:6335528@discussion.autodesk.com...
Gene,

That was "standard" behaviour in v2009, but was fixed in v2010.
I also spotted the problem and posted it in the autodesk.autocad.2009 group
on may 16th 2008 after I notified ADSK ont he issue and got a hilarious
response.

Cheers,

Steven
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!