AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
New Member
ACAD-User
Posts: 2
Registered: ‎07-15-2011
Message 1 of 2 (376 Views)

Dynamic Block Array display/print error.

376 Views, 1 Replies
07-15-2011 04:24 AM

When creating a dynamic block with various functions including the "ARRAY"function, the array-function doesn't work the way it should.

 

I'll try to discribe it.

 

When I insert the dynamic block into a drawing and adjust a few stretch parameters, which are moving the array function, the base array-drawing is moved but, it's original settings are still being displayed and printed. Regen/redraw does not fix this problem. "RESETDYNAMICBLOCK" fixes this problem, but only once. When I insert the block into the drawing again, the problems returns.

 

I have tried to work around it by creating custom buttons and add the commando RESETDYNAMICBLOCK; to it, but this means every block you have to insert needs an extra confirmation. I'm trying to create drawings at work to simplify every drawing, so I'm trying to reduce the amount of handlings to adjust the drawing.

 

Using the "RESETDYNAMICBLOCK" function and  "WBLOCK" also doesn't fix the problem.

 

Reducing the number of parameters does fix the problem, but that reduces the efficiency of the drawing. At the moment the drawing contains 22 parameters.

 

When I test the block it's working like a charm, but when I insert it into another drawing, it malfunctions. I can add as many paramters to the drawing as I'd like, as long as it isn't an "ARRAY"parameter.

 

I hope anyone can help. I've been trying it for about three weeks now and I'm out of ideas.

 

I'm currently using an HP Intel Core 2 1.87Ghz with 2gig internal memory. Operating system is Windows 7 Enterprise 32bit.

Videocard is Intel Q965 onboard. Version AutoCAD 2010.

 

The problem persists on diffirent computers of the same type. I haven't tried it on an entirely different system.

 

Forgive me if my english is not perfect. It ain't my native language.

 

Kind Regards,

 

Arjan

 

 

New Member
ACAD-User
Posts: 2
Registered: ‎07-15-2011
Message 2 of 2 (360 Views)

Re: Dynamic Block Array display/print error.

07-15-2011 05:57 AM in reply to: ACAD-User

I've added a picture of the situation.

 

Left you'll see the freshly inserted block. Right you'll see the Block which have been reset. All parameters are alike.

 

The situation on the left happens when changing the parameter pointed out by the arrow. In this case changing it from 160 to 300.

 

Hope this helps.

 

Kind Regards,

 

Arjan

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.