AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
Active Member
8 Posts
1 Kudo
Registered: ‎05-31-2011
Post 1 of 28
Accepted Solution

Configure Proxy for Autodesk Account in AutoCAD 2012

4632 Views, 27 Replies
05-31-2011 11:23 PM

Hi together,

 

Thanks to this KB-article (http://usa.autodesk.com/getdoc/id=TS16732564) I managed it to get the Autodesk Exchange running but it doesn't affect the Autodesk Account.

 

Can anybody tell me, which Server (or Servers) are connected when a user tries to log into his Autodesk Account through AutoCAD 2012?

 

Thanks in Advance, best regards from Austria,

Julius



Hi Julius,

 

I consulted our development team on this and they suggested you should add the following to the exceptions for your proxy:

 

*.autodesk.com

*.cloudfront.net

*.google-analytics.com

 

Does this make a difference?

 

Best regards,

Silvia



Silvia Menon
Support Specialist
Product Support
Autodesk, Inc.


http://www.autodesk.com/autocad-support

Hi Julius,

 

unfortunately IP addresses are not an option, you can find more details about this here:

http://revitclinic.typepad.com/my_weblog/2011/07/conceptual-energy-analysis-login-through-proxy-servers.html 

 

(The settings discussed are not specific only to Conceptual Energy Analysis).

 

You could also try to force the local proxy setting in winhttp calls through the command line:

 

netsh winhttp set proxy myproxy:smileytongue:ortnumber  (change myproxy:smileytongue:ortnumber  accordingly)

 

If all this does not help, could you log a support issue in Subscription Center, so we can have a closer look into your specific environment and settings?

 

Best regards,

Silvia



Silvia Menon
Support Specialist
Product Support
Autodesk, Inc.


http://www.autodesk.com/autocad-support

 

 

hello Luke Hogan

 

 

 

 

 

 

To check if acad.exe is sending the http/https request through the proxy you can run procmon, filter for acad.exe (process name) and get the Network connections,

All the connections shown in the procmon should be to the proxy server, and not to the actual Autodesk servers.

 

If it is to the Autodesk servers, Try to manually configure IE proxy settings, OR  you can try the netsh command mentioned earlier. All online components within acad.exe are using the IE’s proxy settings.

 

If it is sending to the proxy server, please check the proxy server log to see why the connection is denied. (Normally due to authentication issue, so you need to create/move the rules accordingly)

 

 

With the following statement , if you are referring IE excpetion rule, this would not work.

 

“I have entered the 3 web domains into our proxy exceptions but this didn't work”

 

If you are referring proxy exception in the client (IE proxy settings), this is not a solution as this will create the above

behavior, and the main firewall will block this traffic (which is evident from your statement about “Security issues”)

 

 


 

To conclude, as long as IE’s proxy settings are done properly and proxy server has exception rules to allow 3 domains without Authentication (anonymous access) all acad.exe 2012 online access should work

Finally fixed it!  (with a little help from the proxy vendors)

 

Autocad is having trouble with the authentication method (user authentication), so an exception needed to be made on the proxy server to allow authentication via computer IP address instead. 

 

 

I hope this information is helpful to someone  :smileyhappy:

Yes, It appears AutoCAD does NOT send any authentication.

If your proxy server requires Authentication then no internet appears possible inside AutoCAD.

The only option you have is to stop your proxy server from asking for a username. Usually proxy servers ask for a user name to log which users are visiting which sites. Many proxy servers allow you to turn this off.

To fix this for Microsoft ISA 2004  or ISA 2006 proxies, the outgoing HTTP rules need to be set to 'ALL USERS' and not 'ALL AUTHENTICATED USERS'. In ISA 'All Authenticated Users' will force the application to supply a username and password.

I think this does need Autodesk to issue a fix. The fix should be simple (just push the currently logged in username and password) or have a box inside the autocad options to supply the authentication details,

 

Product Support
182 Posts
25 Kudos
Registered: ‎06-11-2007
Post 2 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-02-2011 04:18 AM in reply to: Juliustiberius

Hi Julius,

 

I am not sure which Autodesk Account this relates to - is the issue that you cannot sign into Subscription Center from AutoCAD 2012?

 

Could you post a screenshot of what you are seeing?

 

Best regards

 



Silvia Menon
Support Specialist
Product Support
Autodesk, Inc.


http://www.autodesk.com/autocad-support

Active Member
8 Posts
1 Kudo
Registered: ‎05-31-2011
Post 3 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-02-2011 10:51 PM in reply to: Juliustiberius

Hi,

 

thanks for your reply. Please find attached a screenshot. Is AutoCAD using the windows proxy-settings? If so, which address do I need to pass by (it's not *.autodesk.com)?

 

In the meantime I found out, that AutoCAD 2012 tries to make a https connection to 216.137.61.237 which belongs to Amazon-S3 cloudfront.net Service. I also tried to bypass these addresses at our proxy - but without success.

 

Thanks in advance for further assistance,

best regards from Austria,

Julius

Active Contributor
37 Posts
1 Kudo
Registered: ‎02-14-2008
Post 4 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-02-2011 10:56 PM in reply to: Juliustiberius

Hello

He says the picture see here


 

 

Hallo

 

Er meint das hier siehe Bild

DH
Active Contributor
37 Posts
1 Kudo
Registered: ‎02-14-2008
Post 5 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-10-2011 01:42 AM in reply to: Juliustiberius

Hi there Can not Help It is very important to us    

 

Hallo Kann da keiner Helfen, ist sehr wichtig für uns

DH
Product Support
182 Posts
25 Kudos
Registered: ‎06-11-2007
Post 6 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-10-2011 02:41 AM in reply to: Juliustiberius

Hi Heinz,

 

I am sorry for the waiting time!

 

What I found out so far is that the settings for the proxy should be the same for Autodesk Exchange and for the access to the Autodesk Account.

 

So the problem very likely is not in the proxy settings, but somewhere else.

 

We have seen some instances where the customer's User ID turned out to be the issue, because there were special character in it, for example an "@".

If this applies to you, could you please try the following:

 

  • Log into your Autodesk Account via the Web (for example through the Forum)
  • Go to "Edit Account information" and change the User ID to one that does not have any special characters
  • Log out again
  • Attempt to log in from the AutoCAD Product Menu

Does it work now?

 

Ich hoffe es hilft!

 

Best regards / Viele Grüße

Silvia



Silvia Menon
Support Specialist
Product Support
Autodesk, Inc.


http://www.autodesk.com/autocad-support

 

 

Active Member
8 Posts
1 Kudo
Registered: ‎05-31-2011
Post 7 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-14-2011 03:45 AM in reply to: Silvia.Menon

Hi,

 

this isn't our issue. We do not have the possibility to enter our login information (as shown on the attached screenshot), as AutoCAD does not get the internet connection, because it does not use our proxy server.

 

Where to edit the proxy settings for AutoCAD 2012?

 

 

Hi,

bei unserem Problem geht's darum, dass wir gar nicht die Login-Information eingeben können (siehe Screenshot), weil AutoCAD keine Internetverbindung bekommt, da es nicht unseren Proxyserver benutzt!

 

Wo werden in AutoCAD 2012 die Proxy-Einstellungen geändert?

Active Contributor
37 Posts
1 Kudo
Registered: ‎02-14-2008
Post 8 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-26-2011 12:32 AM in reply to: Juliustiberius

Hi there Can not Help It is very important to us    

 

Hallo Kann da keiner Helfen, ist sehr wichtig für uns



DH
Product Support
182 Posts
25 Kudos
Registered: ‎06-11-2007
Post 9 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-27-2011 04:16 AM in reply to: cadheinz

Hi Heinz,

 

please can you give some more details about your proxy configuration, so that we can understand why the settings from TS16732564 don't work for you?

 

Are you using Proxy authentication where the users have to enter a password to get to the internet?

 

If you are not comfortable giving details in the forum, please log a support case via Subscription Center and I will pick it up so we can communicate directly via phone or email.

 

Best regards,

Silvia



Silvia Menon
Support Specialist
Product Support
Autodesk, Inc.


http://www.autodesk.com/autocad-support

Active Member
8 Posts
1 Kudo
Registered: ‎05-31-2011
Post 10 of 28

Re: Configure Proxy for Autodesk Account in AutoCAD 2012

06-30-2011 02:24 AM in reply to: Juliustiberius

Hi,

 

the Proxyserver we use is "M86 Security - WebMarshal" Version 6.5.6.

 

The users do not need to ener username and password, as this software is using the Windows active directory credentials so verify the user.

 

If you need additional details, please let me know!

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!