AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
Member
edh123
Posts: 4
Registered: ‎08-16-2010
Message 1 of 9 (46,435 Views)
Accepted Solution

AutoCAD 2011 Mouse Wheel Pan Not Working

46435 Views, 8 Replies
08-17-2010 08:33 AM

I just installed AutoCAD 2011 (32-bit on Windows XP Pro) and my mouse wheel pan capability is not working.  I have already confirmed that my Mbuttonpan variable is set to 1.  When I press my mouse wheel button I see the 'hand icon' for a moment before my cursor returns to the crosshairs. The mouse wheel zoom works just fine, and the pan function still works on my old 2010 install.

 

Does anyone have any idea what is wrong?

Go to your mouse settings (usually in Control Panel) and make sure the mouse wheel click function is set to act as a middle button function.

 

 

Valued Mentor
stevenelliott3894
Posts: 474
Registered: ‎06-14-2010
Message 2 of 9 (46,410 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

08-17-2010 10:49 AM in reply to: edh123

Go to your mouse settings (usually in Control Panel) and make sure the mouse wheel click function is set to act as a middle button function.

 

 

Steven Elliott

When I was a little bitty boy, my grandmother bought me a cute little toy. Silver bells hangin' on a string... she told me it was my ding-a-ling-a-ling!
Member
edh123
Posts: 4
Registered: ‎08-16-2010
Message 3 of 9 (46,404 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

08-17-2010 10:58 AM in reply to: stevenelliott3894

That fixed it, thank you!

New Member
markaudimer
Posts: 1
Registered: ‎12-17-2011
Message 4 of 9 (38,684 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

12-17-2011 04:49 AM in reply to: stevenelliott3894

How about in Vista?

Valued Mentor
stevenelliott3894
Posts: 474
Registered: ‎06-14-2010
Message 5 of 9 (38,640 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

12-19-2011 05:33 AM in reply to: markaudimer

Same thing applies to XP, Vista and Windows 7.

 

Steven Elliott

When I was a little bitty boy, my grandmother bought me a cute little toy. Silver bells hangin' on a string... she told me it was my ding-a-ling-a-ling!
Member
geewi00
Posts: 5
Registered: ‎01-03-2012
Message 6 of 9 (38,348 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

01-03-2012 11:26 AM in reply to: stevenelliott3894

I'm running autocad on my mac. Autocad 2011. Logitech Mouse M500. Mbuttonpan configured on 1. Latest logitech driver downloaded. Configured the scrollbutton as click with middle.

Still not working. I cannot pan with the middels mousebutton (scroll button)

Anyone suggestions?

 

Thanks,

 

Geert

Member
geewi00
Posts: 5
Registered: ‎01-03-2012
Message 7 of 9 (38,343 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

01-03-2012 11:37 AM in reply to: edh123

Stange... When I connect my old mouse (logitech M400), It works fine.... The logitech driver automaticly detects it's the M400 and not the M500. I select the 'click with middle' option under the wheel button and all is fine.... Why doesn't it work with the newer logitech mouse?

New Member
RJ-KLJ
Posts: 1
Registered: ‎02-03-2012
Message 8 of 9 (37,306 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

02-03-2012 02:38 PM in reply to: geewi00

Had the same problem today.

The only solution was to assign the middle wheel button #3 as "Generic Button" under the Setpoint Settings for your Logitech mouse.

 

Go back into CAD program and ensure mbuttonpan is set to (1)

 

Good luck

 

New Member
shauntee
Posts: 1
Registered: ‎11-04-2013
Message 9 of 9 (48 Views)

Re: AutoCAD 2011 Mouse Wheel Pan Not Working

12-26-2014 07:10 AM in reply to: RJ-KLJ

in Setpoint screen, set button 3 to "generic button", set side scroll buttons 6 and 7 to "do nothing". that is the only thing that worked for me

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.