AutoCAD 2010/2011/2012

AutoCAD 2010/2011/2012

Reply
*Expert Elite*
GTVic
Posts: 929
Registered: ‎09-07-2004
Message 1 of 5 (1,118 Views)
Accepted Solution

Arial Text in Block Looks Bold when Rotated 90

1118 Views, 4 Replies
04-30-2012 05:38 PM

We have some blocks that have static text labels on the left and numeric attributes on the right. When these blocks are rotated so the text is near vertical the static text has a bold appearance.

 

If you explode/burst the block then this 'bold' appearance goes away. If you rotate the text to normal then the effect disappears as well. The bold appearance shows up on a plot as well. The effect is subtle at times but noticeable.

 

Sample drawing attached, see the block near the top of the drawing and a copy of it rotated to normal. Use the BURST command on the block on the left to see the change.

 

ArialBold.jpg

The response from Autodesk to my subscription support request is that this is a known issue.

 

The more people that report problems related to this issue, the more likely it is that it will be addressed.

*Expert Elite*
pendean
Posts: 23,722
Registered: ‎11-06-2003
Message 2 of 5 (1,103 Views)

Re: Arial Text in Block Looks Bold when Rotated 90

05-01-2012 04:53 AM in reply to: GTVic

TTF fonts do that if Z height is anything other than zero: SHX fonts don't have this issue.

Explore using FLATTEN express tool.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
*Expert Elite*
3wood
Posts: 1,152
Registered: ‎03-25-2009
Message 3 of 5 (1,096 Views)

Re: Arial Text in Block Looks Bold when Rotated 90

05-01-2012 06:52 AM in reply to: GTVic

If current UCS is not WCS and the Z axis of UCS is not vertical, the extrusion of objects changes after rotation.

This is also one of the reasons Mtexts change appearence after printing.

Please try CHZ20.vlx to reslove it.

 

3wood

CAD KITS

*Expert Elite*
GTVic
Posts: 929
Registered: ‎09-07-2004
Message 4 of 5 (1,086 Views)

Re: Arial Text in Block Looks Bold when Rotated 90

05-01-2012 11:40 AM in reply to: pendean

The FLATTEN command resolves the issue but it does it by creating a new copy of the block with a new name with all of the internal entities changed to yellow instead of BYBLOCK and all entities in the block are now rotated and scaled to match the rotation and scale of the previous block insertion. The new block is inserted with rotation 0 on layer 0.

 

The side effects of the FLATTEN command are not acceptable. The CHZ20 command had no effect.

 

It appears as though text in a block that is rotated because of the block insertion is affected. Attributes are not affected even though they are using Arial. There is no issue with UCS or Z or extrusion as the UCS is WORLD and PLAN is CURRENT UCS and I can take the flattened version and adjust the affected properties and the problem comes back.

 

The only solution in my case appears to be to make all of the labels on the left side of the block into attributes. I can't even make them constant attributes, that doesn't work. So preset attributes is the solution for now. My guess is that this is because attributes are adjustable, AutoCAD renders them differently, probably slows down the drawing.

*Expert Elite*
GTVic
Posts: 929
Registered: ‎09-07-2004
Message 5 of 5 (1,053 Views)

Re: Arial Text in Block Looks Bold when Rotated 90

05-07-2012 11:09 AM in reply to: GTVic

The response from Autodesk to my subscription support request is that this is a known issue.

 

The more people that report problems related to this issue, the more likely it is that it will be addressed.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.