AutoCAD 2007/2008/2009

AutoCAD 2007/2008/2009

Reply
Contributor
madpanda
Posts: 16
Registered: ‎05-07-2008
Message 1 of 7 (321 Views)

Takes a long time to delete or copy objects

321 Views, 6 Replies
04-07-2009 08:36 AM
I have a drawing that I created from scratch in 2008, and when I need to delete a circle or a polygon/polyline the program will lock-up and run my processor to almost max, (quad core) and then minutes later the said objects are deleted, and I can view, the drawing, pan zoom, and move most objects without any issues. I thought maybe there was some sort of corruption in the actual objects, so I made a vba script to redraw the entities and delete the existing ones. But even the new entities will some how cause the same issues. (and sometimes it will lock up with the vba script) I have tried saving it to dxf, opening it in 2009, and 2010, recovering the file, and auditing it in all versions also. This is a huge drawing package, but I have worked with larger. There seems to be no rhyme or reason with these entites. I have also opened the file on other computers, fast and slow, and they all act the same. Has any one ever had this kind of issue ? or have any Ideas ?
*Dave Drahn
Message 2 of 7 (321 Views)

Re: Takes a long time to delete or copy objects

04-07-2009 09:37 AM in reply to: madpanda

Sounds like the scalelistedit problem.

Try SCALELISTEDIT RESET


style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
I
have a drawing that I created from scratch in 2008, and when I need to delete
a circle or a polygon/polyline the program will lock-up and run my processor
to almost max, (quad core) and then minutes later the said objects are
deleted, and I can view, the drawing, pan zoom, and move most objects without
any issues. I thought maybe there was some sort of corruption in the actual
objects, so I made a vba script to redraw the entities and delete the existing
ones. But even the new entities will some how cause the same issues. (and
sometimes it will lock up with the vba script) I have tried saving it to dxf,
opening it in 2009, and 2010, recovering the file, and auditing it in all
versions also. This is a huge drawing package, but I have worked with larger.
There seems to be no rhyme or reason with these entites. I have also opened
the file on other computers, fast and slow, and they all act the same. Has any
one ever had this kind of issue ? or have any Ideas ?
Active Member
joey.stanley
Posts: 6
Registered: ‎12-17-2008
Message 3 of 7 (321 Views)

Re: Takes a long time to delete or copy objects

04-07-2009 11:23 AM in reply to: madpanda
I was have this issue, along with a few others like a C++ runtime error after AutoCAD crashed if my group of selected objects was to large...
Anyway, we are still verifying the fix but check this out as a potential solution:
http://discussion.autodesk.com/forums/thread.jspa?messageID=6157550&tstart=0#6157550
Contributor
madpanda
Posts: 16
Registered: ‎05-07-2008
Message 4 of 7 (321 Views)

Re: Takes a long time to delete or copy objects

04-07-2009 11:41 AM in reply to: madpanda
I have tried that, it didn't work, It seems to only be on polylines, and circles.
Contributor
madpanda
Posts: 16
Registered: ‎05-07-2008
Message 5 of 7 (321 Views)

Re: Takes a long time to delete or copy objects

04-07-2009 11:51 AM in reply to: madpanda
I read up on that link, thanks, I'm not getting any run time errors, autocad does resolve after some time, and this is on a specific file, so I don't think it's autocad itself. Thanks for the input. Also I have tried wblocking into multiple files and reinserting into a new drawing and the issue still seems to randomly appear
Active Member
joey.stanley
Posts: 6
Registered: ‎12-17-2008
Message 6 of 7 (321 Views)

Re: Takes a long time to delete or copy objects

04-07-2009 12:29 PM in reply to: madpanda
If you have Communication Center turned off you may not see the runtime error. My AutoCAD was only crashing for really big copy attempts, smaller stuff it handled fine, but there was a medium that was plain slow. My large drawing (5000K) which contains the majority of my blocks for my custom Tool Palettes was the worst at this and was nearly impossible to work with.
If you search your C:\Windows\system32 and don't find any .dil file extensions then that's definitely not your problem. NOTE, that's and i in the center, not an L.
Contributor
madpanda
Posts: 16
Registered: ‎05-07-2008
Message 7 of 7 (321 Views)

Re: Takes a long time to delete or copy objects

04-07-2009 12:54 PM in reply to: madpanda
I have checked the dil-dll issue, and that is not the problem. the file is large. I can copy just fine, it's erasing or deleting them thats the problem, it can be just one circle or polyline/polygon and the issue would arise, but it's not with every polygon or circle. I can replicate the issue consitantly if I open the drawing, and try to delete certain circles. even if it were wblocked. here is a small portion wblocked, and I have a leader to a cirlce that 9 out of ten times causes the problem
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.