AutoCAD 2007/2008/2009

AutoCAD 2007/2008/2009

Reply
New Member
1 Posts
0 Kudos
Registered: ‎01-31-2012
Post 11 of 15

Re: Some objects missing when printing

01-31-2012 08:52 AM in reply to: dancruchaga
OK, here's my 2 cents worth. After many days of searching for a solution to this annoying problem, I finally solved it by changing one parameter in the Page Setup dialog. I unchecked 'Plot with plot styles' which automatically checked 'Plot object lineweights'. I left that checked and it worked! I haven't delved into setting up plot styles yet, and this is satisfactory for my purposes, but that seems to be the problem. Somehow some of the grouped objects must have plot styles that don't print. Curiously they do "print" to the PDF in the Nitro PDF "printer" but when I print the PDF itself to a real printer they do not. ???!!!&*$%$#&^%$ With that one change they DO print from the PDF to the real printer. AutoCAD 2010, Nitro PDF Creator, HP C5500 printer.
New Member
2 Posts
0 Kudos
Registered: ‎12-20-2012
Post 12 of 15

Re: Some objects missing when printing

12-20-2012 03:21 PM in reply to: hmj6jmh

I have a simular issue.  I can see the objects, they may be a block or a line, but can not select it.  While I can see it, I can not select it and it will not print.

 

I have tried all the commands that are normally referenced.  I can submit a subset of this drawing for you to play with.

 

The only thing that works is to find a block within the drawing and edit it, you do not really have to modify it, then close the block editor.  The line becomes selectable for a while, then becomes unusable again in a short while.

 

This is only an issue in this one drawing and even if I save as.

Of course, audit has been run, purge, etc.

 

Attached is the dwg file.  The contours herein are a good example.

 

Any clues?

 

*Expert Elite*
9,800 Posts
1,210 Kudos
Registered: ‎06-29-2007
Post 13 of 15

Re: Some objects missing when printing

12-20-2012 10:55 PM in reply to: capdgett2004

Hi,

 

I opened your drawing with AutoCAD 2013 and found more than 400 (selectable) proxy-entities. So that means your drawing was created by an vertical application or that are objects created by an application and this functionality (the application has) is not available now, and that means we can't handle the objects at all as long as we don't have the minimum functionality like object-enabler or the application itself.

 

Looking to the proxy-warnings, the applications used were

Architectural Desktop 2007

Land Desktop 2008

Civil 3D

 

If you have a newer version of AutoCAD then you can run command -EXPORTTOAUTOCAD and the aec-part gets "destrroyed" to single AutoCAD geometry objects. See the attached drawing.

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
New Member
2 Posts
0 Kudos
Registered: ‎12-20-2012
Post 14 of 15

Re: Some objects missing when printing

12-21-2012 09:18 AM in reply to: hmj6jmh

These objects that I sent you were created with Lan Development Desktop 2009, less than 8 days ago.

 

So it is not some issue that is caused by some old program not being available.

 

The objects that are not selectable are civil countour objects.  As stated before, if you edit (ANY) block on the sheet then close the block, you can then select these civil contour objects, however, they still will not print.

 

Is there any other command except Audit that is able to repair objects or a dwg.

 

Thx,

*Expert Elite*
24,211 Posts
1,593 Kudos
Registered: ‎11-06-2003
Post 15 of 15

Re: Some objects missing when printing

12-26-2012 06:40 AM in reply to: dancruchaga
WBLOCK, never SAVEAS, might leave behind the unique problems this one file has.
Regardless of AutoCAD variant being used.
RECOVER command used to open the newly created file is about all you can do, short of destroying the AEC content with -EXPORTTOAUTOCAD command (there is a dash in the command name).
Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post