AutoCAD 2007/2008/2009

Reply
Distinguished Contributor
oopzie
Posts: 152
Registered: ‎08-21-2006
Message 1 of 16 (2,301 Views)

Smooth 3D Solids

2301 Views, 15 Replies
01-21-2009 08:41 PM
Hi

When plotting my curves as a rendered image in presentation quality my (cylinders) are looking quite jagged made up of several line segments, instead of a plain circle.

I have gone through all the display settings and turned up the smoothness, segment in a curve, rendered object smoothness, contour lines per surface to the maximum. I Still get the same result.

I have attached an image also of what i am getting (notice the top left circle).
If anyone has any ideas what to do it would be great.

Thanks

Shaun
Contributor
imdaone
Posts: 22
Registered: ‎12-10-2008
Message 2 of 16 (2,301 Views)

Re: Smooth 3D Solids

01-22-2009 01:24 AM in reply to: oopzie
Try changing your 'Viewres' variable to a higher number, you lose quick zoom

David
*Aug
Message 3 of 16 (2,301 Views)

Re: Smooth 3D Solids

01-22-2009 07:00 AM in reply to: oopzie

facetres    =  5

viewres     =
1,000-20,000

 

Aug
Contributor
MarianDLL
Posts: 13
Registered: ‎02-02-2009
Message 4 of 16 (2,301 Views)

Re: Smooth 3D Solids

02-02-2009 07:49 PM in reply to: oopzie
Well I'm experiencing the same problems these days... I'm working on a small visualization, it contains mostly complex 3D solids which were done using subtracting sweeped objects from primitive solids, etc. No faces or meshes, just solids. I also switched everything to max - mainly RENDER OBJECT SMOOTHNESS = 10. The problem is, when I render a scene, some of the solids are perfectly smooth, while others look terrible. I think the problem is not that simple. I attached a picture so you can take a look. Make sure you zoom at 100%. Take a look at the decorations above the main window. They are perfectly smooth. Aren't they? However the frame of the main circular window is ... let's say 95% smooth. It looks as it's made out of a 100-sided polygon rather than a perfect circle. It's not so bad, you have to take a closer look to notice the small edges... And now take a look at the top of the picture. Can you see all of those small 6-sided arches ? WTF? Why is that? Why some objects are rendered perfectly and others not if the settings are the same? As I said the problem is not that simple, because I rendered this scene several times (50x) using various views and sometimes it was all rendered perfectly and sometimes not. Then I spent few days trying to figure out if it depends on some settings, but unfortunately I have to say it's probably a random process. It's sounds crazy I know but listen. I was trying various combinations like lowering the render object smoothness (like 0.1, 5, 7, 9, 9.999 ) and setting higher contour lines and vice-versa. Trying viewres and every other command I know. Switching on/off indirect illumination, or switching between crop/window/viewport rendering . Like houndred of combinations with shadows on and off, perspective vs parallel projection, even switching off the 3d solid history. Most of the combinations don't make any sense I know but I was just trying.... and I've tried everything believe me. And the result? Random! However I must say: when I rendered the scene using preset views (parallel-front view) or when I switched the shadows off, I got most of the pictures correct (I mean everything in the scene was 100% smooth). On the other hand using perspective projection with shadows on I got like 1 out of 10 pictures rendered correctly. It takes about 8 minutes to render the scene you can see on the attached picture and I spent like 3 days rendering it again and again and I didn't understand what's going on. 2 days ago I finished the modelling part and I did som rendering and I was lucky - most of them were correct (but not all of them). Now I'm planning to add materials and more realistic lights and I'm afraid it will not be just a matter of minutes to get it done.
So I really don't know where the probem is with the 3d solid smoothness. Now you're asking why I wrote all of this if I don't have a clue ... ? Because I want to point at this problem that seems to be more complex and it just can't be solved using some specific settings following the help. I hope someone from autodesk will read this. Only I can say is that rendering in AutoCAD 2008 is really annoying. (if it matters my hardware specification is ASUS F3KA NB with AMD Turion TL60 64-bit dual core processor, 2GB RAM, Win Vista 32bit home premium and ATI 2600 mobility radeon.) So please someone out there if you have any idea please let us know.
BTW I'm working in autocad for 7 years almost every day. I know every version of autocad since the 2000 version. I think that it's getting worse and worse with the never versions of acad. Sorry to say. However it's still the best modelling platform . Ever.
*Aug
Message 5 of 16 (2,301 Views)

Re: Smooth 3D Solids

02-03-2009 06:09 AM in reply to: oopzie

What is your facetres set to?

 

Aug
Contributor
MarianDLL
Posts: 13
Registered: ‎02-02-2009
Message 6 of 16 (2,299 Views)

Re: Smooth 3D Solids

02-03-2009 08:45 AM in reply to: oopzie
Currently it is set to 10, but as I said I tried for example using 5. And it was only worse. Do you have any idea?
I think it is AutoCAD's 2008 problem. Maybe trying 2007 ???
*Bill Gilliss
Message 7 of 16 (2,299 Views)

Re: Smooth 3D Solids

02-03-2009 08:51 AM in reply to: oopzie
MarianDLL wrote:
> Currently it is set to 10, but as I said I tried for example using 5.
> And it was only worse. Do you have any idea? I think it is AutoCAD's
> 2008 problem. Maybe trying 2007 ???

FACETDEV is also involved -- the distance an approximated facet of a
curved object may deviate from the mathematically-defined surface. Try
make this much smaller.
Contributor
MarianDLL
Posts: 13
Registered: ‎02-02-2009
Message 8 of 16 (2,299 Views)

Re: Smooth 3D Solids

02-03-2009 12:34 PM in reply to: oopzie
FACETDEV is probably not an Acad 2008 command coz it says is't an unknown command. However i've tried FACETRATIO command which says: FACETRATIO Controls the aspect ratio of faceting for cylindrical and conic solids. A setting of 1 increases the density of the mesh to improve the quality of rendered and shaded models.

0
Creates an N by 1 mesh for cylindrical and conic solids

1
Creates an N by M mesh for cylindrical and conic solids

How can you set the "N" and "M" values?

It didn't work either.
Contributor
MarianDLL
Posts: 13
Registered: ‎02-02-2009
Message 9 of 16 (2,299 Views)

TAKE ATTENTION PLEASE !!!!

02-03-2009 02:00 PM in reply to: oopzie
I made a proof for all of you that smoothing out 3D solids in autocad is a tricky or better say a random process. Take a look at the picture.
Thanks
Contributor
fpostadan
Posts: 14
Registered: ‎11-19-2008
Message 10 of 16 (2,299 Views)

Re: Smooth 3D Solids

02-03-2009 04:43 PM in reply to: oopzie
Shaun,

Have you tried the command "vsedges" and set it to 0

Also Facetres you want it at 10 which is the max. I thin you mentioned that yours is set to 10. Leave it at that.

Try that.
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.