AutoCAD 2007/2008/2009

AutoCAD 2007/2008/2009

Reply
Active Member
Jbrauer
Posts: 6
Registered: ‎10-15-2002
Message 1 of 2 (81 Views)

problems with icons when migating mnu to cui

81 Views, 1 Replies
10-23-2008 02:11 AM
I have a problem when i migrate my Acad2005 MNU file to Acad2009 CUI.

- hard to explain the problem -

In the MNU file I use the iconA0.bmp ... to iconA4.bmp as icons for paper-setup scripts.

When migratet til CUI the script is correct and are working, the icon name are correct and the path point at the correct folder - But in AutoCAD only the iconA3 is shown for all icons.

When I edit the CUI file and change one of the wrong icons to something new - ALL the wrong icons change to the new icon.


what do I wrong
Distinguished Contributor
mwgrutter
Posts: 1,190
Registered: ‎06-03-2005
Message 2 of 2 (81 Views)

Re: problems with icons when migating mnu to cui

10-23-2008 10:12 AM in reply to: Jbrauer

I had the same (or similar) problem when migrating to 2006 (original version to use the CUI interface).

The MNU/MNS text files required different formatting of path names than the CUI editor. Those formats were not automatically adjusted by the editor during conversion to CUI.

After F-ing around for days trying to correct the path statements, I finally just removed the paths from the image lines in each command, placed all custom Icon files in one place and called that location in the Support Paths in OPTIONS>Files.

Haven't had a problem since.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Michael Grutter
Cedar Engineering and Design Service
http://www.cedarengineering.com

Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.