AutoCAD 2007/2008/2009

Reply
Mentor
apanbasu
Posts: 239
Registered: ‎11-12-2004
Message 1 of 9 (692 Views)
Accepted Solution

LTSCALE

692 Views, 8 Replies
01-13-2013 02:05 PM

I have drawn a polygene (phantom) with scale factor 1. This is part of legends File. When I xrefed the file the line becomes solid. The vewport is drawn at 1/8th scale. There also The line remains solid. My MSltscale and PSLtscale are both=1. I tried change the Ltscale to 96. In model space the lines showed up as phantom. On the P Space - the lines remained solid.

 

The working unit is Feet. This is is Federal Project. That is the standard I have to use.

How do I show the phantom lines in the Paperspace?

You really have some work to do to clean this drawing up.  Your scales and LTSCALES are all over the place.  Nothing is consistant when it should be to be able to print properly.

 

The lines in the actual drawing itself have mostly an LT scale of 1 but I found some set to 0.5 also. 

 

The XREF has an LT scale of 1 for 4188 items, LT scale of 10 for 3994 items, and there are 12 items with a 12 LT scale.  I didn't want to go any further to guess what other LT scales there might be.  The phantom line you mentioned is one of the 12 set to a LT scale of 12.

 

The upper viewport scale is "CUSTOM" but is close to 1:131.5.  Whatever scale that is supposed to be.  I guess someone just "scroll wheeled" it.

The lower viewport is actually set to 1/8" = 1' -0" so that is good.  When you set your Global LTSCALE to 0.125 the "DOT DASH" and the thick phantom lines probably show up properly in this viewport.  The upper viewport is still not right tho as far as I can tell.  They should look exactly the same no matter what scale the viewports are set to all things being equal.

 

I would start by making all items' linetype scales equal. Set the PSLTSCALE to 1, LTSCALE to 1 etc, etc, etc, which has already been suggested.  And then see how you stand.  You may have to change Linetypes to correct individual lines which don't match.  I'm thinking someone used the 2X or .5 or even created custom Ltypes because they did't know how to check to see what the drawing LT scale was and couldn't get them to "look" as they should.  So "some" lines don't match others on that same layer.  Maybe?  What a mess!

Dean:

I changed all Line scale to 1 thru Properties already. I have also changed Pline scale to 1 also and it is working now. I am using a Template given to me for this project. So, I had no idea how the Template was set.

Anyway thanks for your help.

Ahh the idea with CANNOSCALE in modelspace is, if you think what you are drawing will be eventually viewed in a 1/4"=1'-0" viewport in paperspace, then you set your modelspace CANNOSCALE to 1/4"=1'-0". Then later in the same drawing, if what you are drawing in modelspace will be in a 3" scale detail viewport in paperspace, then you set the modelspace CANNOSCALE to 3"=1'-0". You can do this on the fly. it does not affect the fact you are still modelng in 1:1 -- only the way it is viewed in modelspace. This gives you a preview of how things will look through a paperspace viewport, even thought you are in modelspace. The lines will adjust automatically. Other annotative objects will not change unless your settings allow the addition of new scales to their properties when the CANNOSCALE is changed. Part of the idea here has to do with having it set beforehand, and then annotative blocks, text, hatches, dimensions etc will insert at the proper viewing scale (as opposed to super huge or super tiny, or hidden linetypes that appear continuous).

*Expert Elite*
pendean
Posts: 23,364
Registered: ‎11-06-2003
Message 2 of 9 (665 Views)

Re: LTSCALE

01-14-2013 05:45 AM in reply to: apanbasu

What if LTSCALE was 1?

How about 0.125?

REGENALL after each change, or click over to Model then bakc to paperspace.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Mentor
apanbasu
Posts: 239
Registered: ‎11-12-2004
Message 3 of 9 (658 Views)

Re: LTSCALE

01-14-2013 07:34 AM in reply to: apanbasu

Dean:

I have done what you have suggested without luck. I have attached ZIP file for your convenience to see what setting is causing me the problem. I am having Problem with A-WALL-1HR Layer.  I have Scale factor of 1 of the Polyline in the HVAC Legends. Vieport is at 1/8th Scale. The xrefed in the Model Space also shows solid lines. I have the Model Space LTSCALE at 4.

Distinguished Mentor
steve216586
Posts: 998
Registered: ‎07-10-2007
Message 4 of 9 (627 Views)

Re: LTSCALE

01-15-2013 11:01 AM in reply to: apanbasu

You really have some work to do to clean this drawing up.  Your scales and LTSCALES are all over the place.  Nothing is consistant when it should be to be able to print properly.

 

The lines in the actual drawing itself have mostly an LT scale of 1 but I found some set to 0.5 also. 

 

The XREF has an LT scale of 1 for 4188 items, LT scale of 10 for 3994 items, and there are 12 items with a 12 LT scale.  I didn't want to go any further to guess what other LT scales there might be.  The phantom line you mentioned is one of the 12 set to a LT scale of 12.

 

The upper viewport scale is "CUSTOM" but is close to 1:131.5.  Whatever scale that is supposed to be.  I guess someone just "scroll wheeled" it.

The lower viewport is actually set to 1/8" = 1' -0" so that is good.  When you set your Global LTSCALE to 0.125 the "DOT DASH" and the thick phantom lines probably show up properly in this viewport.  The upper viewport is still not right tho as far as I can tell.  They should look exactly the same no matter what scale the viewports are set to all things being equal.

 

I would start by making all items' linetype scales equal. Set the PSLTSCALE to 1, LTSCALE to 1 etc, etc, etc, which has already been suggested.  And then see how you stand.  You may have to change Linetypes to correct individual lines which don't match.  I'm thinking someone used the 2X or .5 or even created custom Ltypes because they did't know how to check to see what the drawing LT scale was and couldn't get them to "look" as they should.  So "some" lines don't match others on that same layer.  Maybe?  What a mess!

*Expert Elite*
pendean
Posts: 23,364
Registered: ‎11-06-2003
Message 5 of 9 (589 Views)

Re: LTSCALE

01-17-2013 06:22 AM in reply to: apanbasu

See attached screenshot of PROPERTIES to support the description of the problems noted above.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Mentor
apanbasu
Posts: 239
Registered: ‎11-12-2004
Message 6 of 9 (581 Views)

Re: LTSCALE

01-17-2013 07:06 AM in reply to: apanbasu

Dean:

I changed all Line scale to 1 thru Properties already. I have also changed Pline scale to 1 also and it is working now. I am using a Template given to me for this project. So, I had no idea how the Template was set.

Anyway thanks for your help.

*Expert Elite*
Bob_Zurunkle
Posts: 1,053
Registered: ‎03-24-2011
Message 7 of 9 (503 Views)

Re: LTSCALE

01-29-2013 09:34 AM in reply to: apanbasu

Just out of curiosity, is your CANNOSCALE set to 1:1? This has been often overlooked by pre-2008 users when first encountering annotative objects in 2008...

 

The issue is when it is left at 1:1...

If by some odd chance my nattering was useful -- that's great, glad to help. But if it actually solved your issue, then please mark my solution as accepted :smileyhappy:
Mentor
apanbasu
Posts: 239
Registered: ‎11-12-2004
Message 8 of 9 (497 Views)

Re: LTSCALE

01-29-2013 09:49 AM in reply to: Bob_Zurunkle

After I changed all LTSCALE to 1 as Dean suggested - my problems were resolved.  I set the CANNOSCALE to None as you have suggested to my drawing. Hope this will not create any problem in the future.

I am 76 years old and still do some work. You guys are great help to me.

Many many thanks.  

*Expert Elite*
Bob_Zurunkle
Posts: 1,053
Registered: ‎03-24-2011
Message 9 of 9 (467 Views)

Re: LTSCALE

02-08-2013 09:34 AM in reply to: apanbasu

Ahh the idea with CANNOSCALE in modelspace is, if you think what you are drawing will be eventually viewed in a 1/4"=1'-0" viewport in paperspace, then you set your modelspace CANNOSCALE to 1/4"=1'-0". Then later in the same drawing, if what you are drawing in modelspace will be in a 3" scale detail viewport in paperspace, then you set the modelspace CANNOSCALE to 3"=1'-0". You can do this on the fly. it does not affect the fact you are still modelng in 1:1 -- only the way it is viewed in modelspace. This gives you a preview of how things will look through a paperspace viewport, even thought you are in modelspace. The lines will adjust automatically. Other annotative objects will not change unless your settings allow the addition of new scales to their properties when the CANNOSCALE is changed. Part of the idea here has to do with having it set beforehand, and then annotative blocks, text, hatches, dimensions etc will insert at the proper viewing scale (as opposed to super huge or super tiny, or hidden linetypes that appear continuous).

If by some odd chance my nattering was useful -- that's great, glad to help. But if it actually solved your issue, then please mark my solution as accepted :smileyhappy:
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!