AutoCAD 2004/2005/2006

AutoCAD 2004/2005/2006

Reply
*Trey Monsour
Message 1 of 23 (2,486 Views)

Refedit Problems - cannot save changes?!

2486 Views, 22 Replies
05-03-2005 11:37 AM
Lately I've been getting this error more often than before. It happened
every once in a while using r2005, but seems to be worse now in r2006. I'm
wondering if any of you have experienced this, and if so... what can you do
about it?

When I go to refedit a block, a lot of times I'll add things to the working
set, then save/exit the refedit section. I'm doing this on blocks within
the drawing - not on xrefs ...

Here's the message in the pop-up dialog box after trying to save changes to
my refedit session:

Cannot save back changes because objects in the working set reference
objects outside the working set. This Refedit session is still active.
Press F2 after dismissing the dialog to see the list of missing references.

Here's what's in the text window after that:

Command: _refclose
Enter option [Save/Discard reference changes] : _sav
Errors found in references to other objects:
** Application reference missing: AcDbBlockRepETag, to AcDbLine.
Regenerating model.
Command:


I think I understand what the first message means, but I can assure you that
what I've added to the block during the refedit session is simple geometry
that is not in a group or block. My only guess is that some of the geometry
may have been associated with a hatch boundary or something like that...

But, as for the message in the text window ... wow, yah... that explains
it! As if that message helps someone like me. I'm sure that a lot of
people with programming skills, and with some good LISP background can
figure out what that means ... but not me. Anyway, I'm hoping some of you
have experienced this and can help me out.

Thanks,
Trey
*Ravi Pothineni
Message 2 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

05-03-2005 02:08 PM in reply to: *Trey Monsour
Are you trying to refedit dynamic blocks or legacy blocks?
Can you email me a drawing where the bug is reproducible?

Thanks
Ravi
Autodesk, Inc.

"Trey Monsour" wrote in message
news:4833483@discussion.autodesk.com...
Lately I've been getting this error more often than before. It happened
every once in a while using r2005, but seems to be worse now in r2006. I'm
wondering if any of you have experienced this, and if so... what can you do
about it?

When I go to refedit a block, a lot of times I'll add things to the working
set, then save/exit the refedit section. I'm doing this on blocks within
the drawing - not on xrefs ...

Here's the message in the pop-up dialog box after trying to save changes to
my refedit session:

Cannot save back changes because objects in the working set reference
objects outside the working set. This Refedit session is still active.
Press F2 after dismissing the dialog to see the list of missing references.

Here's what's in the text window after that:

Command: _refclose
Enter option [Save/Discard reference changes] : _sav
Errors found in references to other objects:
** Application reference missing: AcDbBlockRepETag, to AcDbLine.
Regenerating model.
Command:


I think I understand what the first message means, but I can assure you that
what I've added to the block during the refedit session is simple geometry
that is not in a group or block. My only guess is that some of the geometry
may have been associated with a hatch boundary or something like that...

But, as for the message in the text window ... wow, yah... that explains
it! As if that message helps someone like me. I'm sure that a lot of
people with programming skills, and with some good LISP background can
figure out what that means ... but not me. Anyway, I'm hoping some of you
have experienced this and can help me out.

Thanks,
Trey
*Trey Monsour
Message 3 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

05-03-2005 02:36 PM in reply to: *Trey Monsour
Ravi

I've sent you an email with a file attached ... I've explained everything in
the email. You can either return emails to me or post here... I'll be
watching both places. Thanks for checking on this problem.

Trey
Valued Contributor
mrao
Posts: 54
Registered: ‎02-14-2005
Message 4 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

08-04-2005 07:50 AM in reply to: *Trey Monsour
Trey,

Did you get the solution to this problem? I am facing the same issue.

Thanks,
Active Member
Bretth
Posts: 7
Registered: ‎08-04-2005
Message 5 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

08-04-2005 06:59 PM in reply to: *Trey Monsour
I have had this problem many times but seem to have cured it. There seems to be some sort of clash between the variables for entmax and entlim that will not let you add ANY geometry to a refedited block.

We set limits as we start, but no longer do this and it seems to have fixed the problem for us. Are you refediting outside of the actual drawing area you are working in? That was once my problem. Now I do it in place and it has stopped.

Brett Hyland
Valued Contributor
mrao
Posts: 54
Registered: ‎02-14-2005
Message 6 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

08-05-2005 05:31 AM in reply to: *Trey Monsour
Hello Brett,

Thanks for your response. By "working outside the actual drawing area" do you mean beyond the extents of the xref's entities? I guess I was doing that.
Active Contributor
rhuserik
Posts: 30
Registered: ‎10-07-2003
Message 7 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

11-03-2005 08:58 AM in reply to: *Trey Monsour
Did you get a solution to this problem. We are experiencing the same thing.
Active Contributor
rhuserik
Posts: 30
Registered: ‎10-07-2003
Message 8 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

11-03-2005 01:56 PM in reply to: *Trey Monsour
We noticed that this problem started when a hynamic block had be exploded.
Contributor
labeda14
Posts: 17
Registered: ‎07-22-2005
Message 9 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

11-03-2005 02:05 PM in reply to: *Trey Monsour
i am having the same issue!!! help please
Distinguished Contributor
yavid
Posts: 126
Registered: ‎08-06-2004
Message 10 of 23 (2,486 Views)

Re: Refedit Problems - cannot save changes?!

12-13-2005 10:37 AM in reply to: *Trey Monsour
I am experiencing the same problem, did you ever get a solution? I could really use some help on this one.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.