Visual LISP, AutoLISP and General Customization

Visual LISP, AutoLISP and General Customization

Reply
Active Contributor
EKey
Posts: 26
Registered: ‎11-27-2008
Message 1 of 3 (630 Views)

Overkill - command line version problem

630 Views, 2 Replies
12-20-2012 10:28 AM

The message was moved from general AutoCAD 2012 discussion group.

 

Hello,

 

The OVERKILL command has a command line version: -OVERKILL. One of the options of it is "IGNORE". I enter the option and get the prompt:

[None/All/ Color/LAyer/Ltype/ ltScale/LWeight/Thickness/TRansparency/plotSTyle/Material] <Plotstyle>:

 

Here I have a problem. I need to enter a number of choices, e.g. LWeight and Thickness. I can't find a way to do that.

It worked in previous AutoCAD versions. I could enter options demilited with comma and the command accepted all of them. But it doesn't work for AutoCAD 2012.

What can I do to enter a number of the "Ignore" options?

 

I would be appreciated for any help.

Thank you.

E.K.

 

Best Regards,
E.K.
*Expert Elite*
pbejse
Posts: 2,428
Registered: ‎11-24-2009
Message 2 of 3 (600 Views)

Re: Overkill - command line version problem

12-20-2012 08:19 PM in reply to: EKey

EKey wrote:

The message was moved from general AutoCAD 2012 discussion group.

 

Hello,

 

The OVERKILL command has a command line version: -OVERKILL. One of the options of it is "IGNORE". I enter the option and get the prompt:

[None/All/ Color/LAyer/Ltype/ ltScale/LWeight/Thickness/TRansparency/plotSTyle/Material] <Plotstyle>:

 

Here I have a problem. I need to enter a number of choices, e.g. LWeight and Thickness. I can't find a way to do that.

It worked in previous AutoCAD versions. I could enter options demilited with comma and the command accepted all of them. But it doesn't work for AutoCAD 2012.

What can I do to enter a number of the "Ignore" options?

 

I would be appreciated for any help.

Thank you.

E.K.

 


What works if not comma delimited option names? 

Dont have 2012, but in lower versions it works like so

 

(defun c:Test  (/ ss)
      (if (setq ss (ssget ))
            (progn (sssetfirst nil ss)
                   (vla-sendcommand
                         (cond (aDoc)
                               ((setq aDoc
                                           (vla-get-activedocument
                                                 (vlax-get-acad-object))))
                               )
                         "-OVERKILL IGNORE LWeight,Layer  "
                         )
                   )
            )
      (princ)
      )

 

 

Previous -OVERKILL versions show this (2009 Express Tools)

 

[layer,ltype,color,lweight,plotstyle, * (for all)] or "." for none <default>: 

 

You can try and change LWeight,Layer to LWeight,Thickness in the code above and see if it works for you.

 

Active Contributor
EKey
Posts: 26
Registered: ‎11-27-2008
Message 3 of 3 (589 Views)

Re: Overkill - command line version problem

12-21-2012 05:43 AM in reply to: pbejse

 

Previous -OVERKILL versions show this (2009 Express Tools)

 

[layer,ltype,color,lweight,plotstyle, * (for all)] or "." for none <default>: 

 


Thank you for response.

Yes, it worked when the OVERKILL command was a part of  Express Tools. But for AutoCAD 2012 the OVERKILL command is native. It was redesigned and behaves differently is the way that IGNORE options do not work, for me and for now at least.

Best Regards,
E.K.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community