Vault General

Reply
Mentor
kmiller
Posts: 257
Registered: ‎12-17-2007
Message 11 of 17 (186 Views)

Re: move/rename files in vault explanation for 2012

08-26-2011 06:13 AM in reply to: cmcconnell

Thank you for the feedback!

-------------------------------------------------------------------------------------------------

If this response answers your question please click "Accept as Solution".
Valued Contributor
mdurst
Posts: 58
Registered: ‎10-01-2007
Message 12 of 17 (134 Views)

Re: move/rename files in vault explanation for 2012

04-27-2012 08:26 AM in reply to: kmiller

I also think this is a great feature enhancement because of the performance increase except for this problem I have ran into a few times.  Yes, there are best practices to be followed to avoid this, but Vault displays mis-leading information that doesn't appear you can avoid.

 

Here's the scenairo:

 

File that was moved: 300251 & 300258 SLX 14 ENCODER LIFT.IAM

 

Parent File: 300251 & 300258 SLX 14 ENCODER LIFT.IDW

 

Moved From: $\Project\Finished Goods\Projector Lifts\Scissor Lift SL and SLX

 

Moved To: $\Project\Fiinal

 

When opening 300251 & 300258 SLX 14 ENCODER LIFT.IDW, this message is displayed.  This is mis-leading information as it SHOULD be displaying the new path I moved the IAM file to in the Vault.

 

If I say Yes to All, it continues and opens the IAM file from the correct location.


Finished Goods.jpg

 

Here is the bigger problem though:  If the 300251 & 300258 SLX 14 ENCODER LIFT.IAM exists in the location displayed above on my local machine, Inventor will open it from there FIRST before looking anywhere else.

 

So best practice is to:

  1. Move the file in Vault
  2. Delete the local working folder or file that you just moved
  3. Open the Parent File
  4. Yes to All (on the mis-leading information)
  5. And verify it all opened from the new locations (which it should have)

Note: I have ran the Update References command on this 300251 & 300258 SLX 14 ENCODER LIFT.IDW, but this did not change the outcome.

Employee
mikel.martin
Posts: 273
Registered: ‎03-16-2006
Message 13 of 17 (132 Views)

Re: move/rename files in vault explanation for 2012

04-27-2012 08:33 AM in reply to: mdurst

Questions:

 

When opening are you logged into Vault?

Did you use the Open from Vault command or Inventors native open?



Mikel Martin
User Experience Architect
PLM / Data Management
Autodesk, Inc.
Valued Contributor
mdurst
Posts: 58
Registered: ‎10-01-2007
Message 14 of 17 (129 Views)

Re: move/rename files in vault explanation for 2012

04-27-2012 08:40 AM in reply to: mikel.martin

Answers:

Yes, i am logged into the Vault through Vault Explorer and Autodesk Inventor.

 

Using the Vault Explorer to open the File.  Have tried a few methods.

- Right-Click>Get/Check Out to get everything local first (Download Only)

- Right-Click>Open on the 300251 & 300258 SLX 14 ENCODER LIFT.IDW file, Saying Yes or No to check out gives the same result.

 

OR (without the download first)


Right-Click>Open on the 300251 & 300258 SLX 14 ENCODER LIFT.IDW file, Saying Yes or No to check out gives the same result.

Employee
mikel.martin
Posts: 273
Registered: ‎03-16-2006
Message 15 of 17 (125 Views)

Re: move/rename files in vault explanation for 2012

04-27-2012 10:57 AM in reply to: mdurst

Could you try using the Open from Vault within Inventor to open the file?

Do you see the same result?



Mikel Martin
User Experience Architect
PLM / Data Management
Autodesk, Inc.
Valued Contributor
mdurst
Posts: 58
Registered: ‎10-01-2007
Message 16 of 17 (116 Views)

Re: move/rename files in vault explanation for 2012

04-27-2012 01:28 PM in reply to: mikel.martin

The Open from Vault command through Inventor gives me 2 different results on 2 different files that were moved.

 

1. Not All Ref.jpg

 

It continues to open into Inventor with a result like this:

 

Unresolved.jpg

 

 

If I open this same IDW file by right-clicking it and clicking Open while in the Vault explorer it prompts me with the same dialog box from my very first post saying that it needs to download components from the Vault from the original directory it was moved from.

 

2. Opening 300251 & 300258 SLX 14 ENCODER LIFT.IDW through the Open from Vault command inside Inventor, opens just fine without any messages, but this was the IDW I had been working with doing my testing so maybe somehow it updated the links.

 

The other weird thing is, is if I open 300251 & 300258 SLX 14 ENCODER LIFT.IDW by right clicking it in the Vault and saying Open, I still get this dialog box.  Something is definitely off.  If you want to do further testing, I can get us access to the environment and we can setup a time to diagnose the issue and look further into it, so you can see for yourself.  Let me know.

 

Finished Goods.jpg

Mentor
kmiller
Posts: 257
Registered: ‎12-17-2007
Message 17 of 17 (112 Views)

Re: move/rename files in vault explanation for 2012

04-27-2012 01:46 PM in reply to: kmiller

With out a 100% definate answer, I think I have come across this same situation.  I could do some checking if you wanted to confirm results with another system.

-------------------------------------------------------------------------------------------------

If this response answers your question please click "Accept as Solution".

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community