Vault General

Reply
Contributor
ddev
Posts: 11
Registered: ‎12-03-2008
Message 1 of 5 (772 Views)

Vault 2012 and w3wp.exe and not being able to check items into Vault.

772 Views, 4 Replies
10-20-2011 08:07 AM

We have a server running Vault 2012 that was upgraded from 2011. at 2011 it was stable and worked great, but since the upgrade we have been having issues. When trying to check something in we get the following error Exception has been thrown by the target of an invocation. Then when I hit the server I see IIS worker process error and an error in the event log that states faulty application w3wp.exe. We have tried patching the server SQL and Vault but nothing seems to help. We are running Server 2003, SQL 2008. I am working with a support company that hasn't been much help at all.

Any input would be appreciated.

Thanks,

Dan

Valued Contributor
alh-alliedmin
Posts: 102
Registered: ‎09-10-2007
Message 2 of 5 (720 Views)

Re: Vault 2012 and w3wp.exe and not being able to check items into Vault.

02-22-2012 08:44 AM in reply to: ddev

We have the exact same issue.

Vault Basic 2011 upgraded to Vault Basic 2012 running on Windows Server 2003 (32 bit) with SQL 2008 Express.

The w3wp.exe has always been an issue for us. Starting with Vault Basic 2010 to the point that we have the IIS "Application Pools" Properties "Recycle worker processes" every 60 mins. This helped until 2012.

Autodesk Subscription request was not particular helpful. They claimed it might be a software limitation with the 32 bit IIS. I'm now working with our reseller to try other solutions, including a 64 bit OS, a fresh install of Vault with no data and a fresh install with out back up data. So many test, so little time.

What I find interesting is, we have issues checking in AutoCAD Mechanical 2012 files, were most others with this issue can't check in Inventor files. Strange that.

I can't help with a solution. But I did want to tell you, you're not alone.

New Member
jonkersuk
Posts: 2
Registered: ‎08-10-2012
Message 3 of 5 (581 Views)

Re: Vault 2012 and w3wp.exe and not being able to check items into Vault.

08-10-2012 02:32 AM in reply to: ddev

Hi Guys,

 

We are having exactly the same problem on our site, did you ever get to the bottom of the issue?

 

Any help would be appreciated.

 

Thanks,

 

Jon.

Valued Contributor
alh-alliedmin
Posts: 102
Registered: ‎09-10-2007
Message 4 of 5 (555 Views)

Re: Vault 2012 and w3wp.exe and not being able to check items into Vault.

08-15-2012 07:59 AM in reply to: jonkersuk

I never had the chance / time for any testing and never found a solution.

 

As a work around, I have added a simple AutoCad Mechanical .dwg to the root of our Vault engineering folder. If a file will not check in, the engineer goes to this file in the Vault Client, double clicks the file to Open it, and then clicks Yes to Check it out.

As soon as the file opens in AutoCAD Mechanical, the engineer saves the file, checks it back in and closes the .dwg.

Now they check in the other drawing, that wouldn't not check in before, and it works.

Seems this method cleans the pipes as it were.

 

Since 2013 Vault is available for 64 bit servers, our next step is to install and test that version.

And Again, that is IF I get free time.

Good Luck, sorry I can't help more.

Distinguished Contributor
BSchubring
Posts: 105
Registered: ‎05-04-2010
Message 5 of 5 (407 Views)

Re: Vault 2012 and w3wp.exe and not being able to check items into Vault.

11-30-2012 08:46 AM in reply to: alh-alliedmin

This is happening to us as well. it's interesting, your workaround worked for us as well, but we didn't realize it at the time.  While I was troubleshooting a user's computer, I did exactly that because in my mind I was testing to see if the issue was related to the drawing itself. When the blank drawing went in fine, I re-tested the troublesome drawings and they all went in.

 

If anyone has found any information pointing to a final resolution, I'd love to hear it, thanks!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community