Vault General

Reply
Mentor
MaximUdod
Posts: 494
Registered: ‎01-14-2010
Message 1 of 13 (544 Views)

Reference Repair Utility - several concerns

544 Views, 12 Replies
02-18-2013 08:16 AM

Concern #1:

 

When pressing F1 in Autodesk Repair Reference Utility user is being send to http://wikihelp.autodesk.com/Vault/enu/Help/Help/0097-Administ97/0190-Referenc209/0210-Walkthro210#G... But steps/parts are confusing.

Part 4 - Why opening results(xml, right) in Excel?

Part 5 - HOW to import XML on server?! Is it something obvious? Think no.

 

Concern #2:

can't finish the client part of work - after several hours of work the error pops: The utility has encounted some errors and it has stopped working. Please see the log file for details. Nothing in end of log file gives any hint to what have happened:  --------- Parameter name: collection 17:31:36  Processing version 33: version name=FS-DG_SMunit_SupportIns_2.iam in c:\temp\a28a5c88-5de5-400b-85d4-f141c1f28c8a\╨Я╤А╨╛╨╡╨║╤В╤Л\FS-DG\Products\SMunit\SupportIns 17:31:37  1 missing references found. 17:31:37  Error occurred when processing FS-DG_SMunit_SupportIns_2.iam. 17:31:37  Value cannot be null. Parameter name: collection 17:31:37 ---------Those non-readable symbols are Cyrrilic folder name, but it is repeated so many times in the log that just can't be the root of problem sever hours later. How to workaround?

Mentor
MaximUdod
Posts: 494
Registered: ‎01-14-2010
Message 2 of 13 (513 Views)

Re: Reference Repair Utility - several concerns

02-19-2013 01:38 AM in reply to: MaximUdod

#1 Those Parts 4 and 5 occured to be urls (who might expect as it is blue and not underlined, as subclouse "Note" on the same page). Thus the advanced info is on pages

http://wikihelp.autodesk.com/Vault/enu/Help/Help/0097-Administ97/0190-Referenc209/0210-Walkthro210/0...

and

http://wikihelp.autodesk.com/Vault/enu/Help/Help/0097-Administ97/0190-Referenc209/0210-Walkthro210/0... is a description

 

Will comment my Concern#2 after sorting out the 1st one.

Mentor
MaximUdod
Posts: 494
Registered: ‎01-14-2010
Message 3 of 13 (509 Views)

Re: Reference Repair Utility - several concerns

02-19-2013 05:28 AM in reply to: MaximUdod

The concern#2 is actual - utility stops, I resume it - half minute later it stops again. Now i'm planing to create macros that would resume it cyclically but I'm pretty sure it is something that I as subscribed user shouldn't do if Autodesk support would do their job.

 

Concern#3 the utility seems ignore the option of treating historical versions (i don't enable it but still have mentions about not latest parent versions in output xml).

Mentor
MaximUdod
Posts: 494
Registered: ‎01-14-2010
Message 4 of 13 (494 Views)

Re: Reference Repair Utility - several concerns

02-19-2013 11:46 PM in reply to: MaximUdod

Concern#2 Ato-resume haven't helped, there were no progress it always stopped on one particular file.

Now I've deleted the file (it is not something acceptable in real Vault but I'm playing with backup on test server). After ARRU was run again on this vault it now stopps with MS Net.Framework JIT error dialog (ignore/continue or quit). I've choosen to ignore and ARRU seems to hang (no visible changes in its state for hours.

Latest lines in log are:

---

23:54:24  Processing version 18: version name=FS-CM_Pack_Label_Front(47).ipt in c:\temp\9d643aac-008f-4e5e-bf36-ced02c976d1d\Проекты\FS-CM\Products\Pack\Label\Front\47
23:54:25  Error occurred when processing FS-CM_Pack_Label_Front(47).ipt.
23:54:25  WSE910: An error happened during the processing of a response message, and you can find the error in the inner exception.  You can also find the response message in the Response property.
23:54:25  Processing version 19: version name=FS-CM_Pack_Label_Front(47).ipt in c:\temp\9d643aac-008f-4e5e-bf36-ced02c976d1d\Проекты\FS-CM\Products\Pack\Label\Front\47
23:54:25  Error occurred when processing FS-CM_Pack_Label_Front(47).ipt.
23:54:25  The remote name could not be resolved: 's-vserver23.tavrida.local'
23:54:25  Processing version 20: version name=FS-CM_Pack_Label_Front(47).ipt in c:\temp\9d643aac-008f-4e5e-bf36-ced02c976d1d\Проекты\FS-CM\Products\Pack\Label\Front\47
23:54:25  Error occurred when processing FS-CM_Pack_Label_Front(47).ipt.
23:54:25  The remote name could not be resolved: 's-vserver23.tavrida.local'
23:54:25  File $/Проекты/FS-CM/Products/Pack/Label/Front/47/FS-CM_Pack_Label_Front(47).ipt is processed.
23:54:25  Processing $/Проекты/FS-CM/Products/Pack/Label/Front/47/FS-CM_Pack_Label_Front(47).idw
23:54:25  Using handler ExtensionHandlerInventor.CheckReferenceExtHandler
23:54:25  Error occurred when processing FS-CM_Pack_Label_Front(47).idw.

----

Don't know where to move further. Ideas are welcome.

Employee
ralfwalter
Posts: 65
Registered: ‎10-09-2007
Message 5 of 13 (415 Views)

Re: Reference Repair Utility - several concerns

02-27-2013 12:09 PM in reply to: MaximUdod

Hello,

 

Would you be able to share your dataset and detailed steps with us at Autodesk so we can try to reproduce the issue?

 

We can find a way to get that dataset to us without having to post it publicly.

 

Please let me know.

 

Regards,

 

Ralf Walter

Autodesk

Software Engineer

Mentor
MaximUdod
Posts: 494
Registered: ‎01-14-2010
Message 6 of 13 (406 Views)

Re: Reference Repair Utility - several concerns

02-28-2013 01:39 AM in reply to: ralfwalter
Preparation and sending dataset is time consuming. I'd rather get the utility fixed (not searching dangling relationships in historical versions if not said to do so).
Employee
ralfwalter
Posts: 65
Registered: ‎10-09-2007
Message 7 of 13 (401 Views)

Re: Reference Repair Utility - several concerns

02-28-2013 07:43 AM in reply to: MaximUdod

We are looking into this.

 

Thank you,

 

Ralf Walter

Autodesk

Software Engineer

Employee
chearhuat
Posts: 113
Registered: ‎06-10-2010
Message 8 of 13 (384 Views)

Re: Reference Repair Utility - several concerns

02-28-2013 07:51 PM in reply to: MaximUdod

Hi Uma,

 

Would you help to elaborate on concern #3? Particularly on how you get to see the message/indication that 'there is no latest parent version in output xml''? Sharing of the xml file would greatly help us during the troubleshooting.

 

Meanwhile, in the output xml, the node that reads 'Parent_missing_ref' could be extended to mean 'parent file with missing reference / children files'. Hope this is not the one that is causing confusion...

 

 

Regards,

Chear Huat.



Chear Huat
SQA Analyst
DLS- Data Management
Autodesk, Inc.


Be sure to check out the Vault Help Wiki!
Distinguished Contributor
MaxU77
Posts: 204
Registered: ‎04-25-2008
Message 9 of 13 (379 Views)

Re: Reference Repair Utility - several concerns

03-01-2013 05:25 AM in reply to: chearhuat

Dear Chear Huat,

 

Just to clarify - the problem is not in the absence of latest versions in XML, utility generates some errors and stops working. Each time it happens on historical version.

Problem is: utility processes historical versions even if told not to (option “Process all versions of files (including historical)” is not checked).

Please analyse XML attached to case 08095963 .

Lines 22 and 23 are two verions of one file, right?

Why they are both in output if historical versions are not processed?

 

I have the minor hope that if you guys will fix this option the utility will process/fix at least actual versions of files in our Vault and then our company will finally get trusty Item BOMs (after several years of implementing).

 

Thanks in advance.

 

MaxU77,
AI2011 Certified Associate
(Soft: PDSU2012, VP2012&VP2013)
*Expert Elite*
mthomas
Posts: 282
Registered: ‎06-17-2010
Message 10 of 13 (343 Views)

Re: Reference Repair Utility - several concerns

03-04-2013 11:20 AM in reply to: MaxU77

I have 3-folders within my Vault doing the exact same thing... processes, processes, them bam get the error message that it can't proceed. 

Mike Thomas

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community