Vault General

Reply
Active Contributor
Lalitkmr123
Posts: 42
Registered: ‎07-19-2010
Message 1 of 11 (273 Views)

File Migration: One folder (of many) not migrating with Task scheduler

273 Views, 10 Replies
04-11-2012 04:46 AM

Hi,

I am having a strange problem. I upgraded from Vault 2011 to 2012.  I migrated the files using Task Scheduler. I have about 10 folders representing different machines. All these folders migrated to vault 2012 except one(Say A).

 

I migrated the files in this folder using Task scheduler.

 

When I open a file from the vault from this flder, it informs me that the file is newer than the one in Vault, do i want to replace with the one in vault. Saying yes if I open it and go to save it, It gives me the "Data format change screen" saying that the data format has been changed......

 

among all  folders in the vault I am seeing this behaviour only in this folder and its subfolders.

 

If I migrate the files of this folder (A) again, The message says the files are already migrated. but the problem does not go away.

 

Any help is appreciated.

 

Regards

 

Lalit

Employee
mollons
Posts: 400
Registered: ‎07-13-2005
Message 2 of 11 (270 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-11-2012 05:59 AM in reply to: Lalitkmr123

Not sure what is happening bu there is some info:

 

Vault in and of itself does not have any requirements about what format the files are in. When you migrated you migrated the files to Inventor 2012, not Vault 2012. Vautl 2012 can manage any release fo Inventor files.

 

The dialog stating the files you had were newer, was because what you had locally in your workspace appeared to the Vault to be newer than the versions of the files it knew about. Saying yes to replace meant that Vautl was going to overwrite the version in your workspace with the latest version in the Vault.

 

I am not sure what the Data Format dialog is, most likely this is something that Inventor is displaying.

 

Is the data format screen the problem? Could you attach a screen capture of it?

Or is it always telling you the local files in your workspace are newer than the Vault's?

 



Scott Mollon
Quality Assurance
Autodesk, Inc.

Be sure to check out the Vault Help Wiki!
Active Contributor
Lalitkmr123
Posts: 42
Registered: ‎07-19-2010
Message 3 of 11 (267 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-11-2012 07:07 AM in reply to: mollons

Scott,

Thanks for replying.

Here is sequence of the events.

1. I migrated the files in the folder (SP-6) with the help of Task Scheduler.

2. When I check out the file from the vault for this folder. The message "File ....is NEWER than the latest version in the vault. Are you sure you want to replace it with the version in the vault " is displayed. The Message is attached as photo 1. however if I open a file of any other(Other than SP-6) migrated folder from the vault, I dont get this message.
3. I say Yes so that the file in the workspace is replaced with the version in the vault.
4. If I save this file . I get the dialog "The data format of the following files was migrated to the current release.....". Screen shot is attached as photo 2. its basically a manual migration of the file.
   Again, for a file of any OTHER (Other than SP-6) migrated folder from the vault, I dont get any such message when I save.
5. So If I run the migration of the folder (SP-6) through Task scheduler. In the log file I find out that the files have been already migrated. The log file is attached as file "log".

So my understanding is that although in my local workspace the files in the folder (SP-6) have not been migrated ,
   The vault thinks that the these are migrated,
   And that those files are newer than the latest version in the vault.
   after checkout from the vault I have to migrate the file manually.
and this happens for the files in the folder and the subfolder of "SP-6" only. Any other folder does not have a  problem like this.

I have tried to migrate these files from another client machine. there also I get the same issue with "SP-6" folder
 
Regards

Lalit   


Employee
mollons
Posts: 400
Registered: ‎07-13-2005
Message 4 of 11 (254 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-11-2012 08:15 AM in reply to: Lalitkmr123

It looks like the migrated version of SP-928 is not getting checked in to the vault after migration.

In the log we can see it is getting opened, updated, saved. But it is missing in the section where the files get checked in.

 

So what seems to be happening.

1. The file does get migrated in your workspace.

2. Everything in the folder except that file gets checked in.

3. You do an open from vault and the SP-928 file is indeed newer than the vault version.

4. Answering yes overwrites it with the unmigrated version in Vault.

5. You see the dialog saying Inventor has once again migrated it.

 

A couple things to do/check:

 

When you open the assembly and the file is migrated, you might be able to simply check it out and check it in through Inventor. This would get the correctly migrated version checked in to vault.

 

Is there anythign special about the file in the vault? Is it assigned to a file category? Is it in a lifecycle state? Is that state a released state which would not allow for it to be checked out?

 

Is it attached to a released item which would also not allow the file to be checked out?

 

 

 



Scott Mollon
Quality Assurance
Autodesk, Inc.

Be sure to check out the Vault Help Wiki!
Active Contributor
Lalitkmr123
Posts: 42
Registered: ‎07-19-2010
Message 5 of 11 (248 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-11-2012 10:29 AM in reply to: mollons

Scott,

 

Thanks for finding the anamoly. That was the key. Now I see that the files did not get checked in.

As suggested by you , i did check for the model state, Life cycle state, state of the files that these files go in.  All are work-in-progress. Nothing  seems out of the ordinary.

 

Also If the files are not being checked in by the task scheduler after the migration, then their model state in the vault explorer should say "checked out". but the file state shows checked in with"The local copy  edited out of turn " state as explained by you.

 

confusing.

 

So what should be the remedy?  check which files are migrated but not checked in (There are 100s) and manually check out and then check in?.

or

 

Checkout all the files in the folder from the vault with the task scheduler.

Migrate?

and check in with the task scheduler?

 

Regards

 

 

Employee
mollons
Posts: 400
Registered: ‎07-13-2005
Message 6 of 11 (245 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-11-2012 10:44 AM in reply to: Lalitkmr123

I am contacting people much more knowledgable on the task scheduler than I am to see if they can point us in the right direction to figuring this out.

 

I will get back to you soon.

 



Scott Mollon
Quality Assurance
Autodesk, Inc.

Be sure to check out the Vault Help Wiki!
Active Contributor
Lalitkmr123
Posts: 42
Registered: ‎07-19-2010
Message 7 of 11 (222 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-12-2012 11:15 AM in reply to: mollons

Scott,

 

Could you find any thing on my problem with the  file migration.

 

Regards

Employee
mollons
Posts: 400
Registered: ‎07-13-2005
Message 8 of 11 (220 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-12-2012 11:27 AM in reply to: Lalitkmr123

I haven't heard back from the task scheduler experts yet, but I have cast a  wider net to try and find out more about the log file contents.

 

In the meantime, if there are specific projects which need to continue, you could migrate them one by one by using Inventor, or use task scheduler and migrate the rest of the files when they are opened. Then check everything back in to the vault. I know this isn't a good solution, especially for large projects.

 

I haven't forgotten about you though.



Scott Mollon
Quality Assurance
Autodesk, Inc.

Be sure to check out the Vault Help Wiki!
Employee
mollons
Posts: 400
Registered: ‎07-13-2005
Message 9 of 11 (198 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-13-2012 08:59 AM in reply to: mollons

 

I got some feedback about the what the log file indicates.

 

- Are you sure you are using the correct project file for the migration. The log file indicates there are missing files and this could contribute to the problem.

- Are you sure the file that isn't being migrated isn't checked out by someone else?

- Are there other duplicate files with the same  name in the vault?

 



Scott Mollon
Quality Assurance
Autodesk, Inc.

Be sure to check out the Vault Help Wiki!
Active Contributor
Lalitkmr123
Posts: 42
Registered: ‎07-19-2010
Message 10 of 11 (182 Views)

Re: File Migration: One folder (of many) not migrating with Task scheduler

04-18-2012 10:21 AM in reply to: mollons

Scott,

Sorry for not replying earlier. I was out of  town.

For your questions:

 

"- Are you sure you are using the correct project file for the migration. The log file indicates there are missing files and this could contribute to the problem." ----- We use only two project files. One for the main machine files and second for altering the library files.

 

"- Are you sure the file that isn't being migrated isn't checked out by someone else?" --- I went into vault explorer and verified that the files are not checked out by someone else.

 

"- Are there other duplicate files with the same  name in the vault?"---- no there are no other file with the duplicate name. the vault stops us from doing so.

 

also it is happening to all the files in subflders of this one folder called SP-6.  files in all other folders dont have such problem.

 

Regards

 

Lalit

 

 

 

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community