Vault General

Reply
Distinguished Contributor
spascual
Posts: 292
Registered: ‎11-17-2009
Message 1 of 27 (1,117 Views)
Accepted Solution

Error "An Item with the same key has already been added"

1117 Views, 26 Replies
06-21-2010 02:00 PM

Hi Sirs,

 

Any sugestion about this error.

 

VM210 SP1

 

Regards

Employee
yuhui.zhang
Posts: 194
Registered: ‎04-07-2008
Message 2 of 27 (1,108 Views)

Re: Error "An Item with the same key has already been added"

06-21-2010 06:25 PM in reply to: spascual

hi, would you please give some other infomation to figure this out, such as:

- Did this error appear on the Vault client main window or other dialog? what operation made this error thrown?

- Did this error appear when login another Vault database in the same machine?

 

Thanks,

Fay



Fay Zhang
Software QA Engineer
Data Management
Autodesk, Inc.

Be sure to check out the Vault Help Wiki!

Distinguished Contributor
spascual
Posts: 292
Registered: ‎11-17-2009
Message 3 of 27 (1,083 Views)

Re: Error "An Item with the same key has already been added"

06-22-2010 01:25 PM in reply to: yuhui.zhang

Hello Mr. Yuhui,

 

Thanks for your interesting. The environment is VM2010 SP1 with a SAP connector.

 

I have some items that when I click on (in item master environment) a dialog box appears with this message.

 

I have noticed that when I "delete SAP link" (for file and item) the dialog box does not appear.

 

If I do an "Update Item" (it is done without problems) and click on, the dialog box appears again.

 

Thanks

Distinguished Contributor
spascual
Posts: 292
Registered: ‎11-17-2009
Message 4 of 27 (1,012 Views)

Re: Error "An Item with the same key has already been added"

07-16-2010 03:31 AM in reply to: yuhui.zhang

Please, I need help.

 

I hear about an aplication that can find the problem I'm talking about, but with older vault versions.

 

Maybe with a simple consultant to a SQL, the problem is solved.

 

How much it costttttt?????????????????

 

regards

Employee
JamesMcMullen
Posts: 297
Registered: ‎03-19-2009
Message 5 of 27 (990 Views)

Re: Error "An Item with the same key has already been added"

07-16-2010 12:36 PM in reply to: spascual

Have you tried logging a support case against this issue?  I, unfortunately, cannot add anything since it is something I haven't seen.  But, I think we might be able to help you quicker if you went thru support.

 

-Jim

Distinguished Contributor
spascual
Posts: 292
Registered: ‎11-17-2009
Message 6 of 27 (986 Views)

Re: Error "An Item with the same key has already been added"

07-16-2010 04:09 PM in reply to: spascual

I'm an independent professional that cannot ask for official support.

 

Thanks

Distinguished Contributor
spascual
Posts: 292
Registered: ‎11-17-2009
Message 7 of 27 (967 Views)

Re: Error "An Item with the same key has already been added"

07-19-2010 01:16 AM in reply to: spascual

Official support already running

 

Thankssssss

Valued Contributor
Cadenza
Posts: 64
Registered: ‎09-29-2008
Message 8 of 27 (963 Views)

Re: Error "An Item with the same key has already been added"

07-19-2010 04:59 AM in reply to: spascual

Are you using Autocad Mechanical with Vault Manufacturing?? We have had the same problem with a new vault set up, the previous had no issues - eventually we were told

 

"We only have a very few reports of this error occurring before. ... when they created an Item property. When the property was deleted, the error went away. I am wondering if they have recently created a new custom Item property or imported a configuration that has the same name as a property in the ACM BOM Table. The issue being that the custom Item property in 2010 should not have the same name as that in the ACM BOM table."

 

The issue is why there is no guidance on avoiding such problems in the first place

Distinguished Contributor
spascual
Posts: 292
Registered: ‎11-17-2009
Message 9 of 27 (960 Views)

Re: Error "An Item with the same key has already been added"

07-19-2010 05:14 AM in reply to: Cadenza

Goog evening Mr. Cadenza,

 

Well, people are using AutoCAD Mechanical with VM2010, but not are using the AM BOMS.

 

May is occurring what you say with Inventor too.

 

Through a friend, it has been opened an official support, I tell you something.

 

Regards

Distinguished Contributor
spascual
Posts: 292
Registered: ‎11-17-2009
Message 10 of 27 (878 Views)

Re: Error "An Item with the same key has already been added"

08-17-2010 09:54 AM in reply to: spascual

Please help

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community