Vault General Discussion

Reply
Distinguished Contributor
cvbt-thailand
Posts: 125
Registered: ‎12-23-2005
Message 1 of 13 (1,887 Views)
Accepted Solution

How can I add to a Content Center Library in a stand alone installation?

1887 Views, 12 Replies
07-21-2010 02:32 AM

I want to add content to MyLibrary in the Data Management Server (DMS).  I have a single-seat stand alone installation of IV2009 on WinXP SP2.

I went to
File>Projects>Configure Content Center Libraries>
Content and Vault log in [OK]
>Add Libraries>My Library [My Library is Read/Write]

I received an Error Box:  Validate User
"You are logged into an Autodesk Data Management Server as an anonymous user.  Please log in as a user who has the Content Center Editor role."

I checked the Data Management Server Status
User Logon Name: Content Center user
[When I logged on it was User Name: Administrator,  Password: (blank)]
Server Name: localhost
Database: (Vault Name: ) Vault  [I have a stand alone IV installation and do not use Vault]
Connection Status:  Connected

How can I add content to the content center?  How can I add My Library to a project?

Geoffrey Wheeler
IV Pro 2011 64bit SP2; Win7 Ultimate SP1
ASUS MB Intel i5-3450 @ 3.10 GHz, 8GB RAM
ATI AMD Radeon HD 6600 Series, 1GB RAM
Employee
Senthil-Autodesk
Posts: 556
Registered: ‎10-12-2006
Message 2 of 13 (1,833 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-23-2010 01:06 AM in reply to: cvbt-thailand

Hi,

 

Could you please check the option selected for Connection? Please check the attached image for reference. Is it Single Server or Separate server?



Senthil Kumar
Vault QA Team
Autodesk, Inc.


Be sure to check out the Vault Help!
Distinguished Contributor
cvbt-thailand
Posts: 125
Registered: ‎12-23-2005
Message 3 of 13 (1,810 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-23-2010 07:55 PM in reply to: Senthil-Autodesk

Thanks so much for your interest.

I have designated it as a Single Server.  I have IV and the ADMS installed only on a stand-alone PC.  I tried designating it as  separate servers and it gives me the same error as when I try to login read/write as a single-server: "No Vaults have been found on this Server."  I have not installed Vault, just ADMS.  The Login Dialog Box shows Database as "Vault"  It works OK if I check "Content Center Library Read-Only User."  Then the Database is designated as Vault but it is grayed out.

    The on-line help says,
"To edit the Content Center data, you must be connected to the data server and have editing permissions. If you work in a single-user environment, you automatically have permissions to perform editing tasks and you are automatically logged into the Autodesk Data Management server on your local drive. If the Content Center libraries are installed on a remote server, you must be assigned Editor permissions in Autodesk Server Console to perform any of the editing tasks and you must be logged into your library server."
    When I try to add a library to my project it tells me that I'm logged on as an anonymous user and need to logon as a user with editing privileges.  If I logout (IV>File>Autodesk Data Management Server) and login I find that (expanding the options in the login dialog box) I can only login as a Read-Only user (if I try to login with this check box unticked then I need to select a vault; being a single-user I do not have a Vault).  This seems to be in conflict with having single-user editing privileges.  My content center library files are on drive C: of my computer along with my program files.  My .ipt, iam, idw files are on drive F:  I would not expect this to make a difference.  How can I add content to a content center library?  How can I add My Library (which is read/write) to a project?

Geoffrey Wheeler
IV Pro 2011 64bit SP2; Win7 Ultimate SP1
ASUS MB Intel i5-3450 @ 3.10 GHz, 8GB RAM
ATI AMD Radeon HD 6600 Series, 1GB RAM
Employee
Senthil-Autodesk
Posts: 556
Registered: ‎10-12-2006
Message 4 of 13 (1,796 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-25-2010 10:20 PM in reply to: cvbt-thailand

Hi,

 

Thanks for your reply. Here is what you need to do.

 

1. Inside ADMS Ensure you have a Read / Write Library created

2. Inside Inventor, Under Application option Ensure Vault Server is selected

3. Configure your Inventor Project with the New Library - Refer the attached Video for steps.

 

While configuring in Step 3 DO NOT Check the Content Center Library read only user box. Just use the default and log in as "Administrator".

 

After doing this you can Publish your iParts to this new assembly and also you can copy the content centre parts from other library to this new library.

 

You can also refer the following PDF for step by step information on how to configure.

 

http://augiru.augi.com/content/library/au07/data/paper/MA201-1L.pdf

 

Hope the above helps you.



Senthil Kumar
Vault QA Team
Autodesk, Inc.


Be sure to check out the Vault Help!
Distinguished Contributor
cvbt-thailand
Posts: 125
Registered: ‎12-23-2005
Message 5 of 13 (1,775 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-26-2010 06:55 PM in reply to: Senthil-Autodesk

Thanks!

- MyLibrary is Read/Write

- I do not have a Content Center tab in my Tools>>Application Options dialog box.  I am using Inventor 2009 SP2.  I checked my Add-Ins:  I have loaded Content Center, and Content Center Translator and not loaded Inventor Vault.  I tried loading Inventor Vault and it did not give me a Content Center tab in Application Options.

- I cannot add MyLibrary to a project.

 

Geoffrey Wheeler
IV Pro 2011 64bit SP2; Win7 Ultimate SP1
ASUS MB Intel i5-3450 @ 3.10 GHz, 8GB RAM
ATI AMD Radeon HD 6600 Series, 1GB RAM
Employee
Senthil-Autodesk
Posts: 556
Registered: ‎10-12-2006
Message 6 of 13 (1,765 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-26-2010 09:49 PM in reply to: cvbt-thailand

Hi,

 

Thanks for your reply. I am attaching a Video from Inventor 2009 and vault 2009.

 

Ensure your Project is NOT in Read-only mode to add your Library. Also use the Log in as Administrator as I mentioned in my previous reply.



Senthil Kumar
Vault QA Team
Autodesk, Inc.


Be sure to check out the Vault Help!
Distinguished Contributor
cvbt-thailand
Posts: 125
Registered: ‎12-23-2005
Message 7 of 13 (1,759 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-27-2010 12:10 AM in reply to: Senthil-Autodesk

I received your videos.  Thank you.

- To put my project in non Read-Only mode I closed all my inventor files.

- I am not able to login as Administrator as you asked.  I can only login as "Content Center Library Read-Only User."  When I try to login as Administrator (blank password), the Server is set as "local host" by default (with no other selectable options) and database is set as "Vault" by default (with no other selectable options).  If I click the ... Browse button it comes back with a red circle with a white exlaimation mark with floating text, "No vaults have been found on this server."  If I click OK I receive an error message, "the referenced vault does not exist."

 

Also, when I select Tools>>Content Center Editor I receive the message:  "You are logged in to an Autodesk Data Management Server as an anonymous user.  Please log in as a user who has the Content Center Editor role."

 

Why can't I login as Administrator?  I have IV2009 installed as stand-alone single-user.

Thanks

Geoffrey Wheeler
IV Pro 2011 64bit SP2; Win7 Ultimate SP1
ASUS MB Intel i5-3450 @ 3.10 GHz, 8GB RAM
ATI AMD Radeon HD 6600 Series, 1GB RAM
Employee
Senthil-Autodesk
Posts: 556
Registered: ‎10-12-2006
Message 8 of 13 (1,757 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-27-2010 12:18 AM in reply to: cvbt-thailand

Thanks for your reply.

 

Are you able to start ADMS and log in ? Do you see Vault inside ADMS?

 

If you still see the issue please log a Support Request and someone from Support might be able to help you with the installation and configuration.



Senthil Kumar
Vault QA Team
Autodesk, Inc.


Be sure to check out the Vault Help!
Distinguished Contributor
cvbt-thailand
Posts: 125
Registered: ‎12-23-2005
Message 9 of 13 (1,751 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-27-2010 02:41 AM in reply to: Senthil-Autodesk

I can login to ADMS as Administrator without a problem.  I've attached a screen shot showing that there are no Vaults on this server (stand-alone PC).  Thanks, I'll try to contact support.

Geoffrey Wheeler
IV Pro 2011 64bit SP2; Win7 Ultimate SP1
ASUS MB Intel i5-3450 @ 3.10 GHz, 8GB RAM
ATI AMD Radeon HD 6600 Series, 1GB RAM
Employee
Senthil-Autodesk
Posts: 556
Registered: ‎10-12-2006
Message 10 of 13 (1,747 Views)

Re: How can I add to a Content Center Library in a stand alone installation?

07-27-2010 02:57 AM in reply to: cvbt-thailand

Thanks for the image. You should have a Vault Database inside ADMS. Please create a Vault by Right Clicking on Vaults.

 

Then only you can log in from Inventor.

 

Hope this helps you!



Senthil Kumar
Vault QA Team
Autodesk, Inc.


Be sure to check out the Vault Help!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community