Vault General Discussion

Vault General Discussion

Reply
Distinguished Contributor
psaarloos
Posts: 147
Registered: ‎12-09-2004
Message 1 of 2 (247 Views)

Content Center in a replicated environment

247 Views, 1 Replies
10-08-2012 03:39 PM

Hi All,

 

I need some advise on using Content Centers in a replicated environment. I have been searching the forum, looked on several blogs, found a white paper on the AU site, but none of them seem up-to-date to me.

 

For instance, the Advanced Configuration Guide for Vault 2013 has a paragraph (page 70) about Content Center in a replicated environment, but the 'Get Entire Folder' option which is shown in the document doesn't exist anymore since Vault 2011 if I am right. So I wonder if all remarks are still valid.

 

This is as I understand it:

 

Content Center libraries are replicated from the publisher to one or more subscribers. That means all libraries are available at each site. Users are enabled to use the 'Place from Content Center command inside Inventor on each site. Content Center Files are placed in the private folder on the local system (private location).

 

As soon as an user checks in an assembly which contains Content Center Files, the corresponding folders are created in Vault (if not already existing) and the (newly) created Content Center Files are placed in them. Since the newly created folders are created by the user on site A, Site A gets the ownership rights on those folders. Therefore an user on site B can have a problem checking in a different Content Center File of the same family into Vault. The family folder already exists, but site B doesn't have ownership of the folder.

 

To eliminate these kinds of problems it's recommended to create each and every family member in advance. Because then every Content Center File of every family will already exist in the 'Content Center Files' folder in Vault and therefore users will never add new Content Center Files to the Vault. Inventor will just recognize the existing files (if they downloaded them from Vault to their local workspace).

 

My questions:

 

1) Is my understanding of the best practice for using Content Center in a replicated environment correct?

 

2) Is it still necessary to create all Content Center members for every family in advance? I ask this because the use of changing ownership changed a lot in Vault 2013. (Ownership is more or less automatically transferred if possible)

 

3) If question 2 is still the best practice: what is the best method to use to create all members from all families? (Placing them one by one into an assembly so generate the files will cost far to much time!)

 

Many thanks in advance for the feedback!

 

Regards,

Pim Saarloos

 

Distinguished Contributor
mbodnar
Posts: 155
Registered: ‎08-02-2006
Message 2 of 2 (176 Views)

Re: Content Center in a replicated environment

11-14-2012 06:20 PM in reply to: psaarloos

Hi

 

I was able to test ownership in a replicated 2013 environment, and the previous issues with having to request ownership especially for CC folders when adding new files or editing existing, does not exist anymore

 

The transfer of ownership happens automatically when adding new files and when checking-out files

 

Hope this helps?

 

Max B

Announcements
New button for Platinum & Gold Subscription customers
Gold & Platinum Subscription customers can alert Autodesk if they require assistance with their forum post

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.