Discussion Groups

Simulation Mechanical and Multiphysics

Reply
New Member
wulei9921
Posts: 2
Registered: ‎04-05-2012

contact problem

370 Views, 4 Replies
04-05-2012 02:29 PM

I have a inventor model. When i use the simulation to open this model, the simulation does not list all of contacts and give some wrong contact. I add the contact which i want, delete the wrong contact (bonded) from the default contact and set up the wrong contact again for free . However, the wrong contact still work when i mesh the model. Does anyone know how to fix it? Thank you for help. 

Please use plain text.
Employee
INACTIVE_AstroJohn
Posts: 492
Registered: ‎03-25-2010

Re: contact problem

04-09-2012 02:47 PM in reply to: wulei9921

Hi wulei9921,

 

We need some clarification on what you are doing. For example,

 

1) Do you have a simulation setup in Inventor where you have defined different types of contact (separation, sliding/no separation, etc.) in the Stress environment, or are you referring to constraints (mates, etc.) applied in the modeling environment ? Simulation Mechanical (and Multiphysics) only reads the contact types setup in the Inventor simulation.

 

2) You cannot determine how the contact will behave simply by looking at the mesh in the FEA Editor environment. You need to perform the simulation. Then you will be able to see from the results that the contact behaved properly. So, are you saying that you have performed the simulation and the results are incorrect?

 

 

 

Sincerely,
John Holtz, P.E.
Senior User Experience Designer, Simulation
Autodesk, Inc.

Current version of Mechanical & Multiphysics: 2013 SP1 (2013.01.00.0012 28-Jun-2012)
Please use plain text.
New Member
wulei9921
Posts: 2
Registered: ‎04-05-2012

Re: contact problem

04-10-2012 07:48 AM in reply to: INACTIVE_AstroJohn

Hi John Holtz,

Thank you for your help.

I use the inventor to create my model.  All of contacts are created by constrain command (mates, ets) in the inventor. After I create this model, I use the degree of freedom analysis command to check the constrain. All of parts have zero degree of freedom. Then I use the simulation to open this inventor model.

 

My first issue is the simulation cannot list all of contacts and give one wrong  contact.

 

After I mesh the model using midplane, I find the second issue. In my inventor model,two surfaces are not connect with each other. However, they bonded contact after mesh by looking at it. Also, the connect part have large stress after linear static analysis. I try two ways to fixed it, but both of they are not working.

 

The first is that I set up free contract between them. After mesh, both surfaces are still connect.

 

The second way is that I set up default contacts are free and delete all of default contacts, and set up all of contact again( listed above). The mesh is very nice. However, all of parts are separated when I do the linear static analysis ( I did not use the smart bonded, because i will go to nonlinear analysis). Thank you.

 

Thank you

Please use plain text.
Employee
INACTIVE_AstroJohn
Posts: 492
Registered: ‎03-25-2010

Re: contact problem

04-11-2012 10:07 AM in reply to: wulei9921

Simulation Mechanical is not programmed to read the mates and other types of assembly constraints created in Inventor. One reason is that the typical assembly constraints such as mates only indicate the positions, not how the bodies are connected together. And even when the motion constraints are defined in Inventor, Mechanical does not read them. So you need to define how the parts are connected together in the simulation environment.

 

When you say that "simulation cannot list all of contacts", I want to make sure that I understand. I believe you mean that Simulation is not listing any of the contacts other than the default. This is by design to speed the import process. If you want Simulation to find every pair of parts that touch and list them in the "Contact (Default)" branch of the browser, you can do that by the settings under "Tools > Application Options > CAD Import > Global CAD Import Options > Automatically generate contact pairs". But most users find it easier to define the contact pairs themselves, either by selecting the two parts or surfaces in contact, right-click, "Contact". (This keeps the "Contact (Default)" branch much cleaner.)

 

About the gap between the Inventor parts which are removed in Simulation, it sounds like you need to change the matching tolerance under "Mesh > Mesh > 3D Mesh Settings > Model > Model"; they are located on the General tab under the Mesh Matching section. If the tolerance is smaller than the gap between the parts, Simulation will not stretch the mesh to make them match up.

 

To clarify what I wrote before, whether the mesh appears to match in the FEA Editor is only half of what needs to be set to determine how they are connected together. The type of contact also determines whether a matched mesh is treated as bonded, totally free, or surface contact. The FEA Editor only shows fancy images. The Results environment is the only place to see what the processor was solving, either because there is just one node between the parts (bonded), or two nodes (free if there is no contact element).

 

So, either change the mesh matching tolerance, or set the Contact (Default) to bonded and then select the two parts that are supposed to be free, right-click, "Contact > Free/No Contact".

 

 

 

Sincerely,
John Holtz, P.E.
Senior User Experience Designer, Simulation
Autodesk, Inc.

Current version of Mechanical & Multiphysics: 2013 SP1 (2013.01.00.0012 28-Jun-2012)
Please use plain text.
Employee
zhuangs
Posts: 213
Registered: ‎10-04-2010

Re: contact problem

04-30-2012 07:07 AM in reply to: INACTIVE_AstroJohn

Hi,

 

How about setting the Contact (Default) to "Free/No Contact", in case some neighboring surfaces provides extra bonded issue.

 

For this tricky case, set the Contact (Default) to "Free/No Contact", might help.  If the model has some surfaces to be bonded, then set "Bonded" for these specific pairs.

 

Shoubing

Please use plain text.