Discussion Groups

Simulation Mechanical and Multiphysics

Reply
Member
Nefertari_Amy
Posts: 5
Registered: ‎01-17-2013

Problem about mesh

306 Views, 8 Replies
01-17-2013 01:23 AM

I met some strange phenomenons with mesh.

1.My model is symmetrical(all the parts are Cuboid) but the mesh result is asymmetrical no matter the mesh setting is absolute size or at percentage 100%.

2. And for the two models I created just with holes in the opposite position (one hole in the left side of the model and the other one in the right), the stress of the whole model is also not the same.

 

Does anyone know why could this happened?

Thank you in advance.

Please use plain text.
Valued Mentor
AstroJohnPE
Posts: 498
Registered: ‎08-30-2012

Re: Problem about mesh

01-18-2013 09:13 PM in reply to: Nefertari_Amy

Hi Amy,

 

  1. Out of curiosity, why would you expect a computer to understand that your model is symmetric and therefore create a symmetric mesh? I think a symmetric mesh requires real intelligence, not the programmed logic of a computer. To create a symmetric mesh, you could mesh half the model and then mirror the mesh.
  2. Can you provide some more information to explain your situation? You may be able to attach some images to show what you mean, or attaching an archive would be better. (Search for the thread about creating and posting an archive.)

 

John Holtz, PE
Mechanical Engineer
Pittsburgh, PA

16 years experience with Simulation Mechanical
Please use plain text.
Member
Nefertari_Amy
Posts: 5
Registered: ‎01-17-2013

Re: Problem about mesh

01-21-2013 12:59 AM in reply to: AstroJohnPE

Hi John,

 

At first thank you for your reply.

Here is the whole model I am simulating. It is made for 3 parts and you can see clearly on the picture (the third part is a very thin layer between the blue and the orange part, whose size in plane is the same like the blue one)

.Whole model

 

1. Here is the mesh result of the blue part. I just use the generaly mesh size: percentage 100%. Because as you seen, all the parts are so regular but the mesh result is irregular.

mesh 1

 

And when I change the mesh setting such like absoult size:0,1mm (according the thickness of blue part.)

The result is like the picture shown. I just wondered how these pink lines existed.

mesh 2.PNG

 

 

2. Actually the second question is based on the first question. Now I am doing a thermal stress simulation and  comparing the static stress generated by the transient heat. Normally, when the model is symmetrical people will think the stress on the blue part should also be symmetrical.  But following is the result and I can not explain why.

Don't you feel it is strange?

middle.PNG

Please use plain text.
Distinguished Contributor
ilyas
Posts: 139
Registered: ‎06-13-2012

Re: Problem about mesh

01-21-2013 02:15 AM in reply to: Nefertari_Amy

Hi,

 

Firstly, in my opinion, I do not feel that it is that strange if my symmetrical model comes out with an asymmetrical mesh. I believe this is the inherent characteristics of unstructured mesh. Even so, i do not think that the degree of irregularity that you are facing(based on the images) would significantly affect your results. Perhaps you are using a different mesh for the thermal and stress analysis? If that is the case, I suggest you use the same mesh for the stress analysis by copying the design scenario over from your thermal analysis.

 

Regards

Ilyas

Please use plain text.
Member
Nefertari_Amy
Posts: 5
Registered: ‎01-17-2013

Re: Problem about mesh

01-21-2013 02:41 AM in reply to: ilyas

Dear Ilyas,

 

Actually I use the same mesh. I just copyed the design scenario from your thermal analysis. And there is another reason cause me to think about the problem is mesh is that when I try different mesh setting the results will become totally different. I do not know the reason why. You can see from the picture on the following. In this case, I have a hole in the middle of this part.

Mesh setting Left: model:smileytongue:ercentage 120%, for the orange part: absoult size: 0,1mm

Mesh setting Right: model:smileytongue:ercentage 100%, for the orange part: absoult size: 0,1mm

chip3.PNGchip4.PNG

Please use plain text.
Distinguished Contributor
ilyas
Posts: 139
Registered: ‎06-13-2012

Re: Problem about mesh

01-21-2013 10:48 AM in reply to: Nefertari_Amy

Hmm. Perhaps there is something wrong with the mesh matching between parts.

Can you share your model?

Please use plain text.
Member
Nefertari_Amy
Posts: 5
Registered: ‎01-17-2013

Re: Problem about mesh

01-22-2013 01:48 AM in reply to: ilyas

Hi Ilyas,

 

I think so. On the following is my model. In fact the structure of it is very simple. But the thickness of the middle part is very thin and I guess that should be the problem during no matter mesh or stress analysis.

 

model.PNG

Please use plain text.
Distinguished Contributor
ilyas
Posts: 139
Registered: ‎06-13-2012

Re: Problem about mesh

01-22-2013 01:55 AM in reply to: Nefertari_Amy

:smileyhappy: What I meant was, can you share the archived analysis file? Refer to the link below for a guide to archiving and posting the analysis file.

 

http://forums.autodesk.com/t5/Autodesk-Simulation-Mechanical/Create-Post-or-Provide-an-Archive-of-yo...

 

 

Please use plain text.
Member
Nefertari_Amy
Posts: 5
Registered: ‎01-17-2013

Re: Problem about mesh

01-23-2013 02:22 AM in reply to: ilyas

Hi ilyas,

I have created the archive but it is still too large, it is above 2M (about 3,3M) .Would you like to give me your email address and I can send it to you ?

Please use plain text.