Discussion Groups

Robot Structural Analysis

Reply
Valued Mentor
tony.ridley
Posts: 652
Registered: ‎09-07-2011
Accepted Solution

Problem with calculation nodes

1359 Views, 4 Replies
01-10-2013 07:23 PM

Hi guys,

 

I'm getting large (220kNm) moment in bracing!

error in bracing moments.JPG

 

It seems that the moment is coming from shear in the beam crossing almost mid brace;

shear in beams.JPG

 

 

Calculation nodes are being applied at the intersection of diagonal members which it should not be doing. Where members 492 and 493 intersect 106

additional calc nodes.JPG 

 

 

The settings are not turned on to allow this.  So it seems strange calculation nodes appear. 

calc nodes settings.JPG

 

 

When I copy the 3 members to a sub-model and re-analyse, the problem goes away. 

 

Can you guys explain why the forces are being transferred through calculation nodes that should not be there?

 

Model attached in private message. 

 

Cheers,

Tony

Please use plain text.
Valued Mentor
tony.ridley
Posts: 652
Registered: ‎09-07-2011

Re: Problem with calculation nodes

01-10-2013 08:02 PM in reply to: tony.ridley

Update,

I did the CTRL+A and paste into a new model trick.  This did not stop the problem.  The only thing that made the problem go away was adding the bracing members to the "Bars neglected in generation" list. 

 

Cheers,

Tony

Please use plain text.
Product Support
Artur.Kosakowski
Posts: 4,597
Registered: ‎12-17-2010

Re: Problem with calculation nodes

01-11-2013 01:15 AM in reply to: tony.ridley
  The only thing that made the problem go away was adding the bracing members to the "Bars neglected in generation" list. 

 

and this is what should be done as the vertical/horizontal intersection includes also vertical/horizontal  to avoid intersection of the horizontal cladding with diagonal bars

 

If you find your post answered press the Accept as Solution button please. This will help other users to find solutions much faster. Thank you.

 



Artur Kosakowski
Please use plain text.
Valued Mentor
tony.ridley
Posts: 652
Registered: ‎09-07-2011

Re: Problem with calculation nodes

01-11-2013 03:37 AM in reply to: Artur.Kosakowski

Artur,

 

Sorry, I disagree with your answer and also your screen capture.  

I set up two system with same load, one has perpendicular members, one has angle of 135deg

 

Picture 1 - Setup

setup.JPG

 

See results below;

 

Picture 2 - With "normal" settings

shot 1.JPG

 

 

 

Picture 3 - calculation nodes

shot 3.JPG

 

 

 

Picture 4 - With both diagonal and vertical intersection checked ON.

shot 2.JPG

 

 

 

By your explanation, picture 2 should show bending moment on ALL 4 bars.  I only ever get bending moment on 3 of them.  I use this as one of the first examples I do when teaching people how to use Robot.  I have NEVER had diagonal bracing form a connection with a horizontal member UNLESS I turn on the checkbox to achieve it.

 

Regards,

Tony

Please use plain text.
Product Support
Artur.Kosakowski
Posts: 4,597
Registered: ‎12-17-2010

Re: Problem with calculation nodes

01-11-2013 06:58 AM in reply to: tony.ridley

Tony,

 

I'm sorry my mistake. Of course it should be the intersection with the cladding (498). I will remove the attachment and update my previous answer so that nobody gets wrong information any more.



Artur Kosakowski
Please use plain text.