Revit MEP

Reply
Contributor
tbrown6608
Posts: 16
Registered: ‎03-07-2012
Message 1 of 5 (258 Views)

Piping snapping to reference planes

258 Views, 4 Replies
03-13-2012 01:30 PM

I have a branch of piping at 9'-4" and I when try to drop the pipe to 0'-4" by typing in the offset and hitting apply it draws the pipe down to a reference plane in a linked architectural model which is at -6'-0" from the current level. All the piping is referencing the same level, there is no piping in the area this could be auto-connecting to, reference planes are shut off in the view even. I can not find any difference in this project from other projects in my office where this does not happen. If anyone has any ideas on what could be causing this and how it can be fixed it would greatly appreciated.

*Expert Elite*
CADastrophe
Posts: 3,117
Registered: ‎08-28-2009
Message 2 of 5 (246 Views)

Re: Piping snapping to reference planes

03-14-2012 06:18 AM in reply to: tbrown6608

Is your current Work Plane set to the correct Level? Home tab » Set Work Plane.

Corey D.                                                                                                                  ADSK_Logo_EE_2013.png    AutoCAD 2014 User  Revit 2014 User
──────────────────────────────────────────────────────────────────────
⁞|⁞ Please use Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos as appropriate to further enhance these forums. Thank you!
Contributor
tbrown6608
Posts: 16
Registered: ‎03-07-2012
Message 3 of 5 (244 Views)

Re: Piping snapping to reference planes

03-14-2012 06:58 AM in reply to: CADastrophe

Yes, the work plane was set to the correct level.

 

I've been experiementing with this and it seems if I draw the horizontal pipe and drop in the same chain in comes in right, but if I break the chain or if the horizontal pipe is already there and I try to draw just the drop the pipe drops down a lot further than I want it to. It seems the way for me to get around this is to drag the pipe back a foot or so and then draw the pipe horizontal first then drop it. This is still a pain as it is tedious to do this for hundreds of pipe drops. Any other ideas?

*Expert Elite*
CADastrophe
Posts: 3,117
Registered: ‎08-28-2009
Message 4 of 5 (240 Views)

Re: Piping snapping to reference planes

03-14-2012 07:16 AM in reply to: tbrown6608

Does it happen to be exactly one foot off? There was a post a day or two ago vaguely describing the same problem. He got by adjusting the offset to compensate for the one foot differential. I just tested and verified this behavior (RMEP 2012) - works this way with ductwork, too. And it only occurs when it's offset downward. Maybe this is a bug...

Corey D.                                                                                                                  ADSK_Logo_EE_2013.png    AutoCAD 2014 User  Revit 2014 User
──────────────────────────────────────────────────────────────────────
⁞|⁞ Please use Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos as appropriate to further enhance these forums. Thank you!
Contributor
tbrown6608
Posts: 16
Registered: ‎03-07-2012
Message 5 of 5 (237 Views)

Re: Piping snapping to reference planes

03-14-2012 07:57 AM in reply to: CADastrophe

This seems similiar but I think its a different problem. When I choose to drop the pipe to 0'-4" it actually drops the pipe to -6'-0 3/8". But it only does this when the horizontal pipe I drop from is already there. If I create the horizontal pipe and drop in the same chain of command it drops to 0'-4" like I want it to. This has got to be some sort of bug but the strange thing is it doesn't do it in any of my other 2011 jobs just this one.

 

I just noticed the horizontal pipes offset affects where the vertical pipe ends at. At 9'-8" (which is where it has been) the vertical pipe ends at -6'-0 3/8". At 10'-0" the pipe ends at -5'-8 3/8". At 9'-0" the pipe ends at -6'-8 3/8". So it seems Revit is setting the pipe's center point to be at 1'-9 13/16". No idea why it would do that but I guess it had nothing to do with the reference plane I thought it was snapping to, just a coincidence a reference plane was at that elevation.

 

Don't know if a solution to this will be found as it seems like some sort of glitch/bug but I can get around it by starting the pipe at the bottom elevation and then going up to where I want it to be. Thanks for your help.

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Revit Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Revit helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Revit

Twitter

Facebook

Blogs

Youtube