Revit MEP

Reply
Contributor
BrianAd
Posts: 11
Registered: ‎06-11-2009
Message 1 of 1 (403 Views)

Piping Systems Revit 2012

403 Views, 0 Replies
01-29-2013 05:32 AM

How are plumbing piping systems suppose to work in Revit 2012?  It seems there are various opinions, wants, needs, approaches.  Here is my experience....
 
My current project is a hospital. The core of the hospital is a first floor only with 2 patient wings that are 2 floors - a first floor and a ground floor.  Our mains are routed throughout the hospital only on the first floor.  We route down from the first floor into each patient room on the ground floor.
 
Each patient room consists of a water closet, 2 lavatories, and a shower.  One wing has 15 patient rooms the other wing has 16 patient rooms.  That's a total of 248 plumbing fixtures in the patient rooms alone.  That's a lot of plumbing fixtures to connect to one system.  That's not even counting the break rooms and other specialty rooms per wing, nor is it counting the core of the hospital.
 
In my test I piped each patient room individually without connecting to the mains and named the system in relation to the patient room number they are feeding.  Example, Pat Room 1025 has 2 systems, CWater 1025 and HWater 1025.  These show up in the system browser under their respective system type.
 
Piping=>
   Domestic Cold Water=>
      CWater 1025=>
         Fixture 1
         Fixture 2
      HWater 1025=>
         Fixture 1
         Fixture 2
 
With all the rooms piped up individually, ready to connect to the mains, my production speed is tolerable.
 
I then start connecting each branch pipe into the main and as I go around each patient wing making these connections I watch each individual system disappear and get added to one single system.  After all the branch piping is connected I end up with only one system.  It's usually the system I use to make my first connection.  So if I use CWater/HWater 1025 to make the first connection to the mains, all systems thereafter become CWater/HWater 1025.
 
The problem I have after this is that my production speed falls into quick sand, it now takes more than twice the amount of time to connect a pipe and or delete a connected pipe.  It can take upwards of 10 secs just to add a little 1/2" tap off that's 2' long, and god forbid if you misclick due to the slowness, then it's another 10 secs just to undo the mistake and another 10 secs to make the tap again.
 
The other route that I attempted was to create a new Piping System under "Families" in the Project Browser.  I can create a new Piping System for each patient room but that is extremely inefficient.  So either I'm doing something wrong or my expectations of Revit are way to high.
 
I'm not interested in creating separate models for different systems and my computer is more than adequate to run Revit.

Is anyone else experiencing the extreme "lag" of Revit after adding a numerous amount of fixtures to a system ?

Why can't I easily keep systems separate to reduce this "lag" ?

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Revit Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Revit helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Revit

Twitter

Facebook

Blogs

Youtube