Revit MEP

Posts: 256
Registered: ‎12-27-2007
Message 1 of 3 (670 Views)
Accepted Solution

Help with Lookup Table

670 Views, 2 Replies
02-19-2013 10:57 AM

I'm trying to create a new parameter and add it to my Lookup Table.  Here is what I'm trying to do, every time I try this, it says "Invalid Input".  What am I missing?


(Adding a Thread Depth parameter to my Elbow - Threaded - MI - Class 150.rfa family.)


  • Open Lookup Table, save as new name.
  • Revise the Lookup Table Name in my Family Types to match the new name.
  • Add new column to new lookup table.  New column header is "ThD##length##millimeters".  Filled in the thread depth for each size of pipe fitting, or in other words, for each nominal diameter size.
  •  Add new parameter to family
          New Family Parameter, named Thread Depth, Instance Parameter, Discipline is Piping, Type of Parameter is Pipe SIze.  Grouped under Dimensions.
  • Add Formula.  This is the part I am unsure of. 

text_file_lookup(Lookup Table Name, "ThD", 0.1 * Nominal Diameter + 1/64", Nominal Diameter)


I think this should work, but it's not.  What am I doing wrong with this formula?




Posts: 256
Registered: ‎12-27-2007
Message 2 of 3 (664 Views)

Re: Help with Lookup Table

02-19-2013 11:43 AM in reply to: norcaljess

Never mind.  I got it. 


If anyone wants to know....


There was nothing wrong with my Formula.  It was directly tied to WHEN and HOW I saved the replacement lookup file.  Even if I thought I was saving over an existing file, for some reason, Revit wasn't seeing that.  So it wasn't updating.  Once I got all of the information that I needed into my lookup file, I saved it as a completely new name, then added the new Lookup File Name to my Family Types, and lastly, added the formula.  Then it worked!



Posts: 3
Registered: ‎10-23-2008
Message 3 of 3 (424 Views)

Re: Help with Lookup Table

03-28-2013 04:59 PM in reply to: norcaljess

I am going crazy getting this to work.   I am trying lookup tables and I keep getting invalid input.  I have gone down to a simple test... 


The csv at the top "Motor.csv"    only has 2 columns... first column which is the driver and 2nd column to be filled in.  Attached is a screenshot of the family.  I just want this to be number values but that wasn't working so I tried changing it to lengths and still nothing. 


Tried doing a save as with a different name and still no go.  Tried closing and re-opening revit after changes and still no. 


Help anyone?

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community

Revit Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Revit helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Revit