Revit MEP

Reply
Distinguished Contributor
Happyunited123
Posts: 140
Registered: ‎03-12-2011
Message 1 of 4 (129 Views)
Accepted Solution

Filter/Symbol problem

129 Views, 3 Replies
04-10-2014 02:24 AM

Hi,

 

I have a detail item to show my light fixture as a symbol. It's all pretty basic, just a few lines with some filled solid regions (white and black fill).

I want this fixture to display a different colour via a filter but when I apply a colour (red in this case) it changes everything that colour, including the white and black fill. How can I prevent this from happening? I need the white bits to stay whote and the rest to change to the filter colour.

 

Thanks in advance for your replies.

 

Symbol with no filter applied

 

Light.JPG

Red filter applied and everything turns red, even the white solid region in the middle!

 

 

light red.JPG

Valued Contributor
ajax05k
Posts: 59
Registered: ‎01-12-2014
Message 2 of 4 (111 Views)

Re: Filter/Symbol problem

04-10-2014 05:53 AM in reply to: Happyunited123
I don't think u will achieve what U want by using filter........ I am not sure but by using pattern maybe u can achieve it
OR
using Decal.
Ajay K. HVAC Designer, BIM Modeler
*Expert Elite*
CADastrophe
Posts: 3,166
Registered: ‎08-28-2009
Message 3 of 4 (106 Views)

Re: Filter/Symbol problem

04-10-2014 06:08 AM in reply to: Happyunited123

Filled Regions are subject to overrides, so the actual fill color doesn't matter if there is a View Filter, System Graphics Override, Phase Graphic Override, etc. forcing it to a specific color. In order to maintain a white region, use a Masking Region instead.

Corey D.                                                                                                                  ADSK_Logo_EE_2013.png    AutoCAD 2014 User  Revit 2014 User
──────────────────────────────────────────────────────────────────────
⁞|⁞ Please use Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos as appropriate to further enhance these forums. Thank you!
Distinguished Contributor
Happyunited123
Posts: 140
Registered: ‎03-12-2011
Message 4 of 4 (99 Views)

Re: Filter/Symbol problem

04-10-2014 07:21 AM in reply to: CADastrophe
Thanks again, worked a treat!

You are not logged in.

Log into access your profile, ask and answer questions, share ideas and more. Haven't signed up yet? Register

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.

Need installation help?

Start with some of our most frequented solutions to get help installing your software.

Ask the Community


Revit Exchange Apps

Created by the community for the community, Autodesk Exchange Apps for Revit helps you achieve greater speed, accuracy, and automation from concept to manufacturing.

Connect with Revit

Twitter

Facebook

Blogs

Youtube